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1 GenStat Discovery Edition 

1.1 What is this guide about? 

This guide is intended primarily for scientists who wish to use GenStat for the 
analysis of their research data.  Most of the examples are taken from the book 
‘Statistical Methods in Agriculture and Experimental Biology’ by Mead, Curnow 
and Hasted1, others come from course material developed by ICRAF and the 
University of Reading. Our primary aim is to teach GenStat, rather than 
statistics. In some chapter however we review some basic statistics and show 
how GenStat Discovery Edition can be used to teach statistics. Nevertheless, 
minimal information is given regarding the data and the interpretation of the 
results. 

Chapter 2 of this guide gives a basic introduction to GenStat and can be considered as a 
tutorial.  It covers data input, some descriptive statistics, calculations and an introduction 
to the command language. Chapter 3 introduces the application of simple statistical ideas 
in GenStat (t-test and simple regression). Chapter 6 is about data organization and 
exploration. Analysis of Variance using GenStat is covered in chapter 8. Examples include 
a simple randomised block, factorial treatment structure and a split plot design. The other 
chapters contain review questions or “challenges”. 

Our main purpose in writing this guide is to provide supporting material for scientists, who 
are on a training course in statistics.  This guide, particularly chapters 1 - 5, may also be 
used for self-study, either within a supervised environment, or for users who have 
experience of other statistical packages.  This guide is not intended for self-study by 
beginners to statistical computing. 

We estimate that the whole of the guide could be covered in a one-day session on a 
training course for those familiar with other statistical software. This session would 
introduce the software and could include a discussion on initial impressions of GenStat at 
the end of the session. On training courses for participants with limited computer skills, 
this guide will take at least 4 days. Such training course could include other exercises with 
additional datasets. Datasets for a course on analysing agroforestry experiments can be 
found at: http://www.worldagroforestrycentre.org/sites/RSU/dataanalysis/index.asp   

All datasets used in the examples and exercises can be found on the CD-rom.  If you read 
this manual in a printed version, the files can be downloaded from the websites of the 
Research Support Unit of the World Agroforestry Centre 
(http://www.worldagroforestrycentre.org/rsu). If you read this as a pdf file, you can open 
the files by clicking on the attachment icon. 

                                                 
1 Roger Mead, Robert N. Curnow, Anne M. Hasted, 2003. Statistical Methods in Agriculture and 
Experimental Biology. Third Edition. Chapman & Hall/CRC. 472 pages ISBN 1-58488-187-9 

http://www.worldagroforestrycentre.org/sites/RSU/dataanalysis/index.asp
http://www.worldagroforestrycentre.org/rsu
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1.2 The origins of the Discovery Edition. 
The version of GenStat described here is the GenStat for Windows Discovery Edition. It is 
based on the Fifth Edition, Service Pack 2 but with the older graphics release 4.1. 

The Discovery Edition and this guide are the result of a unique public-private partnership 
between a software company, research institutes and a development cooperation 
association. Researchers know that effective statistical analysis is an essential part of 
their research and needs high quality software. In developing countries, there is often a 
lack of resources to obtain such high quality software. During a meeting at the GenStat 
User Conference held in Oxford in September 2001, VSN International Ltd., the distributor 
of GenStat, was asked to consider the possibility of giving the software for free to 
researchers in developing countries. At first, VSN International Ltd. was afraid of 
committing commercial suicide. But gradually ideas changed and on 17 October 2003 
GenStat Discovery Edition was officially launched. During a pilot year, GenStat Discovery 
Edition will be freely available to non-commercial users throughout Africa and will be 
distributed with extensive online documentation, guides and training material. This is a 
pilot scheme, which we expect to continue. The edition is supported by the Statistical 
Services Centre (University of Reading, UK), The World Agroforestry Centre (ICRAF, 
Kenya), The International Livestock Research Institute (ILRI, Kenya) and the Biometry 
Unit Consultancy Service (BUCS, University of Nairobi, Kenya). They issue the licenses 
and develop training materials. To provide assistance to initiatives that improve the 
situation of available hard and software in the region is one of the objectives of the project 
“Capacity strengthening in research methods of partners of the World Agroforestry Centre 
(ICRAF) in East and Central Africa. This project is funded by VVOB, the Flemish 
Association for Development Cooperation and Technical Assistance. Distributing free high 
quality software and training materials to non-commercial users through Africa fits very 
well in this project and VVOB funded the development of a website, part of the 
development of this guide and part of the distribution of CDs with the software and training 
materials. 

The latest information on the GenStat Discovery Edition offer can be found on: 
http://www.worldagroforestrycentre.org/GenStatforafrica  

1.3 Configuration. 
The minimum recommended configuration under Windows 98 is a Pentium PC with 32 Mb 
RAM. GenStat is developed by the GenStat Committee of the Statistics Department, 
IACR-Rothamsted, Harpenden, Hertfordshire AL5 2JQ, UK. GenStat is published and 
distributed by VSN International Ltd, Wilkinson House, Jordan Hill Road, Oxford OX2 
8DR, UK (Tel: +44 (0)1865 511245 – Fax: +44 (0)870 1215653 – http://www.vsn-intl.com - 
E-mail: info@vsn-intl.com ). GenStat is a registered trademark of the Lawes Agricultural 
Trust. 

1.4 Acknowledgements 
This manual has been adapted and expanded from the first half of the guide called “Using 
GenStat for Windows, 5th Edition, in Agriculture and Experimental Biology”. This was 
prepared by staff from the SSC, Reading and ICRAF, Nairobi. It was, in turn based on 

http://www.worldagroforestrycentre.org/GenStatforafrica
http://www.vsn-intl.com
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original notes prepared by Gillian Arnold and Ruth Butler for an MSc course run by the 
Department of Agricultural Sciences of the University of Bristol.  We are very grateful to 
them and many others who contributed to earlier versions of this guide. 

Last but not least we wish to express thanks to the GenStat Team for making high quality 
statistical software available for free to users who really need it. The continuation of this 
initiative depends on the provision of feedback by the users.  

1.5 Reference for GenStat Discovery Edition 
The correct citation when referring to GenStat Discovery Edition in a publication is: 

GenStat, 2003. GenStat for Windows. Release 4.23DE Discovery Edition. VSN 
International Ltd., Hemel Hempstead, UK. 
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2 GenStat Basics  

The aim of this introductory chapter is to become familiar with the basics of 
how GenStat for Windows operates. 

In this manual, we sometimes assume a user who already has experience of MS Excel 
since most users will have organised their data in a spreadsheet and MS Excel is 
currently the most widely used spreadsheet.  We show how data entered into Excel 
can be analysed with GenStat and also how data from GenStat can be saved as an 
Excel file. However, experience with Excel is not necessary for using GenStat. 

2.1 Starting GenStat Discovery Edition 

Once GenStat Discovery Edition is installed and you have obtained the free license 
key, you start GenStat Discovery Edition within Windows on a PC by clicking on the 
GenStat icon on the desktop or toolbar or by selecting the GenStat executable, from 
the Programs Menu. If no GenStat icon is available on the desktop, you can create one 
yourself1. 

 

Fig.  2.1 Some of the GenStat windows after start up, also showing several toolbars. 

 

                                                 
1 By default, GenStat Discovery Edition is installed in the folder C:\Program files\GenDisc. Use 
Windows Explorer and go to the subfolder C:\Program files\GenDisc\bin. Right click with the mouse on 
Genwin42.exe and create a shortcut. This shortcut can now be dragged onto the desktop. You might 
rename the icon on the desktop (right click on the icon and click ‘rename’) as GenStat Discovery Edition, 
to avoid confusion with previous or newer versions. 
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After starting GenStat, you see a standard Windows interface (Fig.  2.1) with a title bar, 
menu bar, tool bar, status bar and several windows (Fig.  2.2).  The Output window will 
contain the output from the operations we perform.  The input log keeps a record of 
what has been done in an analysis.  Many of the menus are standard for Windows 
applications. Only Run, Data, Spread, Graphics and Stats are GenStat-specific. 

Below an example is given of the GenStat for Windows interface after a spreadsheet 
has been opened. 

 
Fig.  2.2 Some GenStat windows once data have been entered. 
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2.2 Data input  

2.2.1 Data input using the Spread Menu.  

We show two ways of entering data into GenStat.  The first is with GenStat.  Choose 
Spread ⇒ New ⇒ Blank as in Fig.  2.3. 

Fig.  2.3 Spread => New => Blank Fig. 2.4 Initial size of the spreadsheet 

Choosing Blank brings up a box allowing you to specify how many data columns you 
want, and how many rows of data there will be. Edit the box to make a GenStat 
spreadsheet with 2 columns and 14 rows as shown in (Fig. 2.4). 

Different types of spreadsheet can be made, but the default (i.e. what GenStat will 
select in the absence of any further information) - Vector - is usually the type you will 
need.  Click [OK], and an empty spreadsheet will appear. You can start to enter data 
by clicking in a cell in the spreadsheet. Type the number, and then press the [Enter] 
key. Enter the following numbers into the first column: 

30.7 36.4 35.1 20.6 31.7 31.7 37.1 34.8 25.9 27.3 28 30.6 22.3 14.4
Press the [Enter] key after the last number. The cursor will then move to the top of the 
next column. Enter these numbers into the second column: 

66 147 126 56 93 99 104 103 32 44 67 56 35 26 

Make sure that you press the [Enter] key after typing the final number, 
otherwise the content of the last cell will not be send to the GenStat server. 

If you have made any mistakes, these can be easily corrected, using the arrow keys to 
move to the cell to amend and entering the correct value. 

For each row, the value in the first column is the height of Prunus africana trees in a 
forest in Uganda. The data were measured as part as a research project of ICRAF. The 
value in the second column gives the diameter of the same tree. So the first tree is 30.7 
metres high and has a diameter at breast height of 66 centimetres. 
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It is considered a good data management practice to give a detailed 
description of your data. If you save your spreadsheet leaving the column 
names C1 and C2, some time in the future you will not remember anymore 
what these data were about. Also none of your colleagues is likely to figure 
out the meaning of your data. 

Adding a detailed description in GenStat can be done in several ways: 

- giving a meaningful column name 

- adding extra description to the column 

- giving a meaningful name to the spreadsheet. 

2.2.1.1 Naming colums.  

To change the column names from the default C1 and C2 to something more 
meaningful, position the cursor as shown in the figure Fig.  2.5 below.  It becomes a 
pencil, rather than a hand, and clicking on the mouse gives a popup screen where you 
can type the name for the column, as shown in Fig.  2.6. Then press [OK]. 

Fig.  2.5 Step one in renaming a 
column 

Fig.  2.6 Giving the column a new name. 

 

 

Once you have given column C1 the name “Height”, repeat with C2 with the name 
“DBH” (for “Diameter at Breast Height). These names now appear on the columns of 
the spreadsheet. 

2.2.1.2 Adding extra description. 

Another way of changing the column name is to choose Spread => Column => 
Attributes/Format, see Fig. 2.7, or click in a column and press [F9], or right-click in a 
column and choose Column attributes (Fig. 2.8). 
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Fig. 2.7 Spread => Column => Attributes/Format Fig. 2.8 Right-click for common features 

 

The result in all cases will be a window that gives all kind of information on column 
attributes and the way the column is formatted (Fig.  2.9). Since some of the data have 
one decimal, we could enter 1 in the Decimals box. You can change the name of the 
column but you can especially add extra information in the Description box. The 
description can be maximum 39 characters long. 

Fig.  2.9 Formatting the column attributes 

 

This example also shows a general point when using GenStat, namely that 
there is usually more than one way to call a dialogue. We often find that the 
quickest route is to right-click, but this only gives the most common 
features. 
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2.2.1.3 Naming spreadsheets.  

Use File => Save As to save the file. By default you are prompted to save the file as 
sheet1.gsh in the C:\Program Files\GenDisc\bin folder (Fig. 2.10). Will you one year 
from now still be able to remember what is the content of sheet1.gsh? Or will you be 
able to differentiate it from sheet 453.gsh? 

It is a good practice to choose something meaningful as a file name, for instance 
“Prunus africana height and dbh Mabira Uganda.gsh”. The filename can be anything 
that is acceptable to your computer system. The Windows 2000 Help gives for 
instance: 

A file name can contain up to 215 characters, including spaces. However, it 
is not recommended that you create file names with 215 characters. Most 
programs cannot interpret extremely long file names. File names cannot 
contain the following characters: \ / : * ? " < > |  

So, use long and descriptive names but don’t exaggerate. 

It is recommended to change the working directory (Fig. 2.11). This is the default 
directory where GenStat will save spreadsheets and other file types. The C:/Program 
Files/GenDisc/bin directory is used for executables and drivers, so it is better not to 
mess around in this folder. If you have a D-drive, use Windows explorer to create a 
folder on that drive for your data files. You can even create one folder per project, each 
containing several subfolders. 
Fig. 2.10 Default directory and name 
 

Fig. 2.11 Saving a GenStat spreadsheet with 
an informative name in a directory of your 
choice 

 
 

Now use Run => Restart Session, to clear everything from the memory. To continue 
with the next chapter, minimize GenStat and open MS Excel. 

2.2.2 Data input from Excel worksheets.   

You may already have your data in a spreadsheet like MS Excel. Importing data from 
an MS Excel spreadsheet into GenStat is very easy. 

If you entered your data using another software, you still can browse 
through this section since most procedures will be quite similar. If you are 
not familiar with MS Excel, you can skip this section. 

GenStat can import data from many spreadsheet formats. To know which ones, choose 
Help => Contents and Index and type “spreadsheet” in the Index box (Fig. 2.12), 
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select the “spreadsheet file formats” entry and click [OK]. The resulting help-file shows 
information on all possible file formats as in Fig. 2.13. 

Fig. 2.12 Help => Contents and Index Fig. 2.13 Importing from different 
spreadsheets 

 

We assume you are now in Excel.  Create a new Excel workbook and enter the data 
from Fig.  2.5. In a spreadsheet like Excel you can add extra information in the cells 
above the data as in Fig. 2.14: 

- You can enter a short name for the column. 
- In the row above, you can enter a long name and mention the 

measurement units. 
- One row higher you can add extra information on the experiment. 

Fig. 2.14 Data and descriptive information 
entered into MS Excel. 

 

The extra information is sometimes called “meta-data” and makes it clear what the data 
are about. To import the data into GenStat, you define a named range in Excel. In 
Excel, highlight the range containing the data and the header row and choose Insert 
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=> Name => Define (Fig. 2.15). Give the range a name, for instance Prunusdata (Fig. 
2.16). Then save the Excel workbook and give it a meaningful name, for instance 
“Prunus africana height and dbh Mabira Uganda.xls”. You can also rename the 
worksheet. Right-click on the tab “Sheet 1” and rename it as “Prunus africana” (Fig. 
2.17). Then save the Excel file again. You have now finished with Excel, so minimize or 
close Excel and go back to GenStat. 

 
Fig. 2.15 Defining a named range in Excel Fig. 2.16 Giving the range a sensible name 

 
Fig. 2.17 Naming an Excel sheet 

 

 

In GenStat, choose File => Open and select the Input file (Fig. 2.18). You can indicate 
that the file to import is of the ‘Other Spreadsheet Files’ type. 
Fig. 2.18 GenStat's File => Open, choosing 
spreadsheet file-types 

Fig. 2.19 Choosing to open the range that was 
named in Excel, see Fig. 2.16 

 
 

In the next window, shown in Fig. 2.19, you can select the named range 
“Prunussadata”. The right-hand side of the same window gives various options to 
customize the way data are imported. By clicking [OK], the data are immediately 
imported in a GenStat spreadsheet as shown in Fig. 2.20. 


Prunus africana

		Height and diameter of Prunus africana in Mabira forest Uganda

		Height (m)		Diameter at breast height (cm)

		Height		DBH

		30.7		66

		36.4		147

		35.1		126

		20.6		56

		31.7		93

		31.7		99

		37.1		104

		34.8		103

		25.9		32

		27.3		44

		28		67

		30.6		56

		22.3		35

		14.4		26





Wim Buysse
Double-click to open the MS Excel 2000 file "Prunus africana height and dbh Mabira Uganda.xls"
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Fig. 2.20 Data imported into a GenStat 
spreadsheet 

 

Sometimes people mistakenly import the whole Excel worksheet instead of just the 
named range. The result is a GenStat spreadsheet that cannot be used, as shown in 
the following example. In GenStat, restart the session by selecting Run ⇒ Restart 
Session and then clicking the [Yes] button, to clear all windows, dialogue boxes and 
the spreadsheet. Choose again File => Open and select the Input file “Prunus africana 
height and dbh Mabira Uganda.xls”. This time however, select the worksheet “Prunus 
africana” (Fig. 2.21). The result is a GenStat spreadsheet with 2 columns containing 
text, as shown in Fig. 2.22. By default, GenStat reads the contents of the Excel cells on 
the first row as column headers. Since the cells on the second row contain text, 
GenStat assumes that the whole column contains text and shows a green T next to the 
column header.  
Fig. 2.21 Mistakenly importing a whole sheet 
from Excel into GenStat 

Fig. 2.22 The resulting import includes the 
column names as data 

 

An alternative way of importing spreadsheet data into GenStat is to copy a range of 
cells from Excel and paste it into GenStat.  This is not good practice in data 
management, but is a fast and easy way of doing quick provisional analyses  

Choose Run => Restart Session to clear all data out of GenStat.  Go back into Excel.  
Highlight the range containing the data and column headers, right click with the mouse 
in this range and click Copy or choose Edit => Copy.  Now the data are loaded into 
the Windows clipboard.  Go back to GenStat and choose Spread => New => from 
Clipboard (Fig. 2.23) and the data are entered into a GenStat spreadsheet. 


Prunus africana

		Height and diameter of Prunus africana in Mabira forest Uganda

		Height (m)		Diameter at breast height (cm)

		Height		DBH

		30.7		66

		36.4		147

		35.1		126

		20.6		56

		31.7		93

		31.7		99

		37.1		104

		34.8		103

		25.9		32

		27.3		44

		28		67

		30.6		56

		22.3		35

		14.4		26





Wim Buysse
Double-click to open the MS Excel 2000 file "Prunus africana height and dbh Mabira Uganda.xls"
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Fig. 2.23 Copying data into GenStat from the clipboard 

 

2.2.3 Advanced data input.  

If you are going to transfer data repeatedly from the same external file, it is also 
possible to create links to that file. More information can be found for instance in ICRAF 
Research Support Unit Technical Note 2, available at 
http://www.worldagroforestrycentre.org/sites/RSU/datamanagement/Documents/dupeofduplication.pdf  

2.2.4 Leaving GenStat  

To end a GenStat session, choose File ⇒ Exit. You will be asked if you want to save 
any of the open windows or spreadsheets. Select [No] on all windows and [Exit] 
GenStat. More on saving data in different file formats can be found in chapter 2.3.4. 

As well as showing you how to enter data into GenStat, you have seen how 
easy it is to transfer data from another package, such as Excel. So, if you 
are already familiar with a spreadsheet or another statistical package, using 
GenStat does not has to stop you from using other software.  You can use 
GenStat in addition.  We will show examples from Excel spreadsheets at 
various points in this guide. 

http://www.worldagroforestrycentre.org/sites/RSU/datamanagement/Documents/dupeofduplication.pdf
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2.3 Some basic data manipulation. 

2.3.1 Summary statistics  

Restart the session and reopen the file “Prunus africana height and dbh Mabira 
Uganda.xls”. The data in the spreadsheet are passed into the GenStat server as soon 
as you click anywhere outside the spreadsheet or the spread menu.  Try doing this by 
clicking in the output window. 

Some summary information about the two columns Height and DBH, will appear in the 
output window showing minimum, mean and maximum values, number of values and 
number of those that are missing.  

For further statistical summaries use the Stats menu, as shown in Fig. 2.24.  Choose 
Stats ⇒ Summary Statistics ⇒ Summarise Contents of Variates. Select the 
variates to be summarised, as shown in Fig. 2.25, and then click [OK].   
Fig. 2.24 GenStat's descriptive 
statistics menu Fig. 2.25 The dialogue to display summary statistics

 

Select the Output Window.  If you cannot see this window, try clicking the  or  
buttons in the toolbar successively until it appears. Some of the results are shown in 
Fig. 2.26 below. 


Prunus africana

		Height and diameter of Prunus africana in Mabira forest Uganda

		Height (m)		Diameter at breast height (cm)

		Height		DBH

		30.7		66

		36.4		147

		35.1		126

		20.6		56

		31.7		93

		31.7		99

		37.1		104

		34.8		103

		25.9		32

		27.3		44

		28		67

		30.6		56

		22.3		35

		14.4		26





Wim Buysse
Double-click to open the MS Excel 2000 file "Prunus africana height and dbh Mabira Uganda.xls"
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Fig. 2.26 The default summary statistics 

 

There are other statistics available with the dialogue box shown in Fig. 2.25. Find the 
dialogue box again.  Click on the [Clear] button to clear all currently selected statistics.  
Reselect the variables and choose Arithmetic Mean, Standard Deviation and Standard 
Error of Mean, and click [OK]. 
In the box in Fig. 2.25, you could already have selected to display a histogram, boxplot 
and stem and leaf diagram. A range of other graphs is possible with the Graphics 
menu. Let’s see for instance if there is a relationship between height and diameter. Use 
Graphics ⇒ Point Plot (see Fig. 2.27) and complete the dialogue box as shown in 
Fig. 2.28. This will give the scatterplot from (Fig. 2.29). 
Fig. 2.27 GenStat's graphics 
menu  Fig. 2.28 An x-y plot dialogue 
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Fig. 2.29 Resulting scatterplot in a separate window 

 

 

2.3.2 Calculating and formatting columns.  

It is easy to calculate new variates from those already entered in a GenStat session. 
Choose Spread => Calculate => Column (Fig.  2.30) and select the calculation you 
need and the name of the new variable that you wish to save. 

Fig.  2.30 Menu for the GenStat calculator 

The next example is not the simplest, but illustrates the ease with which calculations 
can be done. Often when measuring trees, you want to calculate the volume. The 
volume of a quadratic paraboloid is often used as an approximation to the volume of 
the tree. The general formula for this is: V= 0.5*g*h with g being the basal area and h 
the height of the tree. 

First select the spreadsheet “Prunus africana height and dbh Mabira Uganda.xls” 
again. Do this, either by clicking somewhere in it (if you can see it), or use the toolbar 
arrow buttons or the Window menu (Fig. 2.31). 


Prunus africana

		Height and diameter of Prunus africana in Mabira forest Uganda

		Height (m)		Diameter at breast height (cm)

		Height		DBH

		30.7		66

		36.4		147

		35.1		126

		20.6		56

		31.7		93

		31.7		99

		37.1		104

		34.8		103

		25.9		32

		27.3		44

		28		67

		30.6		56

		22.3		35

		14.4		26





Wim Buysse
Double-click to open the MS Excel 2000 file "Prunus africana height and dbh Mabira Uganda.xls"
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Fig. 2.31 One way of retrieving the 
spreadsheet 

 

To calculate a new column, choose Spread ⇒ Calculate ⇒ Column as shown in Fig.  
2.30. First we calculate a column with the basal area, given by the formula: 3.1416 * 
DBH/2 * DBH/2. Position the cursor in the large box on top of the calculate window 
before you start typing. You can either type the names of the variables or double click 
on them in the list with the available data. Also type the name of the new column into 
the bottom box labelled Save Result In as shown in Fig. 2.32. 

 
Fig. 2.32 The calculate dialogue Fig. 2.33 The resulting column 

 
 

There is now a new variate, called basalarea, added to the spreadsheet, as shown in 
Fig. 2.33, which holds the 14 values of the basalarea for each tree.  The name is part 
shaded (in yellow on a colour screen) to indicate that the column basalarea is a 
calculated column.  To illustrate the difference between an ordinary and a calculated 
column, try to change a value in the basalarea column.  GenStat gives a warning, see 
Fig. 2.34 below. 

Fig. 2.34 Warning if you try to change a 
value in a calculated column 
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If you are still in the basalarea column, right click on the mouse, and choose the option 
called Column Attributes.  You will see the Column Attributes dialogue. This gives 
details of the basalarea column, including the calculation you used.  

Thus GenStat's spreadsheet is a little like an ordinary spreadsheet in that it 
records the calculation, rather than just doing the transformation.  If you 
change a value in the original column, the derived values do not however 
change automatically.  You could then use Spread ⇒ Calculate ⇒ 
Recalculate, to update the derived values. 

We will do this now, because our calculation contains an error. The diameter of the 
trees was measured in cm, while usually a basal area is expressed in m2. So we have 
to divide each diameter by 200 to get the radius in meters. Meanwhile we can improve 
the calculation by using the operator ** for the exponent. And instead of abbreviating Pi 
as 3.1416, we can use the GenStat command for the constant pi: CONSTANTS(‘pi’). 
The complete formula is shown in Fig.  2.35. 

 
Fig.  2.35 Correcting the calculation Fig.  2.36 The new calculated column 

 

We have the basal area, but we still could add some descriptive information. Right-click 
in the basalarea column and choose Column Attributes or choose Spread => 
Column => Attributes/Format or press [F9]. Add a description and set the number of 
decimals to two, as shown in Fig. 2.37. 
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Fig. 2.37 Description and decimals for the 
calculated column 

Now we can calculate the volume of each tree. Choose Spread => Calculate => 
Column again or choose Window and select Calculate (Fig. 2.38) or click on the 
window list button in the toolbar (Fig. 2.39). The same window with the first calculation 
will open. 
Fig. 2.38 Getting the calculate dialogue back Fig. 2.39 Another way to restore the dialogue 

 

Many dialogue boxes in GenStat do not close when you click [OK]. They 
only close if you click on [Cancel]. This is so you can easily repeat an 
operation, or get more output from the current analysis without having to go 
back through the menus. It is quite easy to get a large number of windows 
and dialogue boxes open at once, so it can be quite hard to find the one for 
which you are looking. Therefore it is a good idea to close a box by clicking 
[Cancel] as soon as it is no longer needed. 

Calculate the volume and format the column as shown in Fig. 2.40 and Fig. 2.41. 
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Fig. 2.40 Calculating the volume Fig. 2.41 Formatting the calculated column 

 

The data values came from 14 numbered trees. It would be useful to have this 
information entered too.  Click in the first column (Height) of the spreadsheet.  Choose 
Spread ⇒ Insert ⇒ Column before Current Column.  This gives a dialogue box 
called Create a new column as shown in Fig. 2.42 below. 
Fig. 2.42 Spread => Insert => Column before 
Current Column 

Fig. 2.43 Making a column with a regular 
sequence 

 

Type treeno in the name box and click on [OK].  A new column will appear in the 
spreadsheet filled with missing values (denoted by *). You could now type in the 
numbers 1 to 14, but there is a quicker way to fill in regular sequences.  

Right click in the Spreadsheet and choose Fill from the popup menu as shown above 
or choose Spread ⇒ Calculate ⇒ Fill.  In the Fill dialogue that is shown in Fig. 2.43, 
make sure that treeno is in the top box.  Clicking [OK] will fill treeno with the numbers 1 
to 14. Fill can also be used to make patterned sequences.  

Details of the use of this, or any other dialogue, can be found by clicking the [Help] 
button in the dialogue box.  

2.3.3 Columns containing factors.  

So far, all the information entered into GenStat has been numerical. It is possible to 
enter textual information as well. One structure that accepts this kind of information is a 
FACTOR. This is a special column used to indicate groups in the data (there will be 
more about factors later in this manual).  

The first seven trees of this data set were measured in the middle of the forest, the 
interior, while the last seven trees grew at the forest edge. Hence the factor will have 
two groups or levels. Here one is labelled Interior and the other Edge. 
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Click in the first column of the spreadsheet (rowno) and choose Spread ⇒ Insert ⇒ 
Column after Current Column.  Type Position into the Name box, and click to select 
Factor under Column Type. The box will change as shown in Fig. 2.44.  

Fig. 2.44 Creating a factor column 

Specify that the factor has 2 levels and then click on the [Labels] button. The dialogue 
shown below appears. Type 'Interior' and press the [Enter] key. The next level (2) will 
become selected. Type 'Edge', press [Enter] and then click [OK] to make the changes 
take effect. 

Click [OK] in the Create a new column dialogue to make the new, column, which 
contains empty cells (see Fig. 2.46). 
Fig. 2.45 Giving labels to factor levels Fig. 2.46 The resulting spreadsheet 

 

Now there are two ways of entering the position: entering ordinals or entering labels. 
Let’s do the first 5 trees using the ordinals. Factor values are stored as ordinals; 
namely as integers between 1 and the number of levels of the factor. In our example 
there are two factor levels, so the ordinals will be 1,1,1,1,1,1,1,2,2,2,2,2,2,2. 

Right-click in the empty Position column and choose Column Attributes. Indicate that 
the factor has to be displayed as ordinals (Fig. 2.47). Now enter 1 for the first 5 trees, 
see Fig. 2.48. 
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Fig. 2.47 Displaying a factor as 
ordinals 

Fig. 2.48 Entering the first level of a factor 

 

Try to enter 3 as Position for tree number 6. GenStat gives a warning that only 1 or 2 is 
possible (see Fig. 2.49). Click [OK] and press [Escape].  
Right-click again in the Position column and choose Column Attributes to give the 
dialogue shown in Fig. 2.47. This time however, indicate that the factor has to be 
displayed as labels. We had entered the factor labels already, so after clicking [OK], 
the position of the first five trees is shown as Interior. Now you can continue entering 
the values. You can enter ‘Interior’, ‘interior’ or even just the first letter ‘i’ and GenStat 
will show the correct factor label ‘Interior’. Enter ‘e’ for trees 8 until 14 as shown in Fig. 
2.50. 

Fig. 2.49 Attempt to enter an illegal 
value in a factor column 

Fig. 2.50 Entry of data into a factor column using the 
labels 

 
 

As long as you type the right first letter of the Factor label, GenStat will 
display the correct label. If you type the wrong letter, GenStat will give you 
a message and ask you to retype your entry.  Double clicking gives a pop-
up menu that lists the allowable levels; see Fig.  2.51. 
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Fig.  2.51 Popup menu to indicate the allowed 
factor labels 

 

The Position column can be used to label a graph. Choose Graphics ⇒ Point Plot => 
Single XY type. Fill in the boxes as below, and click [Finish]. If you first click [Next] in 
Fig. 2.52, you can add titles to the graph and the axes. 
Fig. 2.52 Graphics => Point Plot => Single 
XY Fig  2.53 Colours in graph for different levels 

 
 

In the screen plot, the points from the two groups will be coloured differently, but both 
will be plotted as X.   

In the GenStat Discovery Edition (based on GenStat for Windows 5), only an older 
version of the graphics editor is available (GenStat 4.1 Graphics). You can add a 
general title and a title to the X and Y axis, add an arrow to the axes and change the 
tick marks. But that’s basically it. In GenStat for Windows from version 5 SP2, also a 
new graphics editor is available, with many more possibilities (changing an existing 
graph, different symbols and colours, zooming, rotating, many more file formats, …). In 
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chapter 6.3 we will show some ways to work around the limitations of the GenStat 4.1 
Graphics editor.  

In the Discovery Edition, graphs can be saved in 3 different formats by choosing File 
=> Save as: 

- *.gmf – GenStat Meta File. This is the default GenStat graphics format. 
You can reopen a GenStat Meta File in GenStat and send it to other 
GenStat users. You will not be able to insert a gmf file as a picture in 
MS Word. 

- *.bmp – Bitmap File. In this file format, graphics are stored as pixels. It 
can only be used on the Windows platform. File compression is not 
supported so bmp files are usually large. 

- *.emf – Enhanced Meta File. This is another graphics file format for the 
Windows platform, the successor of wmf (Windows Meta File) format. In 
the Meta file format, graphics can be stored both as bitmap (pixels) or 
as vector format (commands like “draw line”). Emf is only supported on 
Windows 95 and higher. Not all software supports emf, but MS Word 97 
or later can import it. 

If you want to create a temporary graph that you will only use in GenStat, choose the 
*.gmf format. If you want to include a picture in a Word document, choose the *.emf 
format. For other purposes, use the bmp format. In the graphics editor you can change 
the pixel size (Options => Change Bitmap Size). If you want to make really 
impressive graphics, it’s however better to use GenStat version 7 or another software. 

 
Fig. 2.54 Saving a graph as bitmap file 

 

You leave the GenStat Graphics Window by choosing File ⇒ Exit from the menu bar. 

Earlier, you used Stats ⇒ Summary Statistics ⇒ Summarise Contents of Variates 
to give some summaries of the data.  Now, with the data in two groups, it is useful to 
give the summaries for each group individually.  The dialogue used in Fig. 2.25 can be 
used for this, but a more general alternative is Stats ⇒ Summary Statistics ⇒ 
Summaries of Groups (Tabulation) to give the dialogue shown in Fig. 2.55. 
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Fig. 2.55 The tabulation dialogue Fig. 2.56 Summary statistics for each factor level 

 

 

Complete the dialogue as shown and press [OK].  The results as shown in Fig. 2.56 
appear in the Output Window. 

Save the spreadsheet before continuing 

2.3.4 Saving data from GenStat to Excel.  

In chapter 2.2.1.3 on page 10 we saw already how to save a spreadsheet. By default, a 
Window appears asking to save the data as a GenStat spreadsheet (*.gsh). This is 
particularly useful if backward compatibility with older GenStat versions is wanted. But 
a wide range of other file formats is also available. 

In chapter 2.2.2 it was shown how data could be imported from an Excel worksheet. 
We had imported the file “Prunus africana height and dbh Mabira Uganda.xls” from 
Excel. We will reopen this file and calculate the basal area again. Since we did all 
calculations in the GenStat spreadsheet “Prunus africana height and dbh Mabira 
Uganda.ghs”, the Excel spreadsheet only contains 2 colums Height and DBH. So, first 
choose Run => Restart Session, indicating [Yes] to clear all data from the GenStat 
memory, open the Excel file and calculate the basal area. Refer to chapter 2.3.2 if 
necessary. 

This time we want to save the spreadsheet as an Excel file. Choose File => Save. 
Fig. 2.57 Add to the Excel file Fig. 2.58 A new Excel sheet is added 

 
 

The result is a warning message, shown in Fig. 2.57. When you click [Overwrite], all 
existing worksheets in the workbook “Prunus africana height and dbh Mabira 


Wim Buysse
Double click to open the GenStat spreadsheet "Prunus africana height and dbh Mabira Uganda.gsh"
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Uganda.xls” will be deleted and the data will be saved in a worksheet called GenStat 
Data. By clicking [Add], the existing worksheets will be kept and a new worksheet 
GenStat Data will be added to the Excel file, Fig. 2.58. If you repeat this, new 
worksheets will be added: GenStat Data, GenStat Datb, GenStat Datc, … 

2.3.5 Importing factors from Excel.  

If you import data from Excel that contain factors, they are treated slightly differently. In 
our example, Interior was the first factor level or ordinal and Edge was the second. If 
you import a column containing the factors “Interior” and “Edge” from Excel, Edge 
would have an ordinal of 1 and Interior an ordinal of 2. The reason is that Excel reads 
factors from Excel in alphabetical order.  

2.3.6 Deleting data.  

Before proceeding we delete the column, called treeno to show the difference between 
deleting a whole column and deleting its contents.  

First we select the column. Click in the name field; click in the column and press 
[Alt]+[Ctrl]+C; or choose Spread ⇒ Select ⇒ Current Column. Clicking again will 
deselect the column. Once selected, you might think that the [Delete] key should 
delete the column.  If you press the [Delete] key, only the data disappear, the column 
remains!  Use Edit ⇒ Undo Del Cells or press [Ctrl] + Z to get the data back (Fig. 
2.59). 

To delete the whole column, with the cursor in the column choose Spread ⇒ Delete ⇒ 
Current Column.  You still can recover the column choosing Edit ⇒ Undo Del Col or 
by pressing [Ctrl] + Z (Fig. 2.60).  You can also select one, or more, rows and delete 
them in the same way.  

 
Fig. 2.59 Undoing the deletion of cells Fig. 2.60 Undoing the deletion of columns 
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2.4 Understanding how GenStat works.  

2.4.1 Available variables.  

Close the spreadsheet with the Prunus africana data. You can do this by choosing File 
=> Close, by pressing [Ctrl]+[F4] or by clicking on the button with a diagonal cross in 
the top right hand corner of the spreadsheet. Once closed, do you think the data are 
still in GenStat? 

Fig. 2.61 Closing a GenStat spreadsheet 

 

The answer is yes. Because the GenStat you see is a Windows interface that sends 
commands to a program running in the background: the Genstat Server. When these 
commands are processed, the message in the GenStat status bar shows what is 
happening and the GenStat icon in the Windows Taskbar changes from green (Fig.  
2.62) to red (Fig. 2.63). However, when working on small datasets it goes so fast that 
you will not be able to see it.  

Fig.  2.62 The taskbar with the GenStat server 
ready 

Fig. 2.63 The GenStat server icon changes to 
red when the server is busy 

 

So, even if you don’t see anything, there can be still all kinds of data somewhere in the 
GenStat server. You can check which variables are currently available to the GenStat 
server using Data ⇒ Display or pressing the [F5] key and clicking for instance on “All 
Data”.  

Fig. 2.64 List of all the variables in the GenStat server 
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This lists the names of the structures and their types as shown in Fig. 2.64. 
All structures used so far are variates (Height, DBH, basalarea, volume, 
treeno) and factors (Position), but later on you will use other types of 
columns too.  This is also a useful dialogue box from which you can delete 
columns when they are no longer needed. 

Click [Close] to close the Display dialogue box. See chapter 2.4.3 for information on 
how to clean the GenStat Server of data. 

2.4.2 A first introduction to the GenStat command language.   

So, GenStat is basically a standard Windows application running on top of the GenStat 
server. GenStat existed long before Windows was created and in the old days you had 
to know the "language". You simply typed commands, which you submitted to GenStat.  

The menus in the GenStat Discovery Edition are based on an underlying command 
language, ‘GenStat release 4.2’, see Fig. 2.65. Release 4.2 means it is based on the 
4th major revision of the GenStat Server that has undergone 2 minor revisions. The 
Discovery Edition itself is based on a slightly modified GenStat for Windows fifth 
edition.  

You can still use GenStat by typing commands in the Input Window as we show now. 
At the same time, we show how GenStat is used as a calculator. 

Fig. 2.65 Details about GenStat 

Restart GenStat.  Use File ⇒ New ⇒ Text Window as shown in Fig. 2.66. This gives 
you an Input Window.  In this window, type Print 3+4 as shown in Fig. 2.67. 
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Fig. 2.66 Opening a text window Fig. 2.67 Typing a GenStat command 

 

Now select the Run menu (Fig. 2.68). You can choose either Submit Line (if the 
cursor is still on the line you typed) or Submit Window. Choose one of these. 
Fig. 2.68 Submitting commands to GenStat Fig. 2.69 The results are in the output window 

 

 

You have now submitted your "program" of commands to the GenStat server. The 
results are put in the Output Window.  

You can go to the output window in various ways, e.g. by using the Windows menu.  
There you see that GenStat normally "echoes" the command and shows you that 
3+4=7. 

The Windows version of GenStat gives you a variety of ways of submitting calculations 
to the GenStat server.  An alternative to the above is to use the Data menu: Data ⇒ 
Calculations as shown in Fig. 2.70. 
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Fig. 2.70 Data => Calculations Fig. 2.71 Using the calculate dialogue 

 

Then type 3 + 4 as the function, click on Print in Output and then on [OK]. If you look 
in the Output window, you see that 3 + 4 still equals 7 (Fig. 2.72). 
Fig. 2.72 And yes: 3 + 4 still is 7 Fig. 2.73 The input log 

 

The Input Log Window is also useful.  It keeps a record of all the commands you have 
submitted, see Fig. 2.73.  Access it for instance by choosing Window ⇒ Input Log.  
You see that the use of the Calculation menu has resulted in GenStat preparing the 
commands PRINT 3+4 for you and has submitted them to the GenStat server. 

So, that is how GenStat works. You prepare commands, which are submitted to the 
GenStat server. The Windows version has simply given you a variety of ways of 
helping you prepare the commands for GenStat. GenStat obeys the commands and 
puts the results in the Output Window. It keeps a record in the Input Window. 

If the commands produce graphs, then GenStat puts the graphs in a Graphics 
Window.  If you make a mistake in the command, it prints an error message in the 
Fault Window (and in the Output Window).  

The example above (3 + 4 = 7) indicates that GenStat may be used as a simple 
calculator. This is worth a little practice.   It is useful to have a scientific calculator.  Also 
it is sometimes useful to transform data.  For example, if you want to calculate the 
difference between 4.35 and 2.37 expressed as a percentage of 4.35, open the 
calculator with Data ⇒ Calculations, check that Print in Output, is still ticked and 
type the following calculation in the top box: 

100 * (4.35 -2.37) / 4.35 

Click [OK]. This will give the following in the output window: 
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  (100*(4.35- 2.37))/ 4.35 

    45.52 

i.e. the difference is 45.52% of 4.35. 

It is important that the brackets () are included where appropriate to make sure that the 
calculation has only one meaning.  

Try more calculations to see how this works, using both an Input window and the Data 
⇒ Calculations dialogue box.  

The symbols +, -, *, / are used for the operations of addition, subtraction, multiplication 
and division respectively and ** is used for powers.  There are also various 
mathematical functions available.  One is for calculating the square root of a number.  
The function is SQRT(), where the number whose square root is required is given in 
the parenthesis, for example SQRT(12.37).  The following table gives an overview of 
how to perform some calculations by using the Input Window.  More information can be 
found in the GenStat Help file under ‘List of functions for expressions’. 

 

 

Some basic calculations using the Input Window 

Symbol Operation Example Result 

+ addition PRINT 3+4 7.000 

- subtraction PRINT 3-4 - 1.000 

* product PRINT 3*4 12.00 

/ division PRINT 3/4 0.7500 

** exponentiation PRINT 3**4 81.00 

Function Operation Example Result 

SQRT(x) Square root PRINT SQRT(4) 2.00 

EXP(x) Exponential function PRINT EXP(1) 2.718 

LOG(x) natural logarithm of 
x, for x > 0 

PRINT LOG(2.718) 0.9999 

LOG10(x) logarithm to base 10 
of x, for x > 0. 

PRINT LOG10(10) 1.000 

ROUND(x) rounds the values of 
x to the nearest 
integer. 

PRINT 
ROUND(1.234) 

1.000 

Other examples Result 

PRINT (1/2) 0.5000 

PRINT (100*(4.35 -2.37))/4.35 45.52 

PRINT CONSTANTS(‘pi’) 3.142 

PRINT CONSTANTS(‘e’) 2.718 
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By default, GenStat will show three decimals in the Output Window when using the 
PRINT command, or PRINT directive in the GenStat terminology. To increase this you 
have to add a parameter to this directive. 

PRINT CONSTANTS(‘pi’); DECIMALS = 10 

will give you 3.141592654 in the Output Window. 

Most of the time however, you will perform calculations in a spreadsheet as was seen 
in chapter 2.3.2 above. Once you become experienced in using GenStat, you could 
alternatively do calculations only in the GenStat server, using the Data ⇒ Calculations 
menu, rather than the Spread ⇒ Calculate ⇒ Column route that you used earlier. 
The result is the same to the GenStat Server, but you would not automatically see the 
calculated column in a spreadsheet. 

2.4.3 Server sessions.  

After trying several of the above calculations, the Input and Output Windows look a 
mess. All the data can be cleared out of the GenStat server with Data ⇒ Clear All 
Data or Run ⇒ Restart Session.  Less drastically, you can clear the output window by 

clicking the ‘Clear Output’ button (  ) in the toolbar. 

Input as well as Output Windows can be saved (make the window active by clicking in 
it and click File => Save As).  You can save the Input Window as a text file or as a 
‘GenStat file” (*.gen). In this way, you can load the commands in the Input Window 
again for another, similar, analysis.  The Output Window can be saved as a text file or 
as an ‘Output file’ (*.out).  This is useful to save the results of an analysis for 
comparison with other results or for reporting.  Saving a selection of input and output 
files of critical analyses also contributes in establishing an audit trail. 
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3 Simple statistical ideas 

The main purpose of chapter 2 was to introduce GenStat. Chapter 2 can be 
considered as a tutorial. In this and the following chapters we still show how 
GenStat Discovery Edition operates but we also review some basic 
statistics and show how GenStat can be used to teach statistics. Most of 
the examples are taken from Mead, Curnow and Hasted1. For more 
information on the statistical aspect of the examples, see the relevant 
section in that book or refer to any other introductory text.  

3.1 First some more data manipulation: appending spreadsheets  
In the analysis so far, we have just considered descriptive statistics. Thus we have 
summarised the data numerically and drawn graphs. In the next chapters we introduce 
ideas of simple statistical inference. However, first we introduce some more data 
manipulation. 

We take an example from Mead, Curnow and Hasted, pages 36 and 42. 
This compares 6 observations from a new variety of wheat that have 
following yields (tons/ha): 

new:  2.5  2.1  2.4  2.0  2.6  2.3 
with 10 observations from the standard variety: 

standard: 2.2  1.9  1.8  2.1  2.1  1.7  2.3  2.0  1.7  2.2 

Because these columns are of different lengths, they are entered into two separate 
spreadsheets. For the first set, use Spread ⇒ New ⇒ Blank as shown earlier in 
chapter 2.2.1 (page 7).  Set it to have 1 column of 6 rows, enter the data and give the 
column the name new. 

Save the spreadsheet, giving it a meaningful name as was seen in chapter 2.2.1.3 on 
page 10, for instance “Wheat variety new.gsh”.  Then use Spread ⇒ New ⇒ Blank 
again.  Change the number of rows to 10 and enter the second set of data into this 
other spreadsheet, naming the column as standard.  Save the spreadsheet, giving it 
another name, for instance “Wheat variety standard.gsh” (see Fig.  3.2). 

                                                 
1 Roger Mead, Robert N. Curnow, Anne M. Hasted, 2003. Statistical Methods in Agriculture and 
Experimental Biology. Third Edition. Chapman & Hall/CRC. 472 pages ISBN 1-58488-187-9 


Wim Buysse
Double-click to open the GenStat spreadsheet "Wheat variety new.gsh"


Wim Buysse
Double-click to open the GenStat spreadsheet "Wheat variety standard.gsh"
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Fig.  3.1 Spreadsheets for wheat yields Fig.  3.2 Naming the spreadsheets 

 

 

Data often need reorganising before analysis and here this step is 
illustrated by joining the data together from the two sets.  

What we wish to do is to append the data from the two columns and add a 
further column that specifies from which set each observation has come.  

If the spreadsheets are no longer in GenStat then they will have to be opened. They 
were saved earlier with the names ‘Wheat variety new.gsh’ and ‘Wheat variety 
standard.gsh’ (Fig.  3.1).  

Fig. 3.3 The spreadsheet 'Wheat variety 
standard.gsh' is the active window. 

Fig. 3.4 The append dialogue box. 

 

 

Click in the spreadsheet Wheat variety standard.gsh, so it is the active window (Fig. 
3.3). Use Spread ⇒ Manipulate ⇒ Append and complete the dialogue as shown in 
Fig. 3.4, i.e. append Wheat variety new.gsh to the data in Wheat variety standard.gsh. 
We also specify that a factor column with the name variety will be used to distinguish 
between the two sets of data, and that the second level of the factor will get the name 
‘new’. Press [OK]. 


Wim Buysse
Double-click to open the GenStat spreadsheet "Wheat variety new.gsh"


Wim Buysse
Double-click to open the GenStat spreadsheet "Wheat variety standard.gsh"
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Fig. 3.5 The resulting spreadsheet after the 
append operation. 

Fig. 3.6 The final spreadsheet after some 
renaming. 

 

The resulting spreadsheet is as shown in Fig. 3.5 above. This latter form of the data is 
more common and is used in most of the remainder of this guide. 

Now it is just a matter of cleaning up to get the spreadsheet as in Fig. 3.6 

- Change the label of the first factor level from Original to standard. (see ) 
- Rename the column with the variables from standard to yield. (see 

chapter 2.2.1.1) 
- Save the spreadsheet as ‘wheat yield.gsh’. (see chapter 2.2.1.3) 

So, you have the data in the GenStat server shown in Fig. 3.7  and Fig. 3.8. 

Fig. 3.7 The visible spreadsheets Fig. 3.8 The available data in 
the GenStat server 

 


Wim Buysse
Double-click to open the GenStat file "wheat yield.gsh"
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3.2 Visual data exploration.  

3.2.1 Boxplots. 

One way to present the data is to use a boxplot. It is always useful to explore data 
before carrying out any statistical test. This way you know what to expect and can 
discover anomalies. Use Graphics => Boxplot. When the data are organized in two 
separate spreadsheets (like “Wheat variety new.gsh” and “Wheat variety 
standard.gsh”), complete the dialogue as shown in Fig. 3.9 and click [Finish]. When 
the data are organised as a single variate with groups in one spreadsheet (in “wheat 
yield.gsh”), complete the dialogue as shown in Fig. 3.10. This gives the graphs in Fig. 
3.11. 

Fig. 3.9 Graphics => Boxplot when the data 
are in several variates 

Fig. 3.10 Graphics => Boxplot when the data 
are organised as one variate with several 
groups 

 

Fig. 3.11 The resulting boxplots 
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So, our visual impression is that the yield of the new variety is generally higher than the 
yield of the standard variety although there is some overlap. A formal statistical test has 
to confirm this, but first we go a bit deeper into boxplots. 

3.2.2 Median and quartiles.  

A boxplot is the graphical representation of a 5-number summary of a 
dataset: minimum, Q1, median, Q3, maximum.  

The middle value of data arranged in ascending order is called the median. When 
there is an even number of observations, the median is the average of the two middle 
values. Half the observations are smaller and half of the observations are larger than 
the median.  

- 2/)1(

~

+= nxx  (n = odd) 

- 2/)( )12/()2/(

~

++= nn xxx  (n=even) 

The median of the yield of the standard variety is (2.0 + 2.1)/2 = 2.05. 

yield 1.7 1.7 1.8 1.9 2.0 2.1 2.1 2.2 2.2 2.3 

rank 1 2 3 4 5 6 7 8 9 10 

The value of the median is not influenced by extreme values nor does it change when 
the data are skew or bimodal.  

Quartiles divide the data into quarters: 

- 1st quartile = Q1 = 25 % of the observations are smaller, 75 % are 
bigger 

- 2nd quartile = Q2 = median 
- 3rd quartile = Q3 = 75 % of the observations are smaller, 25 % are 

bigger 
Calculation of the quartiles2: 

- Q1 = median of the group of observations below the median. Q1 of the 
standard wheat yield = 1.8 

- Q3 = median of the group of observations above the median. Q3 of the 
standard wheat yield = 2.2 

The difference between Q3 and Q1 is the interquartile range (IQR). It is a measure of 
the spread of the data. It is not sensitive for extreme values. The IQR of the standard 
wheat yield = 0.4. 

Median and quartile are special cases of percentiles. Generally, the pth percentile is a 
value whereby p % of the observations are lower than this value and (100 – p) % are 
higher. In GenStat Discovery Edition, percentiles are called quantiles. 

There are several routes in GenStat of calculating median, quartiles and quantiles. One 
possibility is through the Stats => Summary Statistics => Summarize Contents of 
Variates menu. Fig. 3.12 shows the dialogue boxes when the 5-number summary is 
made for two variates while Fig. 3.13 shows this for one variate with groups. The 
results can be found in the Output Window. 

                                                 
2 If the whole data set has an odd number of observations note that there are two ways of calculating the 
quartiles. GenStat excludes the median from the calculations of Q1 and Q3 while some other authors 
include the median in both calculations. 
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Fig. 3.12 Calculating the 5-number summary 
for data from two variates 

Fig. 3.13 Calculating the 5-number summary 
for data from one variate with two groups 

 

 

For variates containing groups, also Stats => Summary Statistics => Summaries of 
Groups (Tabulation) can be chosen. Here you need to enter the quantile percentage 
points yourself. In the Quantile Percentage Point box of Fig. 3.14, enter the quantile 
percentage points for lower quartile, median and upper quartile (25, 50, 75). Clicking 
[OK] will give the results in the Output Window while clicking on the [Save] option (Fig. 
3.15) will give you the possibility to save the summary statistics in several tables. The 
resulting tables are given in Fig. 3.16. 

Fig. 3.14 Stats => Summary Statistics => 
Summaries of Groups (Tabulation) 

Fig. 3.15 Saving the summary statistics in 
several tables 
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Fig. 3.16 The resulting tables with minima, maxima, lower quartile, median and upper quartile 
per factor level 

 

Finally, it is also possible to use commands as was introduced in chapter 2.4.2 (page 
29). For instance, submitting the following line: 

QUANTILE  standard,new 

will return the 5-number summary of the variates new and standard in the Output 
Window (Fig. 3.17). 

Fig. 3.17 The output of the QUANTILE 
procedure 

 

 

3.2.3 The use of boxplots.  

Ä Comparing groups 
Boxplots are a useful tool to compare groups of data. In  Fig. 3.11 for instance, it 
looked as if the yield of the new variety is higher than the yield of the standard variety. 
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There is however some overlap and remember the scale we are working with 
(minimum value is 1.7 tons/ha, maximum value is 2.5). A formal statistical test has to 
confirm the difference, but if this test shows completely different results to the graph, 
we know something is wrong. 

Ä Outliers 
Another use of boxplots is to show outliers.  Go back to the spreadsheet and insert a 
value of 2.9 instead of 2.0 for the 8th value in the Standard group. Don’t forget to press 
[Enter] after changing the value or the GenStat server will not be updated.  The 
general shape of the graph is the same, but the odd value is indicated as deserving 
close scrutiny. There are now two ways to display the boxplot. Instead of using 
Graphics ⇒ Boxplot and immediately clicking [Finish], click [Next].  You can choose 
now between two types: Box and Whisker and Schematic. The advantage of a 
schematic boxplot is that you can easily discover outliers. 

 

Fig. 3.18 Box and Whisker plot Fig. 3.19 Schematic boxplot with outlier 
marked 

 

 

In a Box and Whisker boxplot, the ends of the whiskers mark the minimum and 
maximum values of the data set; in a schematic boxplot they mark the ‘upper and lower 
inner fence’. The upper inner fence is defined as the maximum data value that is still 
smaller than the upper quartile plus 1.5 times the interquartile range; or the maximum 
value if this is less than upper quartile plus 1.5 times the IQR. The lower inner fence is 
defined similarly. Extreme values outside 1.5 and 3 times the interquartile range are by 
default marked as green crosses. More extreme values (more than 3 times the above 
mentioned range) are marked as red crosses. 

Ä Shape of distribution 
A boxplot gives an idea about the shape of the distribution, although you can also 
get this information from other plots (histograms and QQ-plot). Fig. 3.20 shows a 
boxplot from data from a normal distribution symmetric around 0. One observation can 
be considered as an outlier.  Fig. 3.21 shows a histogram of the same data. 
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Fig. 3.20 Boxplot for normally distributed data 
(one outlier) 

Fig. 3.21 The corresponding histogram for 
normally distributed data (one outlier) 

 

In Fig. 3.22 we show an example based on a real world dataset of a skew distribution 
with a long tail of high outliers. 50 % of the observations have a value between 0 and 8 
but the largest value is 106. 

Fig. 3.22 Boxplot for skew data Fig. 3.23 The corresponding histogram for 
skew data 

 

Before continuing, set the value of the standard wheat variety you changed back to 2.0. 
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3.3 Hypothesis testing.  

Some of the examples we use are taken from “Confidence and Significance: Key 
Concepts of Inferential Statistics” from the Statistical Services Centre of The University 
of Reading, published in 2001. It can be downloaded from 
http://www.ssc.rdg.ac.uk/develop/dfid/booklets.html This booklet also contains more 
information on the statistical concepts.  

3.3.1 Testing a hypothesis about the population mean.  

The first example comes from this booklet. A researcher facilitates an on-farm trial to 
study the effect of using Tephrosia vogelii as a green manure for soil fertility 
restoration. She claims the use of the manure will increase pigeon pea yields 
measured as pod weight. In the trial pigeon peas are grown with and without the 
Tephrosia in two plots on each of eight smallholders’ fields and the values recorded are 
the differences in pod weights between plots (kg/plot): 

3.0 3.6 5.4 -0.4 -0.8 4.2 4.8 3.2 

Our null hypothesis is that there is no difference in pod weights. We test this against 
the alternative hypothesis that there is a difference. 

plot
kgH 0:0 =µ  

plot
kgH 0:1 ≠µ  

We first enter the differences in pod weight in a new spreadsheet and save it as 
podweight.ghs shown in Fig. 3.24 and we carry out some summary statistics. To carry 
out a t-test we need the mean and the standard error as given in Fig. 3.25. 

Fig. 3.24 The spreadsheet with differences in 
podweight 

Fig. 3.25 Some summary statistics in the 
Output Window 

 

 

The general formula for this one sample t-test is: 

t = (estimate – hypothesised value)/ standard error of the estimate 

In the example this becomes: 

t = (2.875 – 0)/0.81 = 3.55 and we have to compare this with the  t-distribution of 7 
degrees of freedom. 

In GenStat, choose Stats => Statistical Tests => T-Test and fill in the dialogue 
window as in Fig. 3.26 

http://www.ssc.rdg.ac.uk/develop/dfid/booklets.html
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Fig. 3.26 The t-test dialogue box Fig. 3.27 The results of a t-test in the output window 

 

The results of the T-Test can be seen in the Output Window (Fig. 3.27). The p-value is 
0.009, so if the null hypothesis is true (no differences in mean pod weight), then we 
have less than a 1 % chance to get the sample we have. This is not impossible. It is 
however so unlikely that we declare the result to be statistically significant and we 
reject the null hypothesis. 

In the Output Window, we also find the 95 % confidence interval of the mean. This 
range is highly likely (95 % chance) to contain the true population mean. So, based on 
our sample, it is very likely that the average difference in pod weight between pigeon 
peas grown with Tephrosia and those not grown with Tephrosia is somewhere between 
0.96 kg/plot and 4.79 kg/plot. The general formula for this 95 % confidence interval of 
the mean is 

( )xestx fd .... ×±  

 

3.3.2 Comparison of samples.  

We will use the example of the wheat yield again. Choose Run => Restart Session to 
clear all data from the GenStat server. Open the spreadsheet in the file ‘Wheat 
yield.gsh’. 

In the boxplot in Fig. 3.11, it looked as if the yield of the new wheat variety is higher 
than that of the standard variety. We have reasons to believe this is true because the 
new variety was designed to produce higher yields. Our hypothesis is that the mean 
yield of the new variety is higher than the yield of the standard wheat variety. We will 
now do a formal statistical test. In this case, we will use ‘t’ test of two independent 
samples. 

We rephrase our hypothesis as a set of null hypothesis and alternative hypothesis: 

0:
tan0 =−µµ newdardsH  

0:
tan1 ≠−µµ pooleddardsH  

For this t-test, the general formula is:  

t = (estimated mean of first sample – estimated mean of second sample)/(standard 
error of difference of the means ) 


Wim Buysse
Double-click to open the GenStat spreadsheet "wheat yield.gsh"
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The calculations necessary to perform the test depend on two assumptions: 

- both samples come from normally distributed populations 
- both populations have the same variance 

Because of this last assumption, we can combine the two sample variances to give a 
better estimate of the variance in the two populations. This pooled variance is 
calculated as: 
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The standard error of the differences of means is then: 
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It is possible to get the necessary summary statistics (Fig. 3.28) and calculate the 
pooled variance (Fig. 3.29) of 0.0502143. This can then in turn be used to calculate a  
t-value of -2.59253 (not shown). This t-value has to be compared with the t-distribution 
with 14 degrees of freedom (n1 + n2 – 2 = 6 + 10 – 2) that can be found in most 
statistical textbooks. 

Fig. 3.28 The necessary summary statistics Fig. 3.29 Calculating the pooled variance 

 

 

This was the hard way that could be of use when teaching statistics but it is of course 
easier to let the software do all the work. Choose Stats => Statistical Test => T-test, 
select in the Test box the Two-sample (unpaired) test and make sure you indicate the 
data consist of one set with groups as in Fig. 3.30. If you prefer to work with both 
“Wheat variety new.gsh” and “Wheat variety standard.gsh”, proceed as in Fig. 3.31. 


Wim Buysse
Wheat variety new.gsh


Wim Buysse
Wheat variety standard.gsh
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Fig. 3.30 Comparing two samples when there 
is one variate with two groups 

Fig. 3.31 Comparing two samples when there 
are two variates 

 

The results of the test are given in the Output Window. 

***** Two-sample T-test ***** 

  

    Sample     Size       Mean       Variance 

    standard   10         2.000      0.04667 

    new        6          2.300      0.05600 

  

*** Test for equality of sample variances *** 

  

    Test statistic F = 1.20 on 5 and 9 d.f. 

  

    Probability level (under null hypothesis of equal variances) = 
0.76 

  

*** Test for evidence that mean of yield with Variety = standard 
is unequal to mean with Variety = new *** 

  

    Test statistic t = -2.60 on 14 d.f. 

  

    Probability level (under null hypothesis) p = 0.021 

  

    95% Confidence Interval for difference in means: (-0.5477, -
0.05234) 

If the null hypothesis is true (both population means are equal), then we only have a 
chance of about 2 % to find the samples we found (p-value is 0.021). So we can reject 
the null hypothesis and decide that there is a statistically significant difference between 
the two sample means. 

What else do we find in the Output Window ? First we find some summary statistics, 
next we see the results of an F-test, then the t-test and finally the 95 % confidence 
interval for the difference in means. 



GenStat Discovery Edition for everyday use 
 

 
 48 

By default, GenStat gives an F-test for equality of sample variances, because this was 
one of the assumptions we used to perform the t-test of two independent samples. 
However, this F-test only performs well if the distributions of the populations are close 
to the normal distribution.  

The general formula for the 95% confidence interval of differences in means is given 
by: 

...221 21
destxx nn ×±− −+  

So, based on our samples, it is very likely that the standard wheat variety will produce 
on average 0.05 to 0.55 tonnes/ha less than the new wheat variety. 

If necessary, some of the results in the Output Window (for instance this F-test) can be 
suppressed by changing the options of the t-test. After choosing Stats=>Statistical 
Tests=>T-test, click on the [Options] button (Fig. 3.32). 

Fig. 3.32 Comparing two samples when there 
is one variate with two groups 

 

3.3.3 Paired t-test. 

In the above example, we compared two independent groups. In this example we will 
perform the test on paired data. The example comes from Confidence and 
Significance: Key Concepts of Inferential Statistics (Statistical Services Centre, 
University of Reading, 2001) page 17 (data on page 14). The x and y values represent 
the tensile strength of rubber samples collected from two plantations (x and y) on 10 
occasions. The aim was to see whether the two plantations differed in the quality of 
their rubber samples. 

Occasion X Y 
1 174 171 
2 191 189 
3 186 183 
4 199 198 
5 190 187 
6 172 172 
7 182 179 
8 184 183 
9 200 199 
10 177 176 
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1. Introduction 


In this guide we review the basic concepts of estimation and hypothesis, or 
significance, testing.  Our aim is to discuss the key ideas of statistical inference in a 
way that is easy to understand.  These are topics we would usually like to assume, 
when discussing or giving courses on data analysis for researchers.  However, we 
often find the ideas are poorly understood and this lack of understanding contributes to 
the scepticism felt by some scientists of the role of statistics in their work.  You could 
use the following three questions to decide whether you need to read further. 
 


  True False Not 
sure 


1. The standard deviation and the standard error 


are both used to summarise the spread of the 


data 


❒ ❒ ❒ 


2. The 95% confidence interval for the mean is 


the interval that covers roughly 95% of the 


observations.  


❒ ❒ ❒ 


3. If the difference between the effects of two 


farm management practices is not statistically 


significant, the conclusion is that there is no 


difference between them.   


❒ ❒ ❒ 


If you have confidently replied false to the three questions above you may have little 
need to read this guide.  Question 1 is discussed in Section 3, Question 2 in Section 4 
and Question 3 in Sections 5 and 6. 


For simplicity, we use “artificially small problems” to illustrate the ideas.  In Sections 
2 to 6 we cover the basic ideas of estimation, namely standard errors, confidence 
intervals, and hypothesis testing procedures.  In the later sections we apply the ideas.  
We outline the way in which the sample size can be chosen.  We also give our views 
on the role of non-parametric methods and on the implication of performing many 
tests on the interpretation of p-values.  One reason that these two contentious issues 
are included is that they sometimes sidetrack training courses and discussions of other 
topics, because of researchers’ strongly held views. 


The general concept of statistical modelling is introduced in the final section of this 
guide.  This provides a link to our other guides on analysis, and particularly to the one 
called Modern Methods of Analysis. 
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2. Applying Estimation Ideas 


Estimating characteristics of a population of interest, from a sample is a fundamental 
purpose of statistical work, whether the activity is a survey, an experiment or an 
observational study. 


Point estimation arises when a quantity, calculated from the sample, is used to estimate 
a population value. The sample estimates of the population mean ( µ ) and standard 
deviation (σ ) are most often taken as the sample mean, x , and the sample standard 
deviation, s, where 


 /x x n= ∑  


and ( ) ( )( )2
/ 1s x x n= − −∑  respectively. 


For example, consider estimating the average maize production per farmer among (the 
population of) smallholder farmers in a selected agro-ecological region.  To do this, 
suppose a sample of 25 farmers is randomly selected and their maize yields are 
recorded.  The average of the resulting 25 yields are calculated, giving say 278 kg/ha.  
This value is then taken as the estimate of the average maize production per farmer in 
the selected region.  It estimates what one would expect for an individual farm.  
Similarly the sample standard deviation is an estimate of the amount of variability in 
the yields from farm to farm. 


Other estimates of the population mean are possible.  For example, in many surveys 
the observations are not sampled with equal probability.  In this case we might use a 
weighted mean ˆ /x wx w= ∑ ∑  instead of x , with weights, w, that compensate for the 


unequal probabilities. 


Proportions can also be estimated, for example we may wish to estimate π, the 
proportion of families who own their own land, or the proportion of respondents who 
indicate support for community co-management of neighbouring forest areas during a 
semi-structured interview.  Then we might use p = m/n, as the estimate, where m is the 
number of persons making a positive response out of the n who were interviewed.  For 
example, if m = 30, out of n = 150 interviews, then we estimate the proportion as  
p = 0.2, or 20% 


As a point estimate this is the same as a measurement, x, where x = 1 if community co-
management was supported and zero otherwise.  The estimate, p is then the same x , 
given earlier, despite the “data” originally being “non-numeric”.  Much qualitative 
material can be coded in this way. 
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If we have a contingent question, a follow-up only for those who “qualify” by 
supporting co-management, we might find, for instance, k = 12 out of the m = 30 who 
are prepared to play an active role in co-managing forest reserves.  Arithmetically,  
r = k/m = 12/30 = 0.4 has the form of a proportion, but it is actually the ratio of two 
quantities which might both change if another sample of size n is taken in the same 
way from the same population.  If the follow-up question is important, then we must 
ensure that the original sample is large enough that there are an adequate number of 
respondents who qualify (here there were 30) for the precision required of the study. 


Sometimes our main objective is not to estimate the mean.  For example, in 
recommending a new variety of maize to farmers we may wish to ensure that it gives a 
better yield, compared to the existing variety for at least 90% of the farmers.  One way 
to proceed is first to calculate the difference in yields for each farmer.  If, from 
experience, or from our sample, we can accept a normal model, i.e. that the 
population of yield differences has approximately a normal distribution, then the 
required percentage point is found (from standard statistical tables) to be 1.28µ σ− , 
where µ  is the mean difference and σ  is the standard deviation of the differences. 


In this case we can still use our estimates of µ  and σ  to estimate the required 
percentage point, or any other property.  In general we call the (unknown) quantities 
µ  and σ  the parameters of the model.  If we assumed a different probability model 
for the distribution of the yields, then we would have to estimate different parameters.  
The formulae would change, but the ideas remain the same. 


If, in the example above, we were not prepared to assume any distribution, then we 
could still proceed by merely ordering the differences in yields for each farmer and 
finding the value exceeded by 90% of the farmers.  This is a non-parametric solution 
to this problem and we return to this approach in Section 7.  Generally this approach 
requires more observations than a “parametric” or “model-based” approach, such as 
that in the preceding paragraphs. 


For reference later we explain the term degrees of freedom.  This is roughly “pieces 
of information”.  For example, with the sample of 25 farmers we discussed earlier we 
have a total of 25 pieces of information.  In any study it is usually important to have 
sufficient pieces of information remaining to estimate the (residual) spread of the 
population.  In our simple example the spread is estimated by s, and in the formula we 
divided by (n–1).  This is because the spread is being measured about the sample 
mean, x .  The sample mean is one of our 25 pieces of information, so we have n–1 or 
24 degrees of freedom left to estimate variability. 
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3. Standard Errors 


When something is estimated, it is important to give a measure of precision of the 
estimate. 


The measure of precision of an estimate is called the standard error of the estimate.  
The smaller the standard error, the greater is the precision of our sample estimate.  Thus 
a small standard error indicates that the sample estimate is reasonably close to the 
population quantity it is estimating.   


As an example, suppose we select a random sample of 12 farmers (n = 12) and measure 
their maize yields per hectare, we might find x  = 1.5 tons/ha and s = 0.6 tons.  Then our 
estimate of µ  is given by x  = 1.5 tons and its standard error (s.e.) is given by the 
formula  


  s.e. = s/√n . 


In this case it is 0.6 / √12 = 0.17 tons/ha.  


From the above formula it is clear that we get precise estimates either because the data 
have small variability (i.e. s is small) or because we take a large sample, (i.e. n is 
large).  For example, if, instead we had taken a larger sample of 108 farmers that had 
given rise to the same mean and standard deviation, then the standard error of the mean 
would have been 0.058.  Equally, if yields had been less variable at s = 0.2 tons/ha then 
with 12 farmers, we would also have had an s.e. of 0.058.  


Depending on the investigation, we are often interested not so much in means, but in 
differences between means (e.g. differences in mean yield).  In simple situations - where 
there is equal replication of the treatments and n replicates per treatment - the standard 
error of the difference between two means is  


( )s.e.d. 2 /s n=  


i.e. about one-and-a half times the standard error of each individual mean. 


The formulae for the standard error of a proportion or a ratio that were considered in 
Section 2 are more complicated, but the point about precision being related to sample 
size and variability of the data is general.  When the design of the study is complex, 
standard errors cannot be easily computed by “hand” and suitable software is used to 
obtain standard errors for estimates of interest such as treatment differences. 


In this section we have repeatedly mentioned that the data are a random sample from 
the population.  The reason that randomness is important is that it is part of the logic of 
the standard error formulae.  This logic is that, because our sample was collected at 
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random, it is one of many that might have been obtained.  Typically each sample would 
have given a different mean, or in general a different estimate.  The standard error 
measures the spread of values we would expect for the estimate for the different random 
samples. 


The idea of the standard error as a measure of precision can help researchers plan a data 
collection exercise.   In any study, σ  is the unexplained, or residual, variation in the 
data; and an effective study is one that attempts to explain as much of the variation as 
possible.  Continuing the example above, we might find that the farmers use four 
different production systems, thus giving us two components of variation.  There is 
variation between one production system and another, and there is variation between the 
farmers within a production system.   


Suppose the overall variation of the yields, ignoring the different production systems, is 
estimated as s = 0.6 tons/h while the within production-system variability is s = 0.2 
tons/ha.  If we were planning a new investigation to estimate average maize production 
we could either ignore the fact that there are different production systems and take a 
simple random sample from the whole population, or we could take it into account and 
conduct a stratified study.  The standard error formula shows us that in this instance we 
would need nine times more farmers in the simple random sample compared to the 
stratified study to get roughly the same precision.  


The guide on Informative Presentation of Tables, Graphs and Statistics describes how 
the standard error is used in the reporting of the results.  The next section of this guide, 
which is on confidence intervals, shows how the standard error is used to describe 
precision.  The width of a confidence interval is often a simple multiple of the 
standard error.  
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4. Confidence Intervals 


The confidence interval provides a range that is highly likely (often 95% or 99%) to 
contain the true population quantity, or parameter that is being estimated.  The 
narrower the interval the more informative is the result.  It is usually calculated using 
the estimate (see Section 2) and its standard error (see Section 3). 


When sampling from a normal population, a confidence interval for the mean µ  can 
be written as  


    ±    ×  s.e.( )x t x  


where 1nt −  is the appropriate percentage point of the t-distribution with (n–1) degrees 
of freedom.   (See Section 2 for a brief explanation of degrees of freedom) 


The 95% confidence interval is commonly used, for which t-values are 2.2, 2,1 and 2.0 
for 10, 20 and 30 degrees of freedom.  So we can usually write that the 95% 
confidence interval for the mean is roughly: 


  2  s.e.( )x x± ×  


The example in Section 3 involving 12 farmers gave x  = 1.5 tons with s.e. = 0.17.  
The 95% confidence interval for µ  is therefore about 1.16 to 1.84 tons/ha; and so we 
can say that that this range is likely to contain the population mean maize yield.  (The 
exact 95% interval, which one can get from a statistical software package, is 1.12 to 
1.88 tons/ha.) 


More generally, for almost any estimate, whether it be a mean, or some other 
characteristic, and from almost any population distribution, we can write that the 95% 
confidence interval is roughly 


  estimate ±2 × s.e.(estimate)  


Hence it is useful that statistical software routinely provides the standard error of 
estimates.  With the example of Section 2 of p = 30/150 = 0.2, or 20% of the 150 
farmers the standard error is about 0.03, resulting in a confidence interval of about 
0.14 to 0.26. 


Note what a confidence interval is and is not.  A 95% confidence interval does not 
contain 95% of the data in the sample that generated it; very approximately the interval 
x  ± 2s would do that.  This is sometimes called a prediction, or tolerance interval.  In 
our examples of 12 or of 108 farmers above, with x  = 1.5 tons and s = 0.6 tons, this 
interval is 0.3 to 2.7 tons/ha and we would say that most of the farmers have yields in 
this range. 
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Users often confuse the confidence interval for the mean with an interval containing 
most of the data because the objectives of the study often relate to parameters other 
than the mean.  This was considered briefly in Section 2. 


In our example above, the 95% confidence interval for the mean is 1.12 to 1.88 tons 
with the sample of 12 farmers.  With more data, this interval would be narrower as is 
seen by comparison with the confidence interval for a sample with 108 farmers, where 
the same calculations as above give a 95% interval for the mean of about 1.4 to 1.6 
tons. 


When the assumptions about the data may not be quite right, scientists may feel they 
ought to abandon the ordinary confidence interval and use some different procedure 
altogether.  Usually it is more constructive to proceed instead by using the usual 
method, but noting that the true coverage of the “95%” confidence interval may not be 
exactly 95%.  For most purposes, the 95% figure is used to provide a conventional 
measure of uncertainty about an estimate, rather than the basis for decision-making.  
The communication of the approximate magnitude of the uncertainty is usually more 
important than the exact value. 
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5. Hypothesis Testing 


5.1 A Simple Example 


For good reasons, many users find hypothesis testing challenging; there is a range of 
quite complex ideas.  We begin with a simple example.   


A researcher facilitates an on-farm trial to study the effect of using Tephrosia as a 
green manure for fertility restoration.  She claims the use of the manure will increase 
pigeon pea yields, i.e. pod weight.  In the trial pigeon peas are grown with and without 
the Tephrosia in two plots on each of eight smallholders’ fields and the values 
recorded are the differences in yields.   


We test the correctness of this claim.  In this case the “null hypothesis” is usually that 
the true mean increase, µ  = 0.  By the “true” mean increase we mean the increase for 
the population of farmers of which we assume our eight are a random sample. 


The alternative hypothesis is usually that the true mean increase is other than zero. 


The null hypothesis is often given, as here, quite explicitly, with the alternative 
hypothesis being vague.  This is for two reasons: 


(i) Standard statistical tests calculate the probability of getting a sample as extreme 
as the one observed, assuming the null hypothesis is true – this calculation has to 
be done using explicit values for the parameter(s) of the null hypothesis 
distribution; 


(ii) Hypothesis testing adopts the same legal presumption of “innocence until proven 
guilty”.  This is that the null hypothesis that µ  = 0 is to be kept, unless the data 
values are inconsistent with it. 


Textbooks often distinguish between one-sided and two-sided tests.  In this example 
we might consider the test of the null hypothesis, that µ  = 0, against the one-sided 
alternative that µ  > 0, on the assumption that there is no logical reason that the 
manure will decrease yields.  Usually a one-sided test merely halves the significance 
level, so what was significant at 4% with a two-sided test, becomes significant at 2% 
with a one-sided alternative.  As will be seen below, we are not keen for readers to 
become too attached to a particular significance level, so halving a value is not 
important enough for users to spend much time on this idea.  One-sided tests are also 
rarely found in realistic situations, such as those introduced later in this guide. 
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Example 1 


Suppose in the illustration above, the differences in pod weight (in kg) between 
“treated” and “untreated” plots were as follows. 


3.0 3.6 5.4 −0.4 −0.8 4.2 4.8 3.2 


A computer analysis of these data would look like: 


 
Test of mu = 0 vs mu not = 0 
 
Variable          N      Mean     StDev   SE Mean 
podweight         8     2.875     2.290     0.810 
 
Variable             95.0% CI            T      P 
podweight     (   0.959,   4.791)     3.55  0.009 


 


The t-test used to investigate the hypotheses follows the general formula: 


  (estimate – hypothesised value) / s.e.(estimate) 


Here we are interested in the mean difference in pod weight, so our test statistics is: 


  ( ) ( )0 /s.e.t x x= −  


  i.e. (2.87 – 0)/0.81 = 3.55 


By comparison with the 7t  distribution, a value as extreme as 3.55 has a probability 
0.009, i.e. less than 1 in 100, of occurring.  So, if the null hypothesis is true, then there 
is a chance of just less than 1 in 100 of getting the sample we found.  Either something 
unlikely has occurred or the null hypothesis is false.  This event is sufficiently unlikely 
that we declare the result to be statistically significant and reject the null hypothesis. 


In Section 4 on confidence intervals we used a “t-value” of 2 to give approximate 95% 
confidence intervals.  Similarly we find here that values larger than 2 are extreme, (at 
about the 5% level of significance) and hence cast doubt on the hypothesised value. 


5.2 Understanding Significance 


The classical argument is that we should approach this type of decision-based testing 
in an objective way, by pre-setting the significance level, or p-value at which we 
would choose to reject the null hypothesis.  If we were working to a significance level 
of 5%, or p = 0.05, we would reject it at the 5% level and report that p < 0.05.  Rather 
than following such a stringent approach, we recommend that decisions be made on 
the grounds that a p-value is low. 
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Example 2 


We have the same hypothesis as in Example 1, but suppose we collected a slightly 
more variable sample.  The data values might be: 


3.0 3.6 6.8 −1.6 −2.0 5.8 7.1 0.3 


Computer analysis of these data gives the following results. 


 
 
Test of mu = 0 vs mu not = 0 
 
Variable          N      Mean     StDev   SE Mean 
podweights        8      2.87      3.64      1.29 
 
Variable             95.0% CI            T      P 
podweights    (   -0.17,    5.92)     2.23  0.061 
 


 


The standard error of the mean is now larger than in Example 1, and we get a t-statistic 
of 2.23 with a probability of 0.061.  If we used the 5% level as a strict cut-off point, 
then we would not reject the null hypothesis.  This does not mean we accept the null 
hypothesis as “true” and users who write as if it does are showing a serious weakness 
of interpretative skills.  The probability of getting such a sample under a hypothesis of 
no effect is still low so there is some suggestion of a treatment effect, but not low 
enough to meet our criterion at the 5% level. 


Here there is insufficient weight of evidence to draw a conclusion about a difference 
between the treatments.  Had a sample of 16 observations been collected, with the 
same mean and standard deviation as above, the standard error of the mean would 
have been lower (at 0.91) and consequently the t-statistic higher (at 3.15).  This would 
have been significant with a p-value of 0.007. 


Note that if hypothesis-testing is undertaken because a real decision is being made – to 
accept or reject a new variety, for example – not rejecting the null hypothesis may be 
tantamount to accepting the pre-existing variety.  This is not the same thing as 
accepting that the null hypothesis is correct. 


Generally, scientific research does not involve such cut-and-dried decision 
alternatives.  The main purpose of significance testing may just be to establish that an 
expected effect (“research hypothesis”) can be discerned and plausibly shown; not just 
to be a quirk of sampling.  Very tiny effects can be significant if sample sizes are very 
large; a significant effect also needs to be large enough to be of practical importance 
before it is “significant” in the ordinary-language use of the term.   
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Conversely, a non-significant effect does not necessarily imply that an effect is absent.  
A non-significant result can also happen if the sample size is too small or if there is 
excessive variability in the data.  In either of these cases, the effect may in fact be 
present but the data is unable to provide evidence-based conclusions of its existence.  


Such considerations show it is usually more informative to produce a confidence 
interval rather than just the decision outcome and p-value of a hypothesis test.  In 
example 1 above, the 95% confidence interval for the mean is given by 0.96 to 4.79 
using the method of calculation shown in Section 4.  This indicates that the true mean 
increase of 0 kg is unlikely, because the 95% confidence for the true mean does not 
contain the hypothesised value. 


Given a calculated t-value or other test statistic, it was traditional to compare this with 
a 5%, 1%, or 0.1% value in statistical tables.  However, since many statistical 
packages compute exact p-values, results may be accompanied by statements such as 
(p = 0.028) giving a specific numerical figure for the degree of extremeness of the 
disparity between observed results and null hypothesis expectation.  This approach is 
preferable where possible.  It is more informative and easier to interpret. 


5.3 General Ideas 


In a few studies, the objectives of the study correspond to standard hypothesis (or 
significance) tests.  The examples in the previous section provide one scenario and the 
adoption of a new farming practice, instead of a standard, is another. 


Usually however, the hypothesis testing is just a preliminary part of the analysis.  Only 
rarely can the objectives of a study be met by standard significance tests.  The 
statistically significant result provides objective evidence of something interesting in 
the data.  It serves as a “passport” to further analysis procedures.  Confidence intervals 
or an economic analysis are then used to describe the nature and practical importance 
of the results.   


When results are “not-significant” it may indicate that nothing further need be done.  
Often it enables a simpler model to be used.  For example if there is no evidence of a 
relationship between education level and adoption of a new innovative technology, 
then the adoption can be studied using all respondents together.  If there were a 
relation then it might indicate the necessity for a separate analysis (i.e. a separate 
model) for each education level group. 
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5.4 Recognising Structure 


Example 1 above illustrates how a t-test is conducted using differences between plots 
from eight smallholder farms.  The differences were used because a pair of plots was 
available from each farm.  This led to a paired t-test. 


Suppose on the other hand, we had 16 farms, each with just one plot, and eight were 
selected for trying out the “treatment”, with the remaining farms forming the 
“controls”.  The analysis then involves the comparison of two independent samples. 


It is important to recognise the structure in the data when conducting the analysis.  As 
an example, we show below what is often lost if truly paired results are treated like 
independent samples.  Here the x- and y-values represent the tensile strength of rubber 
samples collected from two plantations X and Y, on 10 occasions.  The aim was to see 
whether the two plantations differed in the quality of their rubber samples.   


 


i 1 2 3 4 5 6 7 8 9 10 Mean S.D. 


xi 174 191 186 199 190 172 182 184 200 177  185.5 9.687 


yi 171 189 183 198 187 172 179 183 199 176  183.7 9.764 


di 3 2 3 1 3 0 3 1 1 1  1.8 1.135 


 


The difference in the two means is 1.8.  For the unpaired analysis the standard error of 
this difference is calculated using the standard deviations in the last column, and found 
to be 4.3, leading to a non-significant t-value of 0.41.  The correct strategy of a paired 
analysis uses the differences in the table above.  The standard error of these 
differences is 0.36, leading to a highly significant t-value of 5.0. 


The reason for the difference is that in the unpaired analysis, the occasion-to-occasion 
variation in the samples is included in the calculation of the standard deviations used 
in the two-sample t-test.  Not eliminating this variability means the small but 
systematic differences between the pairs are not detected.  The unpaired analysis is 
unnecessarily weak where true and effective pairing exists.  In general this paired 
structure is similar to the idea of blocking in experiments and stratification in surveys, 
and needs to be properly accounted for in any subsequent data analysis. 
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6. Sample Size 


One common question that is posed to statisticians is how large a sample is needed.  
To be able to answer this type of question for an experiment or survey, information 
must be given on (1) how small a difference is it important to detect, and (2) how 
variable will the observations be for the key response(s) of interest.  This variability is 
usually reflected in the residual standard deviation of the data, because it is the 
unexplained variation of the data that relates to the precision of our data. 


These two elements are needed for the sample size to be evaluated, otherwise a 
statistician could not be expected to rubber-stamp the corresponding study as being 
adequately planned to achieve a formal objective.  This does not deny the importance 
of exploratory or pilot-studies, where the aim is to generate or specify hypotheses, or 
to evaluate a proposed methodology for the future. 


One reason for considering hypothesis tests is that their simplicity provides a basis for 
the evaluation of many sample size calculations.  This involves the power of the test, 
i.e. the probability of correctly rejecting the null hypothesis when it is false.  If your 
sample size is sufficient, then you will have a high power to detect a difference that 
you regard as being important.  


Modern statistical packages, such as Minitab, incorporate extensive facilities for 
sample size or power calculation. There are also specialist packages, such as nQuery.   
It is probably easier to improve ones “feel” for power or sample size calculations 
through hands-on use of a package than from a demonstration. 


As an example we take the paired t-test considered in Section 5.3.  Suppose that our 
aim is to choose the sample size, i.e. how many samples we need for a similar study.  
We suppose that the value of s will be about the same as before, that is about 1.1 and 
that we would like to detect a mean difference in tensile strength of rubber between 
the two plantations, of more than 1 unit with probability 0.95, i.e. we look for a power 
of 0.95.  Further, we suppose the test is to be conducted at the 5% level.  Putting these 
conditions into Minitab gives a required sample size of 18 units.   


If this is too many and we can only have 10 observations, we can keep our difference 
of 1 unit and we would find that the power is 0.73.  Or we can ask for what difference 
the power will be 0.95, giving a value of a mean difference of 1.4.  These results can 
then provide a basis for a discussion on the appropriate study to be conducted. 


A study whose power is low may have little ability to discern meaningful results.  It 
should be reconsidered, so it is large enough to establish important effects, or 
abandoned if it cannot be expected to do so.  Too large a study wastes resources, while 
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one that is too small tends also to be wasteful, as such studies often result in 
inconclusive findings.  Study size calculations are usually closely related to decisions 
on expending resources, so it is important to get them right.  


The choice of values for the power and significance levels in sample size calculation is 
debatable.  Setting the significance level at the conventional values of 5% or 1%, 
quantify the probability of falsely rejecting the null hypothesis, when it is true.  This is 
known as a Type I error.  The power to detect a minimum meaningful difference, if it 
exists, quantifies a second type of error, conventionally called a Type II error, namely 
that a real difference will remain undetected.  Commonly sample size calculations 
specify a power of 80%, though 90% is also used. 


When using results such as the example above it is important to remember that the 
calculations of sample size or power relate to a single hypothesis.  Most studies have a 
number of objectives and significance testing is usually only a small part of the 
analysis.  In general the same type of calculation should therefore be done for a 
number of the key analyses to ensure that the sample size is sufficient for all the 
objectives of the study.  Thus the proper planning of a data collection study requires 
that the main analyses are foreseen and planned for, before the data collection is 
allowed to start. 
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7. Non-Parametric Methods 


The normally distributed measurement is the starting point of much statistical analysis.  
There are situations where this seems worryingly inappropriate.  Measurements are 
perhaps from a very skew distribution, where an occasional reading is much larger 
than the usual range and cannot be explained or discounted.  Results may be only 
quasi-numerical, e.g. an importance score between 1 and 10 allocated to several 
possible reasons for post-harvest fish losses.  Different fishermen may assign scores in 
their own way, some avoiding extreme scores, while others using them.  We may then 
have reasonable assurance as to the rank order of scores given by each individual, but 
doubtful about applying processes such as averaging or calculating variances for 
scores given to each reason. 


In such cases it is sensible to consider using non-parametric methods.  A simple 
example is the paired data shown earlier in Section 5.  Here the ten differences in 
breaking strength were as follows: 


3 2 3 1 3 0 3 1 1 1 


Earlier we used the t-test, but a simple non-parametric test follows from the fact that 
nine out of the ten values are positive, with the other being zero.  If there were no 
difference in the before and after reading we would expect about half to be positive 
and half negative, so this simple summary of the data provides good evidence (p = 
0.004, on a formal test) against this hypothesis.  Just noting whether the observations 
are positive, zero or negative is also clearly robust against occasional readings being 
very large – if the first difference were 30, rather than 3, this would not affect the 
analysis.  Thus non-parametric methods often provide a simple first step.  They also 
add easily explained support for the conclusions from a parametric analysis. 


We advise caution, however, about the over-use of non-parametric methods.  
Inadequate understanding of the data-generating system by the researcher may be the 
real reason for messy-looking data.  A common reason for apparently extreme values, 
or lumpy distribution of data, is often that the population sampled has been taken as 
homogeneous, when it is an aggregate of different strata, within which the 
observations follow different patterns. 


Sometimes problem data arise from poorly designed measurement procedures, where a 
more thoughtful definition of raters’ tasks would produce more reliable data.  It is then 
better to think harder about the structure of the data than to suppress the complications 
and use an analysis that ignores them. 
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The ethos of non-parametric methods often stems from assuming the measurements 
themselves are flawed, or at least weak, so that estimation procedures are of secondary 
importance.  The primary focus of most non-parametric methods is on forms of 
hypothesis testing, whereas the provision of reasonable estimates usually generates 
more meaningful and useful results. 


In the final section of this guide we outline a more general framework for the analysis 
of many sets of data that used previously to be processed using non-parametric 
methods. 
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8. Analysis of Variance 


8.1 Introduction 


Practical problems are usually more complicated than the illustrations so far.  We use 
the Analysis of Variance to illustrate how the concepts are applied in larger problems. 


Understanding the idea of analysis of variance is now a more general requirement than 
just to analyse experimental data.  The same type of generalisation is possible for data 
on proportions, or where regression, or time-series methods would be used.  When 
data are from non-normal distributions, such as survey data on counts, then the ideas 
of Analysis of Variance are generalised and are then called the Analysis of Deviance.  
The key concepts remain unchanged.  


8.2 One-Way ANOVA 


The t-test for two independent samples shown in Section 5 generalises to more than 
two samples in the form of the one-way analysis of variance.  The comparison of a 
collection of independent samples is described as a “completely randomised design”.  
We illustrate this with an example. 


In a study of species diversity in four African lakes the following data were collected 
on the number of different species caught in six catches from each lake. 


 


Lake Tanganyika Victoria Malawi Chilwa 


 64 78 75 55 


 72 91 93 66 


68 97 78 49  


Catches 
77 82 71 64 


 56 85 63 70 


 95 77 76 68 


Mean 72 85 76 62 


The pooled estimate of variance, 2s , is 100.9.  The standard error of the difference 


between any two of the above means is ( )2s.e.d. 2 /6 5.80s= = . 
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The usual analysis of variance (ANOVA) will look like:- 


 
 
One-way ANOVA: catch versus lake 
 
Analysis of Variance for catch    
Source     DF        SS        MS        F        P 
lake        3      1637       546     5.41    0.007 
Error      20      2018       101 
Total      23      3655 
 


 


The F-value and p-value are analogous to the t-value and p-value in the t-test for two 
independent samples.  Indeed, the two-sample case is a special case of the one-way 
ANOVA, and the significance level is the same, irrespective of which test is used. 


With more than two groups a significant F-value, as here, indicates there is a 
difference somewhere amongst the groups considered, but does not say where – it is 
not an end-result of a scientific investigation.  The analysis then usually continues with 
an examination of the treatment means that are shown with the data above.  Almost 
always a sensible analysis will look also at “contrasts” whose form depends on the 
objectives of the study.  For example if lakes in the Tanzanian sector were to be 
compared with the Malawian lakes, we could look at the difference in the mean of the 
first two treatments, compared with the mean of the third and fourth.  If this difference 
were statistically significant, then the magnitude of this difference, with its standard 
error, would be discussed in the reporting the results. 


In the analysis of variance a “non-significant” F-value may indicate there is no effect.  
Care must be taken that the overall F-value does not conceal one or more individual 
significant differences “diluted” by several not-very-different groups.  This is not a 
serious problem; the solution is to avoid being too simplistic in the interpretation.  
Thus again researchers should avoid undue dependence on an arbitrary “cut-off” p-
value, like 5%. 


8.3 Multiple Comparison Tests 


These tests are often known by their author and include Dunnett’s test, Neumann 
Keuls, etc.  They concern the methods of testing differences between means, which 
require ANOVA type analyses.  Some scientists use them routinely while others avoid 
their use. 


Our views are perhaps clear from Section 5.2.  Hypothesis testing is usually just a 
preliminary step, and the further analysis, often concerning the treatment means, 
relates directly to the stated objectives of the study.  This will usually involve 
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particular contrasts, to investigate differences of importance.  We do not recommend 
multiple comparison methods, because they usually do not relate to the objectives of 
the research. 


The case for the multiple comparison tests rests on the danger of conducting many 
significance tests on a set of means, for example comparing the largest with the 
smallest, without adjusting the test for the fact that we have deliberately chosen them 
as being largest and smallest.  The case is clear, but irrelevant to us in most analyses, 
because we do not wish to do lots of tests.  We want, instead to investigate the size of 
differences in relation to their practical importance. 


To take one field of application, that of agricultural field trials, then usually the 
treatment structure will be well defined, with factorial structure being the most 
common.  In such cases multiple comparison procedures are usually clearly not 
relevant.  The only type of factor where we might wish to consider multiple 
comparison methods would be perhaps variety comparison (of maize say) where we 
might wish to present the results in descending order of the mean yields.  Even here, 
we are more likely to try and understand the differences in yields as a function of the 
season length, or country of origin, etc of the varieties, than to suggest a series of tests.  
The one case for the tests would be if we wish to group the varieties into sets that 
behave similarly.  Some might use multiple comparison methods for this.  We would 
suggest cluster analysis, which has the additional advantage that it can be used on 
many variables together.  Even here, we would suggest that the cluster analysis should 
usually be part of a preliminary study, to be followed by attempts to understand the 
reasons for varieties being in one cluster or another. 


Our main concern is that users may be tempted to use a multiple comparison method 
instead of a more thoughtful analysis, and hence will miss interpreting the data in ways 
that are needed given the objectives of the study.  As long as you do not fall into this 
trap, then we invite you to do both.  We predict that when you report the results in 
relation to the objectives, you will not need to use any of the results from the multiple 
comparison methods.  So they can then be deleted from the tables in the report! 


We also discuss this problem in the guide on Informative Presentation of Graphs, 


Tables and Statistics because some scientists may have withdrawal symptoms if they 
do not present tables with a collection of letters beside the corresponding means. 
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9. A General Framework 


The illustrative examples in this guide have all been simple, to concentrate on the 
concepts.  These concepts include: 


• Our data are (or are assumed to be) a sample from some population, and we wish to 
make inferences about the population. 


• We therefore use our sample to estimate the properties (parameters) of the 
population that correspond to the objectives of our study. 


• The standard error of the estimate is its measure of precision.  Sometimes we 
report the standard error itself and sometimes we report a confidence interval for 
the unknown parameter. 


• We often use hypothesis (significance) tests to identify whether differences 
between parameters can be detected in our study.  This testing phase is often the 
first step in the inference part of the analysis. 


 


All the examples in this guide can be written in a general way as: 


 data = pattern (or model) + residual 


This is our assumed model for the population.  For example, the problem of strength 
of rubber can be written as: 


 Strength = Occasion effect + Plantation effect + residual 


Our objective was to investigate the difference between the two plantations, and the 
effect was clear.  But we also saw in Section 6, that if we omitted the occasion effect 
from the model, i.e. if we used the simpler model: 


 Strength = Plantation effect + residual  


then we could not detect the Plantation effect.  This showed that we need the 
“Occasion effect” in the model, even though studying the size of the Occasion effect 
might not have been one of our objectives. 


The model above is the same if there are more than two plantations, as in Section 7 
and would still apply if the data were not “balanced”, i.e. if plantations did not send 
samples on all occasions.  With standard statistics packages the inferences can still be 
made. 


Earlier, one limitation was that the data had to come from a distribution that was 
approximately normal, but this is no longer the case.  Parametric methods are now 
very flexible in dealing with well-behaved data, even when not normally distributed 
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and this often provides an attractive framework for data analysis than the simple tests 
that are often still in current use.  For example, instead of using a simple chi-square 
test to examine relationships in a two-way contingency table, the use of log-linear 
models provides a more general and usable framework, for inferences about 
proportions.  This general framework can be used with both two-way tables (like a 
chi-square test) and with more complicated tables of counts. 


Within this general context, significance tests are often used to provide guidance on 
how complicated a model is required.  Then, using the chosen model, we estimate, as 
above, the properties that correspond to our objectives, and give a measure of 
precision to indicate our level of confidence in reporting the results. 
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Performing a paired test means that the plantation to plantation variability is removed 
from the analysis, so we compare the differences in tensile strength at each occasion. 

In GenStat, choose Run => Restart Session and create a new spreadsheet where 
you enter the above-mentioned data. To show two ways of doing the test, first calculate 
the difference in strength between the X and Y plantation on each occasion in a new 
variable called “Difference”. Save the file as ‘tensile strength paired data.gsh’ (Fig. 
3.33). 

Fig. 3.33 tensile strength paired data.gsh 

 

The first way of doing the test is to select a two-sample (paired test) and compare X 
with Y (Fig. 3.34). Or you can select a one-sample test and compare the differences 
with a mean of zero (Fig. 3.35). 

Fig. 3.34 Paired two sample  t-test Fig. 3.35 The one-sample approach for a 
paired t-test 


Wim Buysse
Double-click to open the GenStat spreadsheet "tensile strength paired data.gsh"
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Fig. 3.36 Output of a paired two sample  t-test Fig. 3.37 Output of the one-sample approach 
for a paired t-test 

 

 

The Output Window gives exactly the same results in both cases (Fig. 3.36 and Fig. 
3.37). No wonder, because by choosing a paired t-test we indicated we want to ignore 
the plantation to plantation variability. So in both cases we tested that the mean of the 
pair wise differences is equal to zero.  

The t-statistic was calculated using the mean difference and the standard error of the 
estimate as seen in chapter 3.3.1: 

( ) 013.510
289.1/8.1 ==t  

By comparing matched pairs we improved the precision of the analysis. If we had 
chosen to perform a t-test of two independent samples, the small but systematic 
differences between the pairs would not have been detected. We would have 
calculated a pooled variance from the rather large variances of X and Y. This would 
have lead to a non-significant t-value of 0.41 (Fig. 3.38) and we would have mistakenly 
concluded that there are no differences in tensile strengths between the two 
plantations. 

Fig. 3.38 Using the wrong approach leads to wrong results although nothing is technically 
wrong with the calculations. 

 

This paired structure can be compared to the concept of blocking in experiments and 
stratification in surveys. 
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3.3.4 A non-parametric example. 

All t-tests and generally much statistical analysis are based on the assumption that 
data come from a normal distribution. Sometimes this is not the case, for instance: 

- the distribution is very skew because one or some measurements are 
much larger that the usual range and are not a measurement error. 

- measurements are not on the ratio scale but on the ordinal scale. For 
instance different farmers may assign scores between 1 and 10 about 
preferences of using different tree species on their farm. Some farmers 
will avoid extreme scores, others will use them. 

In such cases we may choose to use non-parametric methods.  

Let’s imagine that the differences in tensile strength (Fig. 3.33) consist of such data. A 
possible approach now is to use the sign test. Under a null-hypothesis of no difference 
between the two samples, about half of the differences would be positive and about 
half would be negative, so the median would be zero. In the example, 9 differences are 
positive, one difference is zero and zero differences are negative. We do not go into 
details about the calculations but show how to perform the test in GenStat. Choose 
Stats => Statistical Tests => One-sample non-parametric tests. The variate to be 
tested is “Difference” and by default, GenStat tests against a median value of zero (Fig. 
3.39). 

Fig. 3.39 Sign test 

 

***** One-sample Sign Test ***** 

  

         Variate        Size      Median 

      Difference           9       1.500 

  

 Test if median equals 0 

  

                  Test statistic:      9 

           Effective sample size:      9 

     Two-sided probability level:  0.004 

In this example it is very obvious that the null-hypothesis of no difference is rejected 
(p=0.04). 
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3.4 A fast and simple regression.  

We will now introduce some key elements of data analysis using GenStat, 
by means of simple regression.  This example is taken from page 193 of 
Mead, Curnow and Hasted.  In this chapter we only show how to perform a 
linear regression in GenStat and what kind of options are available.  

Start a new GenStat session (see chapter 2.4.3), create a spreadsheet with 2 columns 
(conc and uptake) and 17 rows and enter the data from Fig. 3.40. Add extra description 
to the two columns: conc are various CO2 concentrations passed over wheat leaves at 
a temperature of 35 °C and uptake is the amount of CO2 that is taken up by those 
leaves. Format the uptake column so it shows two decimals. Save the spreadsheet as 
‘CO2 uptake wheat leaves.gsh’. See chapter 2.2 if you need some help with this. 

Fig. 3.40 Simple regression data Fig. 3.41 The same data in a GenStat spreadsheet

CO2 concentration Uptake 
(cm3/dm2/hour) 

conc uptake 
75 0.00 

100 0.65 
100 0.50 
100 0.40 
120 1.00 
130 0.95 
130 1.30 
160 1.80 
160 1.80 
160 2.10 
190 2.80 
200 2.50 
200 2.90 
200 2.45 
200 3.05 
240 4.30 

250 4.50 

 

Before starting a formal analysis we first look at the data in an exploratory way. Check 
the summary statistics for each of the two columns (see chapter 2.3.1) and draw a 
graph. Draw a point plot as in Fig. 3.42 to see if there is a linear relationship. 


Wim Buysse
Double-click to open the GenStat spreadsheet "CO2 uptake wheat leaves.gsh"
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Fig. 3.42 A point plot of the regression data 

 

Choose Stats ⇒ Summary Statistics ⇒ Correlations and complete the dialogue as 
shown in Fig. 3.43 to give the correlation between uptake and conc. Indicate you want 
to see the correlations in a spreadsheet. 
Fig. 3.43 Correlations dialogue Fig. 3.44 Results in a new spreadsheet 

 

So, we see a linear pattern and a high positive correlation between the CO2 
concentration and the CO2 uptake. We have therefore fit a straight-line model to the 
data. Choose Stats ⇒ Regression Analysis ⇒ Linear. Choose or Simple Linear 
Regression or General Linear Regression in the regression box and click [OK]. Once 
you have done this, the results of the regression can be seen in the Output Window 
and the buttons on the linear regression menu that were dimmed in Fig. 3.45 have 
become active. 
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Fig. 3.45 Linear regression dialogue 

 

 

At  the bottom of the Output Window we can see the estimate of parameters in the 
fitted equation: 

uptake = -2.043 + 0.02494 * conc 
Click on [Further Output] in the dialogue in Fig. 3.45, next on [Fitted Model] and 
finally give the explanatory variable, see Fig. 3.46 to produce a graph with the original 
observations and the fitted regression line. 

Fig. 3.46 Further output from the regression 
model Fig. 3.47 The resulting graph 

 

This example shows it is easy to “do statistics” once you have become familiar with the 
use of dialogues in GenStat.  
 



4 Review of chapters 2–3. 

Here we review some of the tasks you have undertaken in the previous chapters. 
Could you? 

Task Hint 

Open a set of data you entered earlier in Excel, for example the file 
“Prunus africana height and dbh Mabira Uganda.xls”? 

See page 10 

Enter a new set of data which has 3 columns and 6 rows? See page 7 

Import a named range from an Excel worksheet. See  page 12 

Derive a new column containing the square of the values in an 
existing column? 

See page 17 

Append a GenStat spreadsheet to another? See page 35 

Carry out a two-sample unpaired t-test? See page 45 

Find the names and lengths of all the columns of data. See page 28 

Explain why a boxplot is often a useful summary of a set of data 
and also to compare different sets?   

See page 42, look in a 
statistics book, or ask 
someone. 

Give a line plot?   Look at the second 
option in the menu 
shown in Fig. 2.27 on 
page 16 

Carry out a simple linear regression? See page 52 
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Task Hint 

Summarise a column of data? See page 15 and page 
26 

Explain how GenStat “works”? See chapter 2.4 on 
page 28 

Explain what is meant by a factor column? See page 21 

Leave GenStat?  (If not, then keep practising!)  

 

 



5 Challenge 1  

The file called “Fallow species trial.xls” contains data from a field 
experiment in which soil nitrate was measured at the start of the season in 
plots that had been under various fallows (coded in TRT).  Maize yield was 
measured in each plot at the end of the season, as well as the level of 
Striga (a parasitic weed) infestation.  Find the average grain yield for each 
type of fallow.  Produce a graph that shows the relationship between maize 
yield and preseason soil nitrate for each type of fallow.  Check whether 
there is an obvious relationship between maize yield and Striga, and 
whether the plot looks clearer if square root (Striga) is considered. 

 
 


91 season

		Data from Chipata, Zambia

		Screening of suitable species for 3 year fallow

		Treatment		Replication number		Grain Yield		Striga		NITRATE N

						(t/ha)		Striga		(mg/kg)

		TRT!		REP!		YIELD		STRIGA		NIT_N

		SES		1		5.46		1		7.58

		GLI		1		4.50		19.5		6.43

		LEU		1		3.01		8		2.50

		FLE		1		2.68		8		5.32

		SEN		1		1.64		2		1.72

		ROT		1		2.20		105.5		8.98

		NAT		1		2.06		169		2.56

		M		1		1.49		1504		6.53

		CAL		1		2.36		49		4.51

		SES		2		6.35		2		7.02

		GLI		2		5.93		382		4.96

		LEU		2		3.51		9.5		3.17

		FLE		2		4.04		26.5		4.99

		SEN		2		2.43		5		2.78

		ROT		2		3.95		37		10.80

		NAT		2		3.15		173		3.56

		M		2		3.10		312		8.04

		CAL		2		3.62		10		4.40

		SES		3		6.86		0.5		11.70

		GLI		3		4.44		720		7.78

		LEU		3		3.50		10.5		3.10

		FLE		3		3.82		14		8.15

		SEN		3		2.15		1.5		2.84

		ROT		3		3.99		74		9.22

		NAT		3		2.61		245.5		4.66

		M		3		2.01		728		6.79

		CAL		3		2.14		112		4.16

		SES		4		7.18		1		10.72

		GLI		4		4.97		402.5		9.07

		LEU		4		5.83		30.5		4.33

		FLE		4		3.33		876.5		7.21

		SEN		4		2.15		4.5		2.08

		ROT		4		4.12		229.5		11.23

		NAT		4		4.17		53.5		4.16

		M		4		2.04		909.5		6.80

		CAL		4		3.04		76		4.49



&A

Page &P



Double-click to open the MS Excel 2000 file "Fallow species trial.xls"
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6 Before starting an Analysis of Variance 

GenStat has comprehensive facilities for the analysis of designed 
experiments.  In this chapter we look first at the way the data are set-up for 
this type of analysis.  This extends the discussion of factors that was 
introduced in chapter 2.  We then consider examples of a completely 
randomised, randomised block and split plot experiment.  The important 
concept of factorial treatment structure is also described. 

6.1 Factors and data organization 

6.1.1 In a GenStat spreadsheet.  

In a textbook or course on statistics, a dataset containing measurements on the yield of 
4 melon varieties may be given as in Fig. 6.1 (see Mead, Curnow and Hasted, 2003. p. 
58): 

Fig. 6.1 Common data layout in textbooks 
Variety A B C D 

Yields 25.12 40.25 18.30 28.55 

 17.25 35.25 22.60 28.05 

 26.42 31.98 25.90 33.20 

 16.08 36.52 15.05 31.68 

 22.15 43.32 11.42 30.32 

 15.92 37.10 23.68 27.58 

This tabular layout is not, however, best suited, or indeed, acceptable to most statistical 
packages.  Instead, as shown in Fig. 6.2, the measurements are entered in columns of 
length equal to the total number of units.  Together with these data, other columns are 
entered that describe the experimental treatment, etc.  These are the factors that were 
introduced earlier (chapter 2.3.3 page 21).  Common examples are the unit number, 
the block from which the unit comes, or the fertiliser amount applied to the plot. In most 
experiments, there is more than one measurement.  The way of entering data with 
each measurement in a single column is also well suited to such situations.  An 
example is shown in Fig. 6.2. 
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Fig. 6.2 Data layout for use with statistical packages 

 

Notice that in the example the name of the columns ‘Variety’ and ‘dbclass’ 
are in italics. In a GenStat spreadsheet, a name in italics preceded by an 
exclamation mark (!) indicates that the column is a factor. 

We will now create some spreadsheets that will be used in chapter 8. 

6.1.1.1 Melon yields.  

Create a spreadsheet with 2 columns and 24 rows. The first column, called Variety, is a 
factor with 4 levels (“A”, “B”, “C” and “D”). The second column Yield is a variate. Format 
Yield to show 2 decimals. Save the spreadsheet as “Melon yield.gsh” and choose Run 
=> Restart Session to clear all data from memory. 

Normally data are entered in the randomised order that corresponds to the 
recording in the field book and a column is included that gives the plot 
number. Here however we have entered the data in the order shown in the 
textbook. 

All this was shown in chapter 2.3.3. In that chapter we also saw the difference between 
entering ordinals or labels. We show now some alternative ways of creating a 
spreadsheet, some are more suitable when entering ordinals, others when entering 
labels. Skip the rest of this section if you’re happy to know only one way of entering 
data into GenStat. 

Ä Fill 
This is the easiest option when entering data as ordinals. In the example we could fill a 
column containing a variate: 6 times 1, 6 times 2, 6 times 3 and 6 times 4. Choose 
Spread => Calculate => Fill and indicate you want 6 repeats (Fig. 6.3). In the preview 
window you are able to see how the figures will appear in the column. Next choose 
Spread => Column => Convert, convert the column into a factor type and with the 
Spread => Factor => Edit labels option you can change the 4 figures into 4 letters 
(Fig. 6.4). Press the [Enter] key after typing each label. 


Wim Buysse
Double-click to open the GenStat spreadsheet "Melon yield.gsh"
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Fig. 6.3 Indicating the number of repeats Fig. 6.4 Changing the Factor labels 

If you already have a factor, and you want to give it labels or to modify the 
existing labels, click anywhere in the column, choose Spread ⇒ Factor ⇒ 
Edit Labels. 

Ä List fill. 
This option is slightly more difficult. Consider it as a good practice for when you want to 
learn the GenStat command language. Otherwise, the Fill option is easier. Spread => 
Calculate => List Fill brings you to a small dialogue screen where you can enter a 
formula (Fig. 6.5) 

- 1…24 is called a progression; a list of numbers ascending with equal 
increments or descending with equal decrements. 1…24 returns 1, 2, 3, 
4, 5 up to 24. A second number separated from the first by a comma 
gives the increment or decrement. 1,2…24 would return 1, 3, 5, 7 and 
so on (24 would not be included). 

- Pre-multipliers cause each number in a progression or list between 
brackets to be repeated. 6(1…4) would return 1, 1, 1, 1, 1, 1, 2, 2, 2, 2, 
2, 2, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 4, 4 

- Post-multipliers cause the list to be repeated. (1…4)6 would return 1, 
2, 3, 4, 1, 2, 3, 4, 1, 2, 3, 4, 1, 2, 3, 4, 1, 2, 3, 4, 1, 2, 3, 4 

 

Fig. 6.5 The List Fill dialogue screen 

 

Again, convert the column to a factor afterwards and change the labels.  
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Ä Converting text columns. 
This option is very useful when importing for instance survey data from other software 
packages. On a text column you can right-click and choose Convert to Factor.  The 
result is a factor column in GenStat containing labels. 

 

6.1.1.2 Layers and light regimes.  

Use any of the methods mentioned in chapter 2.3.3 and chapter 6.1.1.1 to create a 
spreadsheet with data of an experiment on the effect of lighting on the egg production 
of pullets (Mead, Curnow and Hasted page 69). The figures are the number of eggs 
laid by a pen of six pullets in the period between 1 December 1950 and 22 February 
1951. 

Blocks 

Treatments 

1 2 3 4 Treatment 

 totals 

O 330 288 295 313 1226 

E 372 340 343 341 1396 

F 359 337 373 302 1371 

Block totals 1061 965 1011 956 3993 

 

If you use the List fill option, note that the formula to enter the blocks will be (1…4)3 
while the formula for the treatments will be 4(1…3). The difference when using Spread 
=> Calculate => Fill is shown in Fig. 6.6 and Fig. 6.7. 

Fig. 6.6 The Fill dialogue screen when 
entering the blocks 

Fig. 6.7 The Fill dialogue screen when 
entering the treatments 

 

The resulting GenStat spreadsheet should look as in Fig. 6.8. The following information 
can be included as column attributes to the treatment column. 

- Treatment O: control (natural daylight only) 
- Treatment E: extended day (total day length 14 hours) 
- Treatment F: flash lightning (natural day plus twice 20 second flashes 

per night) 
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Fig. 6.8 The resulting spreadsheet 

 

Save the file as “Egg production.gsh”. 

6.1.2 From an Excel spreadsheet.  

6.1.2.1 Survival of Salmonella typhimurium. 

The layout of the data where each factor or measurement is entered in a single 
column, as introduced in chapter 6.1.1, is the most suitable layout for working with any 
statistical package. However, if you have many factors or measurements, it can be 
difficult to understand the contents of a column. One way of documenting the data in 
GenStat is to give an extra description as was seen in chapter 2.2.1 

A more convenient way of adding a description to factors and measurements and also 
adding meta-documentation about the dataset can be done using Excel, as shown in 
the example below. Fig. 6.9 shows the textbook layout, while Fig. 6.10  shows the 
layout as entered in the Excel file “Salmonella typhirum survival.xls”. The data are from 
Mead, Curnow and Hasted, 2003 page 113. 


Wim Buysse
Double-click to open the GenStat spreadsheet "Egg production.gsh"


Salmonella

		Data from Mead, Curnow & Hasted - p113

		Effects of three levels of sorbic acid and six levels of water activity on survival of Salmonella typhimurium

		unit		block number		sorbic acid (ppm)		water activity		water density (log(density/ml))

		Unit		Block!		Sorbic!		Water!		Density:2

		1		1		0 ppm		0.98		8.19

		2		2		0 ppm		0.98		8.37

		3		3		0 ppm		0.98		8.33

		4		1		0 ppm		0.94		6.65

		5		2		0 ppm		0.94		6.7

		6		3		0 ppm		0.94		6.25

		7		1		0 ppm		0.9		5.87

		8		2		0 ppm		0.9		5.98

		9		3		0 ppm		0.9		6.14

		10		1		0 ppm		0.86		5.06

		11		2		0 ppm		0.86		5.35

		12		3		0 ppm		0.86		5.01

		13		1		0 ppm		0.82		4.85

		14		2		0 ppm		0.82		4.31

		15		3		0 ppm		0.82		4.52

		16		1		0 ppm		0.78		4.31

		17		2		0 ppm		0.78		4.34

		18		3		0 ppm		0.78		4.2

		19		1		100 ppm		0.98		7.64

		20		2		100 ppm		0.98		7.79

		21		3		100 ppm		0.98		7.59

		22		1		100 ppm		0.94		6.52

		23		2		100 ppm		0.94		6.19

		24		3		100 ppm		0.94		6.51

		25		1		100 ppm		0.9		5.01

		26		2		100 ppm		0.9		5.28

		27		3		100 ppm		0.9		5.78

		28		1		100 ppm		0.86		4.85

		29		2		100 ppm		0.86		4.95

		30		3		100 ppm		0.86		4.29

		31		1		100 ppm		0.82		4.29

		32		2		100 ppm		0.82		4.43

		33		3		100 ppm		0.82		4.18

		34		1		100 ppm		0.78		4.13

		35		2		100 ppm		0.78		4.39

		36		3		100 ppm		0.78		4.18

		37		1		200 ppm		0.98		7.14

		38		2		200 ppm		0.98		6.92

		39		3		200 ppm		0.98		7.19

		40		1		200 ppm		0.94		6.33

		41		2		200 ppm		0.94		6.18

		42		3		200 ppm		0.94		6.43

		43		1		200 ppm		0.9		5.2

		44		2		200 ppm		0.9		5.10

		45		3		200 ppm		0.9		5.43

		46		1		200 ppm		0.86		4.41

		47		2		200 ppm		0.86		4.40

		48		3		200 ppm		0.86		4.79

		49		1		200 ppm		0.82		4.26

		50		2		200 ppm		0.82		4.27

		51		3		200 ppm		0.82		4.37

		52		1		200 ppm		0.78		3.93

		53		2		200 ppm		0.78		4.12

		54		3		200 ppm		0.78		4.15



&A

Page &P

WBuysse:
Roger Mead, Roger N. Curnow and Anne M. Hasted, 2003. Statistical Methods in Agriculture and Experimental Biology. Third Edition. Chapman & Hall/CRC. 472 pages ISBN 1-58488-187-9



Wim Buysse
Double-click to open the MS Excel 2000 file "Salmonella typhirum survival.xls"
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Fig. 6.9 Text book layout of data Fig. 6.10 Meta-documentation layout of data 
in MS Excel 

 

As mentioned in chapter 2.2.2, you can define a name in Excel for the range containing 
only the data plus the header row, and import the named range into GenStat. Part of 
the GenStat spreadsheet after importing the Excel named range is shown in Fig. 6.11.  

 

Fig. 6.11 Part of an imported Excel 
spreadsheet 
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Some tricks for easily importing a named range from Excel into GenStat. 

An exclamation mark (!) following the column header in Excel (for 
example “Sorbic!”) automatically converts the column to be a factor column 
in GenStat. In the resulting GenStat spreadsheet, the name of the column 
will be in italics and will be preceded by an exclamation mark. 

A dollar sign ($) following the column header automatically converts the 
data in the column to text. In the resulting GenStat spreadsheet, a green 
letter T will precede the name of the column.  

A colon (:) followed by a figure behind the column header formats the 
variate automatically to a certain number of decimals. For instance when 
importing the column Density:2 from Excel into GenStat, that variate will be 
formatted with two decimals. 

Column headers (called identifiers in GenStat) can consist of up to 32 
letters or digits, but they must start with a letter and they are case sensitive. 
Spaces between several words are converted to an underscore. However, 
avoid using long names or special characters (@, #, /, …) since this can 
create problems when exporting to other software packages. 

A description of the column can be added in the row above the column 
name. 

If any values are missing, an asterisk (*) could be entered. Blank Excel 
cells are automatically converted into an asterisk, when importing into 
GenStat. However both blank cells and asterisks can create confusion 
when exporting to other software packages. Make sure you distinguish 
blank cells from cells containing the value zero. 
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6.2 Exploratory analysis 

Before proceeding to the Analysis of Variance it is important to look 
(critically) at the data, both for error checking and to see if we can discover 
patterns in the data.  We will do this now for the 3 spreadsheets we have 
created. 

6.2.1 Melon yields  

In chapter 2.3.1 we saw already how to create summary statistics. As always there are 
still other ways. Clear the GenStat memory (Run => Restart Session), open the file 
“Melon yield.gsh” and choose Stats => Summary Statistics => Summaries of 
Groups (Tabulation). Complete the dialogue as shown in Fig. 6.12.  

Fig. 6.12 The tabulation dialogue window Fig. 6.13 The resulting table in the Output 
Window 

 

 

The results appear in the output window (Fig. 6.13). You may now want to copy these 
summary statistics in a report. The following options will save you time.  

Highlight the table in the Output Window and choose Edit => Copy Special => RTF 
Table. Two dialogue boxes will appear. The first asks you after how many spaces you 
want to split the columns (Fig. 6.14); the second allows you to change the appearance 
of the final Word table (Fig. 6.15). Modify the options to suit the style of your report and 
click [OK].   
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Double-click to open the GenStat spreadsheet "Melon yield.gsh"
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Fig. 6.14 Splitting columns after one or two 
spaces Fig. 6.15 Options for a RTF table 

 

The table below is what you get when you choose Edit => Paste Cells in Word. The 
resulting table looks as follows: 

Mean Minimum Maximum Median  
Variety     
A 20.49 15.92 26.42 19.70 
B 37.40 31.98 43.32 36.81 
C 19.49 11.42 25.90 20.45 
D 29.90 27.58 33.20 29.44 

 

Notice that the headings of the columns are not correct. You could have edited the 
table in the Output Window of GenStat before copying it. Or you can modify the layout 
of the table in Word. The example below gives the same table with some columns 
deleted, some changes in the layout and some extra information added. 

Melon variety Average yield 
(kg) 

A 20.49 
B 37.40 
C 19.49 
D 29.90 

Data from Mead, Curnow and Hasted, 
2003. p. 58 

 

Alternatively, you could first save your summary statistics in a GenStat spreadsheet. 
First click on the [Save] button in the Summary by Groups dialogue window. Check the 
summary statistics you want and give them a name. In the example we want the 
means and will call this “Average yield”. Don’t forget to indicate you want to show the 
resulting table in a spreadsheet (Fig. 6.16). After clicking [OK] a new table containing 
the summary statistics will appear (Fig. 6.17). You can format the means to have 2 
decimals (see chapter 2.3.2).  
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Fig. 6.16 Saving the table Fig. 6.17 The resulting GenStat table 

 

 

With the table of means selected, you can now choose again Edit => Copy Special => 
RTF Table. The next dialogue window is the same as in Fig. 6.15 and allows you to 
change the appearance of the final Word table. Again, you can paste the cells in Word 
and modify the layout of the table. 

From the resulting table we clearly see that the average yield of variety B is higher than 
the others. Variety A and C have a low average yield, probably not much different. We 
cannot see if these differences are caused by a few observations or if the averages 
give a picture of the average situation. For this a boxplot is useful. Refer to chapter 
3.2.1 (page 38) to create a similar boxplot to the one in Fig. 6.18. 

Fig. 6.18 Boxplot of the yields of the melon 
varieties 

 

The exploratory analysis gives us an idea of which melon varieties have a higher yield 
and which ones produce a similar yield. Whether these are real differences will be 
shown later during the formal statistical analysis. 

6.2.2 Layers and light regimes. 

Follow the steps described in the previous section with the file “Egg production.gsh”, to 
give the results shown in Fig. 6.19 and Fig. 6.20. 


Wim Buysse
Double-click to open the GenStat spreadsheet "Egg production.gsh"
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Fig. 6.19 GenStat table with average egg 
production per treatment Fig. 6.20 The resulting boxplot 

 

The “Margin” in Fig. 6.19 which can be renamed as “Grand Mean”, is given by selecting 
the Set Margin box in the Summary by Groups dialogue window (Fig. 6.21) before you 
click on the [Save] button. 

Fig. 6.21 Setting the margin 

 

6.2.3 Survival of Salmonella typhimurium.  

Open “Salmonella typhirum survival.xls” and perform some exploratory analysis. In 
some cases, a scatter plot (also called a point plot), is more useful than boxplots to 
draw conclusions. One question here is if there is a change in Salmonella density with 
increasing water acidity for the different levels of sorbic acid. 

Use Graphics ⇒ Point plot and complete the dialogue as shown in Fig. 6.22. 


Salmonella

		Data from Mead, Curnow & Hasted - p113

		Effects of three levels of sorbic acid and six levels of water activity on survival of Salmonella typhimurium

		unit		block number		sorbic acid (ppm)		water activity		water density (log(density/ml))

		Unit		Block!		Sorbic!		Water!		Density:2

		1		1		0 ppm		0.98		8.19

		2		2		0 ppm		0.98		8.37

		3		3		0 ppm		0.98		8.33

		4		1		0 ppm		0.94		6.65

		5		2		0 ppm		0.94		6.7

		6		3		0 ppm		0.94		6.25

		7		1		0 ppm		0.9		5.87

		8		2		0 ppm		0.9		5.98

		9		3		0 ppm		0.9		6.14

		10		1		0 ppm		0.86		5.06

		11		2		0 ppm		0.86		5.35

		12		3		0 ppm		0.86		5.01

		13		1		0 ppm		0.82		4.85

		14		2		0 ppm		0.82		4.31

		15		3		0 ppm		0.82		4.52

		16		1		0 ppm		0.78		4.31

		17		2		0 ppm		0.78		4.34

		18		3		0 ppm		0.78		4.2

		19		1		100 ppm		0.98		7.64

		20		2		100 ppm		0.98		7.79

		21		3		100 ppm		0.98		7.59

		22		1		100 ppm		0.94		6.52

		23		2		100 ppm		0.94		6.19

		24		3		100 ppm		0.94		6.51

		25		1		100 ppm		0.9		5.01

		26		2		100 ppm		0.9		5.28

		27		3		100 ppm		0.9		5.78

		28		1		100 ppm		0.86		4.85

		29		2		100 ppm		0.86		4.95

		30		3		100 ppm		0.86		4.29

		31		1		100 ppm		0.82		4.29

		32		2		100 ppm		0.82		4.43

		33		3		100 ppm		0.82		4.18

		34		1		100 ppm		0.78		4.13

		35		2		100 ppm		0.78		4.39

		36		3		100 ppm		0.78		4.18

		37		1		200 ppm		0.98		7.14

		38		2		200 ppm		0.98		6.92

		39		3		200 ppm		0.98		7.19

		40		1		200 ppm		0.94		6.33

		41		2		200 ppm		0.94		6.18

		42		3		200 ppm		0.94		6.43

		43		1		200 ppm		0.9		5.2

		44		2		200 ppm		0.9		5.10

		45		3		200 ppm		0.9		5.43

		46		1		200 ppm		0.86		4.41

		47		2		200 ppm		0.86		4.40

		48		3		200 ppm		0.86		4.79

		49		1		200 ppm		0.82		4.26

		50		2		200 ppm		0.82		4.27

		51		3		200 ppm		0.82		4.37

		52		1		200 ppm		0.78		3.93

		53		2		200 ppm		0.78		4.12

		54		3		200 ppm		0.78		4.15



&A

Page &P

WBuysse:
Roger Mead, Roger N. Curnow and Anne M. Hasted, 2003. Statistical Methods in Agriculture and Experimental Biology. Third Edition. Chapman & Hall/CRC. 472 pages ISBN 1-58488-187-9
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Fig. 6.22 The scatter plot dialogue window Fig. 6.23 The resulting graph 

 

 

Fig. 6.23 shows a clear pattern of increasing Salmonella density with increasing water 
activity. In the GenStat Discovery Edition, it is however not easy to see the different 
levels of sorbic acid. We see they have different colours, but we don’t learn more from 
the legend. In the latest version, it is possible to change legends, titles and axes after a 
graph has been plotted. 

A possible way to work around this problem with the Discovery Edition is to plot the 
group averages. Choose Stats => Summary Statistics => Summaries of Groups 
(Tabulation) and calculate the means of Density by Water activity and Sorbic acid 
level (Fig. 6.24). Click on the [Save] button to save the means in a table (Fig. 6.25). 
This table will show the levels of the factor that is put at the bottom in the Groups box 
(Fig. 6.24) as columns. The other factors will be shown as rows.  

Fig. 6.24 First step while creating a table of 
average Density by Water activity and Sorbic 
acid level 

Fig. 6.25 Finishing the table 
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The resulting spreadsheet is a table shown in Fig. 6.26. This is another GenStat data 
structure. It is not possible to plot a graph of the data in a table, but we can convert the 
table to the normal type of spreadsheet (the “Vector” type). Click in the table shown in 
Fig. 6.26 and choose Spread => Manipulate => Convert, indicate you want the sheet 
type “Vector” and click [OK] (see Fig. 6.27). Also, format the columns to show 2 
decimals. 

Fig. 6.26 A GenStat table Fig. 6.27 Converting the table to a vector 
sheet type 

 

If you now check the available data in the GenStat server (see Fig. 6.28 as was shown 
in chapter 2.4.1), you see you have created three new variates and one new factor, 
each of them with 6 values. GenStat converted the column headers from the table into 
those variates and factors but at the same time changed their name (Water_1, 
%0_ppm, %100_ppm, %200_ppm). We will not go into details about this naming. You 
can now create a point plot. Since the y-values of such a plot are in 3 different variates, 
we choose a Multiple Y Scatter Plot in Fig. 6.29. 

 

Fig. 6.28 New data structures in the available 
data Fig. 6.29 Creating a Multiple Y Scatter Plot 

 

The resulting scatter-plot of the group averages gives us a clear picture of the trend in 
the data set, and we can distinguish the different levels of Sorbic acid in the legend.  
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Fig. 6.30 The resulting  scatter-plot with a clear legend 

We conclude that the Salmonella density increases with increasing Water activity. The 
density also diminishes with increasing Sorbic acid. The question remains if these 
differences are significant. This is found out with a formal statistical analysis.  
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6.3 A real example.  

Textbook examples are usually too small to demonstrate the importance of 
data exploration.  A “real” example is therefore used as a further illustration 
of exploratory methods.  This was an experiment in Kenya with 16 farmers 
in one district and 12 in a second.  Each farmer had 3 plots, two of which 
had tree mulch applied; the third was a control. The main variable of 
interest was the grain yield.  The primary objective of this experiment was 
to investigate whether the “good results” with the Tithonia and Lantana 
mulch in on-station experiments was repeated on farmer’s fields. 

Import the named range “data” from the Excel file “Onfarm tithonia and lantana 
mulches.xls”. One topic of interest was whether all farmers from the West district 
benefited from the mulch in the experiment.   

There is a spreadsheet menu ‘Restrict’ that is very useful when exploring data. 
Choose Spread => Restrict/Filter. There are several possibilities and we choose to 
restrict by selecting a factor level (Fig. 6.31). In this case we want to select only the 
farmers of the West district and West is one of the two levels of the factor location. So 
we restrict the data to include only the level ‘West’ of the factor ‘location’ as in Fig. 
6.32. 

Fig. 6.31 Restricting to a factor level Fig. 6.32 Selecting only the location ‘West’ 

 

The result of this restriction is that all data from the Central district are still there but 
they are not used in the calculations. The status bar (Fig. 6.33) shows for instance that 
only 36 of the 84 rows are not restricted. 

Fig. 6.33 The status 
bar shows the number 
of non-restricted rows. 

When you click on the ‘restrict switch’ (Fig. 6.34); a cross above the scroll bar of the 
spreadsheet, the restricted rows will be displayed in red as shown in Fig. 6.35. 


short rains 95

		Effect of Tithonia diversifolia and Lantana camara mulches

		Kenya: West and Central Bunyore Locations

		Short rains 1995 maize harvest

		Plot size(m2)		25

		Location		Farmer		Treatment		Grain yield		Application of Biomass		Quantity applied		Striga incidence		Streak incidence		Couch grass incidence		Biomass		Weeding		Manure application

						(type of biomass apllied. Control=none)				(A= at planting, B= before planting)		(farmers estimate. Target was 100kg fresh wt per plot)		(H=high, L=low)		(H=high, L=low)		(H=high,L=low)		(Y=yes,N=surface applied)		(number of weedings)		(Y=yes, N=no)

								(t ha-1)				(kg per plot)

		location!		farmer!		treat  !		grain		applic!		quantity		striga!		streak!		couch!		incorp!		weeding!		manure!

		West		1		Tithonia		3.46		A		97		H		H		H		Y		2		N						0		0

		West		1		Lantana		4.06		A		73		H		H		H		Y		2		Y						0		0

		West		1		Control		2.81		control		0		H		H		H		control		2		Y						0		0

		West		2		Tithonia		2.72		A		66		L		H		H		N		2		N

		West		2		Lantana		2.35		A		60		L		H		H		N		2		N

		West		2		Control		2.52		control		0		L		H		H		control		2		N

		West		3		Tithonia		4.1		A		94		L		H		H		Y		1		N

		West		3		Lantana		2.8		A		83		L		H		H		Y		1		N

		West		3		Control		2.71		control		0		L		H		H		control		1		N

		West		4		Tithonia		3.76		A		93		L		H		L		Y		2		N

		West		4		Lantana		4.08		A		50		L		H		L		Y		2		N

		West		4		Control		4.4		control		0		L		H		L		control		2		Y

		West		5		Tithonia		2.59		B		103		L		H		L		Y		2		N

		West		5		Lantana		2.35		B		93		L		H		H		Y		2		N

		West		5		Control		2.09		control		0		L		H		H		control		2		N

		West		6		Tithonia		4.91		A		100		L		H		L		N		2		N

		West		6		Lantana		4.87		A		100		L		H		L		N		2		N

		West		6		Control		3.12		control		0		L		H		L		control		2		N

		West		7		Tithonia		3.99		A		117		L		H		L		Y		2		N

		West		7		Lantana		4.82		A		43		L		H		L		Y		2		N

		West		7		Control		4.89		control		0		L		H		L		control		2		Y

		West		8		Tithonia		1.87		A		66		L		L		L		Y		1		N

		West		8		Lantana		3.03		A		72		L		L		L		Y		1		N

		West		8		Control		1.57		control		0		L		L		L		control		1		N

		West		9		Tithonia		3.24		A		100		H		H		H		Y		1		N

		West		9		Lantana		1.44		A		86		H		H		H		Y		1		N

		West		9		Control		1.8		control		0		H		H		H		control		1		N

		West		10		Tithonia		2.62		B		100		H		H		L		Y		2		N

		West		10		Lantana		1.93		B		100		H		H		L		Y		2		N

		West		10		Control		1.68		control		0		H		H		L		control		2		N

		West		11		Tithonia		3.36		A		100		L		L		L		Y		2		N

		West		11		Lantana		2.3		A		67		L		L		L		Y		2		N

		West		11		Control		0.85		control		0		L		L		L		control		2		N

		West		12		Tithonia		8.42		B		125		L		L		L		Y		1		Y

		West		12		Lantana		4.95		B		90		L		L		L		Y		1		N

		West		12		Control		2.65		control		0		L		L		L		control		1		N

		Central		1		Tithonia		1.36		A		106		H		L		L		Y		2		N

		Central		1		Lantana		0.95		A		100		H		L		L		Y		2		N

		Central		1		Control		0.72		control		0		H		L		L		control		2		N

		Central		2		Tithonia		2.72		A		103		L		L		L		Y		2		N

		Central		2		Lantana		2.57		A		106		L		L		L		Y		2		N

		Central		2		Control		1.39		control		0		L		L		L		control		2		N

		Central		3		Tithonia		2.87		A		100		H		L		L		Y		2		N

		Central		3		Lantana		1.04		A		99		H		L		L		Y		2		N

		Central		3		Control		1.85		control		0		H		L		L		control		2		N

		Central		4		Tithonia		2.48		A		85		L		L		L		N		2		N

		Central		4		Lantana		2.55		A		61		L		L		L		N		2		N

		Central		4		Control		1.09		control		0		L		L		L		control		2		N

		Central		5		Tithonia		8.51		A		20		L		L		L		N		2		Y

		Central		5		Lantana		7.37		A		11.4		L		L		L		N		2		Y

		Central		5		Control		5.42		control		0		L		L		L		control		2		Y

		Central		6		Tithonia		6.08		A		85		H		L		H		Y		2		N

		Central		6		Lantana		6.41		A		24		H		L		H		Y		2		N

		Central		6		Control		3.02		control		0		H		L		H		control		2		Y

		Central		7		Tithonia		6.78		A		66		L		L		H		Y		1		N

		Central		7		Lantana		6.02		A		47		L		L		H		Y		1		N

		Central		7		Control		4.08		control		0		L		L		H		control		1		N

		Central		8		Tithonia		2.91		A		102		L		H		L		Y		2		N

		Central		8		Lantana		2.14		A		105		L		H		L		Y		2		N

		Central		8		Control		0.76		control		0		L		H		L		control		2		N

		Central		9		Tithonia		4.96		B		89		L		H		L		Y		2		N

		Central		9		Lantana		2.38		B		51		L		H		L		Y		2		N

		Central		9		Control		2.97		control		0		L		H		L		control		2		N

		Central		10		Tithonia		5.66		A		87		H		L		L		Y		2		N

		Central		10		Lantana		6.36		A		60		H		L		L		Y		2		N

		Central		10		Control		4.53		control		0		H		L		L		control		2		N

		Central		11		Tithonia		8.34		A		33		L		H		L		N		2		Y

		Central		11		Lantana		3.64		A		33		L		H		L		N		2		N

		Central		11		Control		4.72		control		0		L		H		L		control		2		Y

		Central		12		Tithonia		5.21		B		100		H		H		L		Y		2		N

		Central		12		Lantana		3.05		B		100		H		H		L		Y		2		N

		Central		12		Control		2.85		control		0		H		H		L		control		2		N

		Central		13		Tithonia		5.41		A		53		L		L		H		Y		2		N

		Central		13		Lantana		5.37		A		40		L		L		H		Y		2		N

		Central		13		Control		2.42		control		0		L		L		H		control		2		N

		Central		14		Tithonia		4.14		B		93		H		L		L		Y		2		N

		Central		14		Lantana		2.89		B		82		H		L		L		Y		2		N

		Central		14		Control		1.72		control		0		H		L		L		control		2		N

		Central		15		Tithonia		3.35		A		102		L		L		H		N		3		N

		Central		15		Lantana		1.63		A		100		L		L		H		N		3		N

		Central		15		Control		1.6		control		0		L		L		H		control		3		N

		Central		16		Tithonia		7.81		A		178		H		L		H		N		1		N

		Central		16		Lantana		5.4		A		211		H		L		H		N		1		N

		Central		16		Control		4.95		control		0		H		L		H		control		1		N
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Fig. 6.34 The restrict switch Fig. 6.35 Restricted rows are shown in red 

 

To see if farmers in the West district who applied mulch obtained a higher maize yield, 
we could construct a line plot. Choose Graphics => Line plot and construct a plot of 
maize yield (the variate grain) versus farmer grouped per type of mulch (variate treat). 

Fig. 6.36 Constructing a line plot Fig. 6.37 The resulting line plot 

 

 

The resulting graph (Fig. 6.37) helps but not much. First of all, because we are working 
in an older version of the GenStat graphics, the legend shows ‘grain versus farmer’ 
three times but in a different colour. We cannot see which type of mulch gives the 
highest yield. The second problem is that the data along the X-axis are organised with 
increasing farmer number. It would be more helpful if the data were organised with 
increasing average grain yield. 

We can work around the first problem by using the latest version of GenStat, or by 
using some tricks in GenStat Discovery Edition and MS Word. From the graph in Fig. 
6.37 it is obvious that the highest yield for farmer 12 is given by the treatment 
symbolized with a green line. Then follows the red line and the lowest yield is given by 
the black line.  

To find which mulches these are you could for instance further restrict the restricted 
dataset, but this time ‘To Groups(factor levels)‘ farmer is 12 and make sure to select 
that you combine this restriction with the existing restrictions.  
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Fig. 6.38 The resulting spreadsheet after a 
second restriction 

In the resulting spreadsheet of Fig. 6.38 you see that the Tithonia mulch gave the 
highest maize yield and the control the lowest. So, the green line is Tithonia mulch, the 
red line is Lantana mulch and the black line is no mulch (control). 

To use this graph in a report, save it as a bitmap file. In the GenStat 4.1 graphics 
window, choose File => Save as, set the file type to bitmap file and name the file for 
instance ‘mulch.bmp’. Now open MS Word. In MS Word, choose Insert => Picture => 
From File and insert the mulch.bmp file. Now select the drawing toolbar (View => 
Toolbars => Drawing) and click on the text box button (Fig. 6.39). Type “Control” in 
the first text box and drag it over the text next to the black line in the legend as in Fig. 
6.40. 

Fig. 6.39 Creating a Text Box with the 
drawing toolbar in MS Word 

Fig. 6.40 Overwriting the GenStat legend with 
a text box in Word 

 

 

In Word, it will be necessary to format the text box. Right-click on it and choose Format 
Text Box. You will probably have to: 

- Change Colors and Lines: choose a white fill colour and no border 
line. 

- Make sure that the Wrapping style under the Layout tab is set “In front 
of text”. 

- The Internal margins under the Text box tab are set at 0 or 0.05 cm. 
- Make sure that the font size of the text in the text box is not too big. Use 

for instance Times New Roman 9pt. 
Repeat this for “Tithonia” and “Lantana”, where you will also have to change the colour 
of the text. The resulting graph can be seen in Fig. 6.41. 
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Fig. 6.41 The resulting line plot with a clear legend 

 

You could have done most of what we did using MS Word directly in GenStat by using 
the commands. If you look in the Input Window after having created the graph of Fig. 
6.37, you see that GenStat used a whole bunch of commands with different parameters 
and options to create the graph as is shown below. 

XAXIS [RESET=yes] WINDOW=1; TITLE='farmer'; TPOSITION=middle;\ 

TDIRECTION=parallel;LPOSITION=outside; LDIRECTION=parallel;\ 

MPOSITION=outside; ARROWHEAD=omit; ACTION=display 

YAXIS [RESET=yes] WINDOW=1; TITLE='grain';\ 
TPOSITION=middle;TDIRECTION=parallel; LPOSITION=outside;\ 

LDIRECTION=perpendicular; MPOSITION=outside; ARROWHEAD=omit;\ 
ACTION=display 

CALC _nlevs=NLEVELS( treat) 

PEN [RESET=yes] 1..._nlevs; METHOD=line; JOIN=ascending;\ 
SYMBOL=0; LINESTYLE=1 

DGRAPH [WINDOW=1; TITLE='Maize yield in West District'] Y=grain;\ 
X=farmer; PEN=NEWLEVELS( treat;!(1..._nlevs)) 

PEN [RESET=yes] 1..._nlevs 

 

An alternative way to  create a graph with a clear and unambiguous legend is to 
change some of the parameters and options and run the commands again. It is 
however not completely straightforward. Check the GenStat help for the commands 
XAXIS, YAXIS, PEN and DGRAPH. 

In the graph in Fig. 6.41, the data along the X-axis are ordered according to farmer 
number. It would me more informative to order them according to increasing average 
maize yield. You could consider the column grain as a stack of maize yield data when 
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there is no mulch, when Lantana mulch is applied and when Tithonia mulch is applied. 
With the Unstack menu command we can split the stack of data in three smaller stacks; 
in this case into one stack per type of mulch applied. 

Choose Spread => Manipulate => Unstack (Fig. 6.42). We split the stack of maize 
(put grain in the Unstack Columns box) according to treatment (treat in the 
Unstacking Factor box) and we want to keep some other factors in the new 
spreadsheet, like location and farmer, to be able to identify the data values (put them in 
the ID Factors box). The result should look as in Fig. 6.43. 

Fig. 6.42 The Unstack Columns dialogue box Fig. 6.43 The resulting spreadsheet with 
unstacked columns 

 

Rename the columns grain_1, grain_2 and grain_3 according to the treatment (see 
chapter 2.2.1.1) and calculate the average grain yield in a new column (see chapter 
2.3.2). With Search => Bookmark => By value, you can now mark the minimum and 
maximum value of each variate (Fig. 6.44). When you right-click in the column with the 
average grain yield, a menu appears that allows you to sort the averages in ascending 
order (Fig. 6.45). 

Fig. 6.44  Marking the extremes Fig. 6.45 Sorting on the average 

 

If you followed all steps above, you should get a spreadsheet that looks as in (Fig. 
6.46) 
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Fig. 6.46 The sorted spreadsheet 

Follow the steps mentioned above (but think about what we did in chapter 6.2.3 when 
choosing the type of plot). You should get a similar graph as the one in Fig. 6.47. 

 

Fig. 6.47 The final graph with maize yield in ordered along the 
ascending average maize yield 

 

Now back to the data exploration. Try to answer following questions, using either the 
table or the graph shown above: 

- How many of the 12 farmers had a higher yield from the Tithonia mulch 
compared to the control ? 
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- And the Lantana mulch compared to the control? 
In the original spreadsheet, use Spread ⇒ Restrict/Filter ⇒ Using Factor levels 
again and select only the Central district.  Click to [Replace with New], otherwise you 
will have no data left! Use Graphics ⇒ Line Plot again to plot just the Central district 
data.  This gives the equivalent plot for the Central district.  Try to answer the same 
questions as above but for the Central district.  From the two graphs do you feel that 
the farmers in the two districts benefit equally from the mulch? 

Remember that when you wish to use all the data, you must first use 
Spread ⇒ Restrict/Filter ⇒ Remove All. All calculations under the Stats 
menu will only be performed on the restricted data set. Bookmarks 
however will be set on all data. 
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7 Challenge 2  

In the graph in Fig. 6.47 on page 78, the data along the X-axis are ordered according to 
increasing average maize yield. You became familiar with stacking  and unstacking 
data in GenStat. There is also a second way of arriving at the graph in Fig. 6.47. Try to 
find it. 

(Hint, use a tabulation first and set the margin.) 


short rains 95

		Effect of Tithonia diversifolia and Lantana camara mulches

		Kenya: West and Central Bunyore Locations

		Short rains 1995 maize harvest

		Plot size(m2)		25

		Location		Farmer		Treatment		Grain yield		Application of Biomass		Quantity applied		Striga incidence		Streak incidence		Couch grass incidence		Biomass		Weeding		Manure application

						(type of biomass apllied. Control=none)				(A= at planting, B= before planting)		(farmers estimate. Target was 100kg fresh wt per plot)		(H=high, L=low)		(H=high, L=low)		(H=high,L=low)		(Y=yes,N=surface applied)		(number of weedings)		(Y=yes, N=no)

								(t ha-1)				(kg per plot)

		location!		farmer!		treat  !		grain		applic!		quantity		striga!		streak!		couch!		incorp!		weeding!		manure!

		West		1		Tithonia		3.46		A		97		H		H		H		Y		2		N						0		0

		West		1		Lantana		4.06		A		73		H		H		H		Y		2		Y						0		0

		West		1		Control		2.81		control		0		H		H		H		control		2		Y						0		0

		West		2		Tithonia		2.72		A		66		L		H		H		N		2		N

		West		2		Lantana		2.35		A		60		L		H		H		N		2		N

		West		2		Control		2.52		control		0		L		H		H		control		2		N

		West		3		Tithonia		4.1		A		94		L		H		H		Y		1		N

		West		3		Lantana		2.8		A		83		L		H		H		Y		1		N

		West		3		Control		2.71		control		0		L		H		H		control		1		N

		West		4		Tithonia		3.76		A		93		L		H		L		Y		2		N

		West		4		Lantana		4.08		A		50		L		H		L		Y		2		N

		West		4		Control		4.4		control		0		L		H		L		control		2		Y

		West		5		Tithonia		2.59		B		103		L		H		L		Y		2		N

		West		5		Lantana		2.35		B		93		L		H		H		Y		2		N

		West		5		Control		2.09		control		0		L		H		H		control		2		N

		West		6		Tithonia		4.91		A		100		L		H		L		N		2		N

		West		6		Lantana		4.87		A		100		L		H		L		N		2		N

		West		6		Control		3.12		control		0		L		H		L		control		2		N

		West		7		Tithonia		3.99		A		117		L		H		L		Y		2		N

		West		7		Lantana		4.82		A		43		L		H		L		Y		2		N

		West		7		Control		4.89		control		0		L		H		L		control		2		Y

		West		8		Tithonia		1.87		A		66		L		L		L		Y		1		N

		West		8		Lantana		3.03		A		72		L		L		L		Y		1		N

		West		8		Control		1.57		control		0		L		L		L		control		1		N

		West		9		Tithonia		3.24		A		100		H		H		H		Y		1		N

		West		9		Lantana		1.44		A		86		H		H		H		Y		1		N

		West		9		Control		1.8		control		0		H		H		H		control		1		N

		West		10		Tithonia		2.62		B		100		H		H		L		Y		2		N

		West		10		Lantana		1.93		B		100		H		H		L		Y		2		N

		West		10		Control		1.68		control		0		H		H		L		control		2		N

		West		11		Tithonia		3.36		A		100		L		L		L		Y		2		N

		West		11		Lantana		2.3		A		67		L		L		L		Y		2		N

		West		11		Control		0.85		control		0		L		L		L		control		2		N

		West		12		Tithonia		8.42		B		125		L		L		L		Y		1		Y

		West		12		Lantana		4.95		B		90		L		L		L		Y		1		N

		West		12		Control		2.65		control		0		L		L		L		control		1		N

		Central		1		Tithonia		1.36		A		106		H		L		L		Y		2		N

		Central		1		Lantana		0.95		A		100		H		L		L		Y		2		N

		Central		1		Control		0.72		control		0		H		L		L		control		2		N

		Central		2		Tithonia		2.72		A		103		L		L		L		Y		2		N

		Central		2		Lantana		2.57		A		106		L		L		L		Y		2		N

		Central		2		Control		1.39		control		0		L		L		L		control		2		N

		Central		3		Tithonia		2.87		A		100		H		L		L		Y		2		N

		Central		3		Lantana		1.04		A		99		H		L		L		Y		2		N

		Central		3		Control		1.85		control		0		H		L		L		control		2		N

		Central		4		Tithonia		2.48		A		85		L		L		L		N		2		N

		Central		4		Lantana		2.55		A		61		L		L		L		N		2		N

		Central		4		Control		1.09		control		0		L		L		L		control		2		N

		Central		5		Tithonia		8.51		A		20		L		L		L		N		2		Y

		Central		5		Lantana		7.37		A		11.4		L		L		L		N		2		Y

		Central		5		Control		5.42		control		0		L		L		L		control		2		Y

		Central		6		Tithonia		6.08		A		85		H		L		H		Y		2		N

		Central		6		Lantana		6.41		A		24		H		L		H		Y		2		N

		Central		6		Control		3.02		control		0		H		L		H		control		2		Y

		Central		7		Tithonia		6.78		A		66		L		L		H		Y		1		N

		Central		7		Lantana		6.02		A		47		L		L		H		Y		1		N

		Central		7		Control		4.08		control		0		L		L		H		control		1		N

		Central		8		Tithonia		2.91		A		102		L		H		L		Y		2		N

		Central		8		Lantana		2.14		A		105		L		H		L		Y		2		N

		Central		8		Control		0.76		control		0		L		H		L		control		2		N

		Central		9		Tithonia		4.96		B		89		L		H		L		Y		2		N

		Central		9		Lantana		2.38		B		51		L		H		L		Y		2		N

		Central		9		Control		2.97		control		0		L		H		L		control		2		N

		Central		10		Tithonia		5.66		A		87		H		L		L		Y		2		N

		Central		10		Lantana		6.36		A		60		H		L		L		Y		2		N

		Central		10		Control		4.53		control		0		H		L		L		control		2		N

		Central		11		Tithonia		8.34		A		33		L		H		L		N		2		Y

		Central		11		Lantana		3.64		A		33		L		H		L		N		2		N

		Central		11		Control		4.72		control		0		L		H		L		control		2		Y

		Central		12		Tithonia		5.21		B		100		H		H		L		Y		2		N

		Central		12		Lantana		3.05		B		100		H		H		L		Y		2		N

		Central		12		Control		2.85		control		0		H		H		L		control		2		N

		Central		13		Tithonia		5.41		A		53		L		L		H		Y		2		N

		Central		13		Lantana		5.37		A		40		L		L		H		Y		2		N

		Central		13		Control		2.42		control		0		L		L		H		control		2		N

		Central		14		Tithonia		4.14		B		93		H		L		L		Y		2		N

		Central		14		Lantana		2.89		B		82		H		L		L		Y		2		N

		Central		14		Control		1.72		control		0		H		L		L		control		2		N

		Central		15		Tithonia		3.35		A		102		L		L		H		N		3		N

		Central		15		Lantana		1.63		A		100		L		L		H		N		3		N

		Central		15		Control		1.6		control		0		L		L		H		control		3		N

		Central		16		Tithonia		7.81		A		178		H		L		H		N		1		N

		Central		16		Lantana		5.4		A		211		H		L		H		N		1		N

		Central		16		Control		4.95		control		0		H		L		H		control		1		N





Wim Buysse
Double-click to open the MS Excelfile "Onfarm tithonia and lantana mulches.xls"
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8 Analysis of variance. 

8.1 Two simple ANOVA’s 

Start a new GenStat session and open the file “Melon yield.gsh” (chapter 6.1.1.1 , page 
60). The design of this experiment is a completely randomised design. From the 
exploratory analysis in chapter 6.2.1 we suspect there will be differences between the 
yields of different melon varieties. We confirm this with a formal statistical analysis. To 
perform an analysis of variance, choose Stats ⇒ Analysis of Variance. In the 
Analysis of Variance menu, choose Completely Randomized Design or One-Way 
ANOVA (no Blocking), see Fig.  8.1. Fill in the variate and the treatment and click 
[OK].  
 

Fig.  8.1 The ANOVA dialogue window 

 

 

The resulting ANOVA table can be found in the Output Window. 

***** Analysis of variance ***** 
  
Variate: Yield 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
Variety                    3    1291.48     430.49   23.42  <.001 
Residual                  20     367.65      18.38 
Total                     23    1659.13 

We conclude that there are significant differences in yield for the different melon 
varieties. 

If you prefer to use the command language (see chapter 2.4.2), look in the Input 
Window to see which commands have been used. 

"Completely Randomized Design." 
BLOCK "No Blocking" 
TREATMENTS Variety 
COVARIATE "No Covariate" 
ANOVA [PRINT=aovtable,information,means; FACT=32; FPROB=yes; 
PSE=diff] Yield 

 


Wim Buysse
Double-click to open the GenStat spreadsheet "Melon yield.gsh"
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Restart the session and open “Egg production.gsh” (chapter 6.1.1.2 , page 62). This 
time there is not only a factor describing the treatments, but a second factor – Block – 
describing the layout (design) of the experiment. 

To analyse data from such an experiment choose Stats ⇒ Analysis of Variance, then 
select One-way ANOVA (in Randomised Blocks) from the list in the Design box, see 
Fig.  8.2.   

The resulting dialogue box differs from a simple one-way ANOVA used earlier in that 
there is an extra box [Blocks] for the blocking factor.  This allows information about the 
layout of the experiment to be passed to GenStat.  

Fig.  8.2 The dialogue window for a one-way ANOVA in 
randomized blocks 

 

The results are shown in the Output Window. We conclude there are differences in egg 
production for the different treatments. 

***** Analysis of variance ***** 
  
Variate: Eggs 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3     2330.3      776.8    2.01 
  
Block.*Units* stratum 
Treatment                  2     4212.5     2106.3    5.44  0.045 
Residual                   6     2321.5      386.9 
  
Total                     11     8864.2 

 


Wim Buysse
Double-click to open the GenStat spreadsheet "Egg production.gsh"
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8.2 Getting more out of the output  

The conclusion that there are significant differences between the treatments is just the 
starting point in the analysis. We now use the other information in the Output Window 
to assess what differences they are. 

We expect that the treatments will increase the egg production. That is why we did the 
experiment. This increase can be calculated from the tables of means that can be 
found in the Output Window. Treatment F (flash lights) increases the number of eggs 
per 6 chickens by 36.3 (342.8 – 306.5) in the almost three month period (or by 36.3/6 = 
6.05 eggs per chicken). Extended daylight increases the production by 42.5 eggs (i.e. 
349 – 306.5); or 7.1 eggs per chicken.  

***** Tables of means ***** 
  
Variate: Eggs 
 Grand mean  332.8 
 Treatment        O        E        F 
              306.5    349.0    342.8 

 

The standard error of the differences of the means is also provided in the Output 
Window. 

*** Standard errors of differences of means *** 
Table            Treatment 
rep.                     4 
d.f.                     6 
s.e.d.               13.91 

 

The standard error times a t-value based on 6 degrees of freedom (the residual 
degrees of freedom from the ANOVA – also shown with the s.e.d.) is called the LSD 
(least significant difference). This can also be found in the Output Window by 
requesting it in the ANOVA Options dialogue window (Fig.  8.3). You get this window 
by clicking on the [Options…] button in the Analysis of Variance dialogue window. 

Fig.  8.3 Changing the options what to include 
in the output of an ANOVA 
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*** Least significant differences of means (5% level) *** 
  
Table            Treatment 
rep.                     4 
d.f.                     6 
l.s.d.               34.03 

 

So, we are fairly sure that either of the two treatments will increase the egg production 
compared to the control. Now, which of the two treatments is the “better”? The 
difference of 6.2 eggs per pen (or about 1 egg per chicken) is way below 34.03. Any 
difference between E and F is too small for this experiment to detect. 

We have been using the standard output to compare the treatments. In this case, there 
were only a few treatments and the comparisons were done to answer the research 
questions: “Does extra light improve the egg production and which method is the 
better?”. We answered these questions and added a measure of precision. 

One common way to ensure that the analysis corresponds to well-defined objectives is 
to use contrasts. We illustrate their use with this same example. 

Fig.  8.4 The [Contrasts] button in the 
ANOVA dialogue window Fig.  8.5 Specifying the contrast 

 

 

Click on the [Contrasts] button in the Analysis of Variance dialogue window (Fig.  8.4). 
A sub-dialogue window opens, where we specify the contrasts. We want to compare 
some treatments, so the Contrast Factor in the example is Treatment and the type of 
contrast is Comparisons (Fig.  8.5). We want to make 2 comparisons (light treatments 
versus control and extended daylight versus flashing), so the number of contrasts is 2. 
When you click [OK] you will get a matrix as shown in Fig.  8.6. The default name of the 
matrix is Cont, but you could have changed this in the ANOVA Contrasts dialogue 
window. This matrix has two rows, because we specified that we wanted to make 2 
comparisons. It has 3 columns, because the treatment factor has 3 levels. 

Fig.  8.6 Renaming the contrast Fig.  8.7 Filling in the linear combination 
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By default the rows are labelled as “Contrast 1” and “Contrast 2” but you can change 
this by simply clicking in the cell. We are interested in 2 comparisons; “O vs E and F” 
and “E vs F”, see Fig.  8.7. 

Now we have to define coefficients for each level of the factor we want to compare. To 
compare Extended daylight and Flashlights, subtract one effect from the other, as 
shown in the second row of Fig.  8.7. To compare the control (O) with the other two, 
you subtract the effect of O from the mean of the effects of the two treatments; see the 
first row of Fig.  8.7. GenStat will now use these coefficients to split up the treatment 
sum of squares. 

Technically, you have filled the matrix so that the sum of the coefficients is zero for 
each comparison, i.e. for each row in Fig.  8.7. In Fig.  8.7, this is the case for each 
comparison: (-1) + 0.5 + 0.5 = 0 and –1 + 1 = 0. Also the sum of the pairwise products 
of the coefficients is zero: (-1)*0+0.5*(-1)+0.5*1 =0. This is the definition of orthogonal 
contrasts. Orthogonal contrasts can be interpreted separately because they are 
estimated independently, though useful contrasts do not have to be orthogonal.  

Fig.  8.8 The contrasts are incorporated in the 
treatment structure 

When the matrix is ready, click somewhere outside the matrix to send the data to the 
GenStat server and to return to the main dialogue. You will see (Fig.  8.8) that the 
treatment structure in the Analysis of Variance dialogue window has changed. Click on 
[OK] and the resulting Treatment sum of squares in the ANOVA table in the Output 
Window has been split up. The Treatment effects explain about half (4212.5) of the 
total variation (8864.2). Almost all of those Treatment effects are explained by the 
difference between the control and the two lighting regimes (4134.4 of 4212.5), while 
the difference between extended daylight and flashing explains almost nothing (78.1 of 
4212.5). So the significant difference between treatments we saw before is due to the 
difference between O on the one hand and E and F on the other hand (p-value of 
0.017). There is no evidence for a difference between E and F. 



GenStat Discovery Edition for everyday use 
 

 
 88 

***** Analysis of variance ***** 
  
Variate: Eggs 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3     2330.3      776.8    2.01 
  
Block.*Units* stratum 
Treatment                  2     4212.5     2106.3    5.44  0.045 
  O vs E and F             1     4134.4     4134.4   10.69  0.017 
  E vs F                   1       78.1       78.1    0.20  0.669 
Residual                   6     2321.5      386.9 
  
Total                     11     8864.2 

 

No multiple comparison tests ? 

If you have been using other statistical packages to analyse experimental 
data, then you may have been using multiple comparison tests (Newman-
Keuls, Tukey, Duncan, etc.) to compare treatments, rather than the 
contrasts that we described above. 

We are pleased to report that the GenStat Discovery Edition menus do 
NOT include multiple comparison tests. The developers of GenStat do not 
feel that these add to the proper analysis of experimental data. They did 
introduce these tests in the latest version so that they could demonstrate 
that these tests are not of value! 

So you will have to pay for the latest version of GenStat if you want to do 
these tests. You can also see in the guides of SSC Reading why we do feel 
they are not worthwhile. 
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1. Introduction 


In this guide we review the basic concepts of estimation and hypothesis, or 
significance, testing.  Our aim is to discuss the key ideas of statistical inference in a 
way that is easy to understand.  These are topics we would usually like to assume, 
when discussing or giving courses on data analysis for researchers.  However, we 
often find the ideas are poorly understood and this lack of understanding contributes to 
the scepticism felt by some scientists of the role of statistics in their work.  You could 
use the following three questions to decide whether you need to read further. 
 


  True False Not 
sure 


1. The standard deviation and the standard error 


are both used to summarise the spread of the 


data 


❒ ❒ ❒ 


2. The 95% confidence interval for the mean is 


the interval that covers roughly 95% of the 


observations.  


❒ ❒ ❒ 


3. If the difference between the effects of two 


farm management practices is not statistically 


significant, the conclusion is that there is no 


difference between them.   


❒ ❒ ❒ 


If you have confidently replied false to the three questions above you may have little 
need to read this guide.  Question 1 is discussed in Section 3, Question 2 in Section 4 
and Question 3 in Sections 5 and 6. 


For simplicity, we use “artificially small problems” to illustrate the ideas.  In Sections 
2 to 6 we cover the basic ideas of estimation, namely standard errors, confidence 
intervals, and hypothesis testing procedures.  In the later sections we apply the ideas.  
We outline the way in which the sample size can be chosen.  We also give our views 
on the role of non-parametric methods and on the implication of performing many 
tests on the interpretation of p-values.  One reason that these two contentious issues 
are included is that they sometimes sidetrack training courses and discussions of other 
topics, because of researchers’ strongly held views. 


The general concept of statistical modelling is introduced in the final section of this 
guide.  This provides a link to our other guides on analysis, and particularly to the one 
called Modern Methods of Analysis. 
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2. Applying Estimation Ideas 


Estimating characteristics of a population of interest, from a sample is a fundamental 
purpose of statistical work, whether the activity is a survey, an experiment or an 
observational study. 


Point estimation arises when a quantity, calculated from the sample, is used to estimate 
a population value. The sample estimates of the population mean ( µ ) and standard 
deviation (σ ) are most often taken as the sample mean, x , and the sample standard 
deviation, s, where 


 /x x n= ∑  


and ( ) ( )( )2
/ 1s x x n= − −∑  respectively. 


For example, consider estimating the average maize production per farmer among (the 
population of) smallholder farmers in a selected agro-ecological region.  To do this, 
suppose a sample of 25 farmers is randomly selected and their maize yields are 
recorded.  The average of the resulting 25 yields are calculated, giving say 278 kg/ha.  
This value is then taken as the estimate of the average maize production per farmer in 
the selected region.  It estimates what one would expect for an individual farm.  
Similarly the sample standard deviation is an estimate of the amount of variability in 
the yields from farm to farm. 


Other estimates of the population mean are possible.  For example, in many surveys 
the observations are not sampled with equal probability.  In this case we might use a 
weighted mean ˆ /x wx w= ∑ ∑  instead of x , with weights, w, that compensate for the 


unequal probabilities. 


Proportions can also be estimated, for example we may wish to estimate π, the 
proportion of families who own their own land, or the proportion of respondents who 
indicate support for community co-management of neighbouring forest areas during a 
semi-structured interview.  Then we might use p = m/n, as the estimate, where m is the 
number of persons making a positive response out of the n who were interviewed.  For 
example, if m = 30, out of n = 150 interviews, then we estimate the proportion as  
p = 0.2, or 20% 


As a point estimate this is the same as a measurement, x, where x = 1 if community co-
management was supported and zero otherwise.  The estimate, p is then the same x , 
given earlier, despite the “data” originally being “non-numeric”.  Much qualitative 
material can be coded in this way. 
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If we have a contingent question, a follow-up only for those who “qualify” by 
supporting co-management, we might find, for instance, k = 12 out of the m = 30 who 
are prepared to play an active role in co-managing forest reserves.  Arithmetically,  
r = k/m = 12/30 = 0.4 has the form of a proportion, but it is actually the ratio of two 
quantities which might both change if another sample of size n is taken in the same 
way from the same population.  If the follow-up question is important, then we must 
ensure that the original sample is large enough that there are an adequate number of 
respondents who qualify (here there were 30) for the precision required of the study. 


Sometimes our main objective is not to estimate the mean.  For example, in 
recommending a new variety of maize to farmers we may wish to ensure that it gives a 
better yield, compared to the existing variety for at least 90% of the farmers.  One way 
to proceed is first to calculate the difference in yields for each farmer.  If, from 
experience, or from our sample, we can accept a normal model, i.e. that the 
population of yield differences has approximately a normal distribution, then the 
required percentage point is found (from standard statistical tables) to be 1.28µ σ− , 
where µ  is the mean difference and σ  is the standard deviation of the differences. 


In this case we can still use our estimates of µ  and σ  to estimate the required 
percentage point, or any other property.  In general we call the (unknown) quantities 
µ  and σ  the parameters of the model.  If we assumed a different probability model 
for the distribution of the yields, then we would have to estimate different parameters.  
The formulae would change, but the ideas remain the same. 


If, in the example above, we were not prepared to assume any distribution, then we 
could still proceed by merely ordering the differences in yields for each farmer and 
finding the value exceeded by 90% of the farmers.  This is a non-parametric solution 
to this problem and we return to this approach in Section 7.  Generally this approach 
requires more observations than a “parametric” or “model-based” approach, such as 
that in the preceding paragraphs. 


For reference later we explain the term degrees of freedom.  This is roughly “pieces 
of information”.  For example, with the sample of 25 farmers we discussed earlier we 
have a total of 25 pieces of information.  In any study it is usually important to have 
sufficient pieces of information remaining to estimate the (residual) spread of the 
population.  In our simple example the spread is estimated by s, and in the formula we 
divided by (n–1).  This is because the spread is being measured about the sample 
mean, x .  The sample mean is one of our 25 pieces of information, so we have n–1 or 
24 degrees of freedom left to estimate variability. 
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3. Standard Errors 


When something is estimated, it is important to give a measure of precision of the 
estimate. 


The measure of precision of an estimate is called the standard error of the estimate.  
The smaller the standard error, the greater is the precision of our sample estimate.  Thus 
a small standard error indicates that the sample estimate is reasonably close to the 
population quantity it is estimating.   


As an example, suppose we select a random sample of 12 farmers (n = 12) and measure 
their maize yields per hectare, we might find x  = 1.5 tons/ha and s = 0.6 tons.  Then our 
estimate of µ  is given by x  = 1.5 tons and its standard error (s.e.) is given by the 
formula  


  s.e. = s/√n . 


In this case it is 0.6 / √12 = 0.17 tons/ha.  


From the above formula it is clear that we get precise estimates either because the data 
have small variability (i.e. s is small) or because we take a large sample, (i.e. n is 
large).  For example, if, instead we had taken a larger sample of 108 farmers that had 
given rise to the same mean and standard deviation, then the standard error of the mean 
would have been 0.058.  Equally, if yields had been less variable at s = 0.2 tons/ha then 
with 12 farmers, we would also have had an s.e. of 0.058.  


Depending on the investigation, we are often interested not so much in means, but in 
differences between means (e.g. differences in mean yield).  In simple situations - where 
there is equal replication of the treatments and n replicates per treatment - the standard 
error of the difference between two means is  


( )s.e.d. 2 /s n=  


i.e. about one-and-a half times the standard error of each individual mean. 


The formulae for the standard error of a proportion or a ratio that were considered in 
Section 2 are more complicated, but the point about precision being related to sample 
size and variability of the data is general.  When the design of the study is complex, 
standard errors cannot be easily computed by “hand” and suitable software is used to 
obtain standard errors for estimates of interest such as treatment differences. 


In this section we have repeatedly mentioned that the data are a random sample from 
the population.  The reason that randomness is important is that it is part of the logic of 
the standard error formulae.  This logic is that, because our sample was collected at 
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random, it is one of many that might have been obtained.  Typically each sample would 
have given a different mean, or in general a different estimate.  The standard error 
measures the spread of values we would expect for the estimate for the different random 
samples. 


The idea of the standard error as a measure of precision can help researchers plan a data 
collection exercise.   In any study, σ  is the unexplained, or residual, variation in the 
data; and an effective study is one that attempts to explain as much of the variation as 
possible.  Continuing the example above, we might find that the farmers use four 
different production systems, thus giving us two components of variation.  There is 
variation between one production system and another, and there is variation between the 
farmers within a production system.   


Suppose the overall variation of the yields, ignoring the different production systems, is 
estimated as s = 0.6 tons/h while the within production-system variability is s = 0.2 
tons/ha.  If we were planning a new investigation to estimate average maize production 
we could either ignore the fact that there are different production systems and take a 
simple random sample from the whole population, or we could take it into account and 
conduct a stratified study.  The standard error formula shows us that in this instance we 
would need nine times more farmers in the simple random sample compared to the 
stratified study to get roughly the same precision.  


The guide on Informative Presentation of Tables, Graphs and Statistics describes how 
the standard error is used in the reporting of the results.  The next section of this guide, 
which is on confidence intervals, shows how the standard error is used to describe 
precision.  The width of a confidence interval is often a simple multiple of the 
standard error.  
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4. Confidence Intervals 


The confidence interval provides a range that is highly likely (often 95% or 99%) to 
contain the true population quantity, or parameter that is being estimated.  The 
narrower the interval the more informative is the result.  It is usually calculated using 
the estimate (see Section 2) and its standard error (see Section 3). 


When sampling from a normal population, a confidence interval for the mean µ  can 
be written as  


    ±    ×  s.e.( )x t x  


where 1nt −  is the appropriate percentage point of the t-distribution with (n–1) degrees 
of freedom.   (See Section 2 for a brief explanation of degrees of freedom) 


The 95% confidence interval is commonly used, for which t-values are 2.2, 2,1 and 2.0 
for 10, 20 and 30 degrees of freedom.  So we can usually write that the 95% 
confidence interval for the mean is roughly: 


  2  s.e.( )x x± ×  


The example in Section 3 involving 12 farmers gave x  = 1.5 tons with s.e. = 0.17.  
The 95% confidence interval for µ  is therefore about 1.16 to 1.84 tons/ha; and so we 
can say that that this range is likely to contain the population mean maize yield.  (The 
exact 95% interval, which one can get from a statistical software package, is 1.12 to 
1.88 tons/ha.) 


More generally, for almost any estimate, whether it be a mean, or some other 
characteristic, and from almost any population distribution, we can write that the 95% 
confidence interval is roughly 


  estimate ±2 × s.e.(estimate)  


Hence it is useful that statistical software routinely provides the standard error of 
estimates.  With the example of Section 2 of p = 30/150 = 0.2, or 20% of the 150 
farmers the standard error is about 0.03, resulting in a confidence interval of about 
0.14 to 0.26. 


Note what a confidence interval is and is not.  A 95% confidence interval does not 
contain 95% of the data in the sample that generated it; very approximately the interval 
x  ± 2s would do that.  This is sometimes called a prediction, or tolerance interval.  In 
our examples of 12 or of 108 farmers above, with x  = 1.5 tons and s = 0.6 tons, this 
interval is 0.3 to 2.7 tons/ha and we would say that most of the farmers have yields in 
this range. 
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Users often confuse the confidence interval for the mean with an interval containing 
most of the data because the objectives of the study often relate to parameters other 
than the mean.  This was considered briefly in Section 2. 


In our example above, the 95% confidence interval for the mean is 1.12 to 1.88 tons 
with the sample of 12 farmers.  With more data, this interval would be narrower as is 
seen by comparison with the confidence interval for a sample with 108 farmers, where 
the same calculations as above give a 95% interval for the mean of about 1.4 to 1.6 
tons. 


When the assumptions about the data may not be quite right, scientists may feel they 
ought to abandon the ordinary confidence interval and use some different procedure 
altogether.  Usually it is more constructive to proceed instead by using the usual 
method, but noting that the true coverage of the “95%” confidence interval may not be 
exactly 95%.  For most purposes, the 95% figure is used to provide a conventional 
measure of uncertainty about an estimate, rather than the basis for decision-making.  
The communication of the approximate magnitude of the uncertainty is usually more 
important than the exact value. 
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5. Hypothesis Testing 


5.1 A Simple Example 


For good reasons, many users find hypothesis testing challenging; there is a range of 
quite complex ideas.  We begin with a simple example.   


A researcher facilitates an on-farm trial to study the effect of using Tephrosia as a 
green manure for fertility restoration.  She claims the use of the manure will increase 
pigeon pea yields, i.e. pod weight.  In the trial pigeon peas are grown with and without 
the Tephrosia in two plots on each of eight smallholders’ fields and the values 
recorded are the differences in yields.   


We test the correctness of this claim.  In this case the “null hypothesis” is usually that 
the true mean increase, µ  = 0.  By the “true” mean increase we mean the increase for 
the population of farmers of which we assume our eight are a random sample. 


The alternative hypothesis is usually that the true mean increase is other than zero. 


The null hypothesis is often given, as here, quite explicitly, with the alternative 
hypothesis being vague.  This is for two reasons: 


(i) Standard statistical tests calculate the probability of getting a sample as extreme 
as the one observed, assuming the null hypothesis is true – this calculation has to 
be done using explicit values for the parameter(s) of the null hypothesis 
distribution; 


(ii) Hypothesis testing adopts the same legal presumption of “innocence until proven 
guilty”.  This is that the null hypothesis that µ  = 0 is to be kept, unless the data 
values are inconsistent with it. 


Textbooks often distinguish between one-sided and two-sided tests.  In this example 
we might consider the test of the null hypothesis, that µ  = 0, against the one-sided 
alternative that µ  > 0, on the assumption that there is no logical reason that the 
manure will decrease yields.  Usually a one-sided test merely halves the significance 
level, so what was significant at 4% with a two-sided test, becomes significant at 2% 
with a one-sided alternative.  As will be seen below, we are not keen for readers to 
become too attached to a particular significance level, so halving a value is not 
important enough for users to spend much time on this idea.  One-sided tests are also 
rarely found in realistic situations, such as those introduced later in this guide. 
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Example 1 


Suppose in the illustration above, the differences in pod weight (in kg) between 
“treated” and “untreated” plots were as follows. 


3.0 3.6 5.4 −0.4 −0.8 4.2 4.8 3.2 


A computer analysis of these data would look like: 


 
Test of mu = 0 vs mu not = 0 
 
Variable          N      Mean     StDev   SE Mean 
podweight         8     2.875     2.290     0.810 
 
Variable             95.0% CI            T      P 
podweight     (   0.959,   4.791)     3.55  0.009 


 


The t-test used to investigate the hypotheses follows the general formula: 


  (estimate – hypothesised value) / s.e.(estimate) 


Here we are interested in the mean difference in pod weight, so our test statistics is: 


  ( ) ( )0 /s.e.t x x= −  


  i.e. (2.87 – 0)/0.81 = 3.55 


By comparison with the 7t  distribution, a value as extreme as 3.55 has a probability 
0.009, i.e. less than 1 in 100, of occurring.  So, if the null hypothesis is true, then there 
is a chance of just less than 1 in 100 of getting the sample we found.  Either something 
unlikely has occurred or the null hypothesis is false.  This event is sufficiently unlikely 
that we declare the result to be statistically significant and reject the null hypothesis. 


In Section 4 on confidence intervals we used a “t-value” of 2 to give approximate 95% 
confidence intervals.  Similarly we find here that values larger than 2 are extreme, (at 
about the 5% level of significance) and hence cast doubt on the hypothesised value. 


5.2 Understanding Significance 


The classical argument is that we should approach this type of decision-based testing 
in an objective way, by pre-setting the significance level, or p-value at which we 
would choose to reject the null hypothesis.  If we were working to a significance level 
of 5%, or p = 0.05, we would reject it at the 5% level and report that p < 0.05.  Rather 
than following such a stringent approach, we recommend that decisions be made on 
the grounds that a p-value is low. 
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Example 2 


We have the same hypothesis as in Example 1, but suppose we collected a slightly 
more variable sample.  The data values might be: 


3.0 3.6 6.8 −1.6 −2.0 5.8 7.1 0.3 


Computer analysis of these data gives the following results. 


 
 
Test of mu = 0 vs mu not = 0 
 
Variable          N      Mean     StDev   SE Mean 
podweights        8      2.87      3.64      1.29 
 
Variable             95.0% CI            T      P 
podweights    (   -0.17,    5.92)     2.23  0.061 
 


 


The standard error of the mean is now larger than in Example 1, and we get a t-statistic 
of 2.23 with a probability of 0.061.  If we used the 5% level as a strict cut-off point, 
then we would not reject the null hypothesis.  This does not mean we accept the null 
hypothesis as “true” and users who write as if it does are showing a serious weakness 
of interpretative skills.  The probability of getting such a sample under a hypothesis of 
no effect is still low so there is some suggestion of a treatment effect, but not low 
enough to meet our criterion at the 5% level. 


Here there is insufficient weight of evidence to draw a conclusion about a difference 
between the treatments.  Had a sample of 16 observations been collected, with the 
same mean and standard deviation as above, the standard error of the mean would 
have been lower (at 0.91) and consequently the t-statistic higher (at 3.15).  This would 
have been significant with a p-value of 0.007. 


Note that if hypothesis-testing is undertaken because a real decision is being made – to 
accept or reject a new variety, for example – not rejecting the null hypothesis may be 
tantamount to accepting the pre-existing variety.  This is not the same thing as 
accepting that the null hypothesis is correct. 


Generally, scientific research does not involve such cut-and-dried decision 
alternatives.  The main purpose of significance testing may just be to establish that an 
expected effect (“research hypothesis”) can be discerned and plausibly shown; not just 
to be a quirk of sampling.  Very tiny effects can be significant if sample sizes are very 
large; a significant effect also needs to be large enough to be of practical importance 
before it is “significant” in the ordinary-language use of the term.   
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Conversely, a non-significant effect does not necessarily imply that an effect is absent.  
A non-significant result can also happen if the sample size is too small or if there is 
excessive variability in the data.  In either of these cases, the effect may in fact be 
present but the data is unable to provide evidence-based conclusions of its existence.  


Such considerations show it is usually more informative to produce a confidence 
interval rather than just the decision outcome and p-value of a hypothesis test.  In 
example 1 above, the 95% confidence interval for the mean is given by 0.96 to 4.79 
using the method of calculation shown in Section 4.  This indicates that the true mean 
increase of 0 kg is unlikely, because the 95% confidence for the true mean does not 
contain the hypothesised value. 


Given a calculated t-value or other test statistic, it was traditional to compare this with 
a 5%, 1%, or 0.1% value in statistical tables.  However, since many statistical 
packages compute exact p-values, results may be accompanied by statements such as 
(p = 0.028) giving a specific numerical figure for the degree of extremeness of the 
disparity between observed results and null hypothesis expectation.  This approach is 
preferable where possible.  It is more informative and easier to interpret. 


5.3 General Ideas 


In a few studies, the objectives of the study correspond to standard hypothesis (or 
significance) tests.  The examples in the previous section provide one scenario and the 
adoption of a new farming practice, instead of a standard, is another. 


Usually however, the hypothesis testing is just a preliminary part of the analysis.  Only 
rarely can the objectives of a study be met by standard significance tests.  The 
statistically significant result provides objective evidence of something interesting in 
the data.  It serves as a “passport” to further analysis procedures.  Confidence intervals 
or an economic analysis are then used to describe the nature and practical importance 
of the results.   


When results are “not-significant” it may indicate that nothing further need be done.  
Often it enables a simpler model to be used.  For example if there is no evidence of a 
relationship between education level and adoption of a new innovative technology, 
then the adoption can be studied using all respondents together.  If there were a 
relation then it might indicate the necessity for a separate analysis (i.e. a separate 
model) for each education level group. 
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5.4 Recognising Structure 


Example 1 above illustrates how a t-test is conducted using differences between plots 
from eight smallholder farms.  The differences were used because a pair of plots was 
available from each farm.  This led to a paired t-test. 


Suppose on the other hand, we had 16 farms, each with just one plot, and eight were 
selected for trying out the “treatment”, with the remaining farms forming the 
“controls”.  The analysis then involves the comparison of two independent samples. 


It is important to recognise the structure in the data when conducting the analysis.  As 
an example, we show below what is often lost if truly paired results are treated like 
independent samples.  Here the x- and y-values represent the tensile strength of rubber 
samples collected from two plantations X and Y, on 10 occasions.  The aim was to see 
whether the two plantations differed in the quality of their rubber samples.   


 


i 1 2 3 4 5 6 7 8 9 10 Mean S.D. 


xi 174 191 186 199 190 172 182 184 200 177  185.5 9.687 


yi 171 189 183 198 187 172 179 183 199 176  183.7 9.764 


di 3 2 3 1 3 0 3 1 1 1  1.8 1.135 


 


The difference in the two means is 1.8.  For the unpaired analysis the standard error of 
this difference is calculated using the standard deviations in the last column, and found 
to be 4.3, leading to a non-significant t-value of 0.41.  The correct strategy of a paired 
analysis uses the differences in the table above.  The standard error of these 
differences is 0.36, leading to a highly significant t-value of 5.0. 


The reason for the difference is that in the unpaired analysis, the occasion-to-occasion 
variation in the samples is included in the calculation of the standard deviations used 
in the two-sample t-test.  Not eliminating this variability means the small but 
systematic differences between the pairs are not detected.  The unpaired analysis is 
unnecessarily weak where true and effective pairing exists.  In general this paired 
structure is similar to the idea of blocking in experiments and stratification in surveys, 
and needs to be properly accounted for in any subsequent data analysis. 
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6. Sample Size 


One common question that is posed to statisticians is how large a sample is needed.  
To be able to answer this type of question for an experiment or survey, information 
must be given on (1) how small a difference is it important to detect, and (2) how 
variable will the observations be for the key response(s) of interest.  This variability is 
usually reflected in the residual standard deviation of the data, because it is the 
unexplained variation of the data that relates to the precision of our data. 


These two elements are needed for the sample size to be evaluated, otherwise a 
statistician could not be expected to rubber-stamp the corresponding study as being 
adequately planned to achieve a formal objective.  This does not deny the importance 
of exploratory or pilot-studies, where the aim is to generate or specify hypotheses, or 
to evaluate a proposed methodology for the future. 


One reason for considering hypothesis tests is that their simplicity provides a basis for 
the evaluation of many sample size calculations.  This involves the power of the test, 
i.e. the probability of correctly rejecting the null hypothesis when it is false.  If your 
sample size is sufficient, then you will have a high power to detect a difference that 
you regard as being important.  


Modern statistical packages, such as Minitab, incorporate extensive facilities for 
sample size or power calculation. There are also specialist packages, such as nQuery.   
It is probably easier to improve ones “feel” for power or sample size calculations 
through hands-on use of a package than from a demonstration. 


As an example we take the paired t-test considered in Section 5.3.  Suppose that our 
aim is to choose the sample size, i.e. how many samples we need for a similar study.  
We suppose that the value of s will be about the same as before, that is about 1.1 and 
that we would like to detect a mean difference in tensile strength of rubber between 
the two plantations, of more than 1 unit with probability 0.95, i.e. we look for a power 
of 0.95.  Further, we suppose the test is to be conducted at the 5% level.  Putting these 
conditions into Minitab gives a required sample size of 18 units.   


If this is too many and we can only have 10 observations, we can keep our difference 
of 1 unit and we would find that the power is 0.73.  Or we can ask for what difference 
the power will be 0.95, giving a value of a mean difference of 1.4.  These results can 
then provide a basis for a discussion on the appropriate study to be conducted. 


A study whose power is low may have little ability to discern meaningful results.  It 
should be reconsidered, so it is large enough to establish important effects, or 
abandoned if it cannot be expected to do so.  Too large a study wastes resources, while 
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one that is too small tends also to be wasteful, as such studies often result in 
inconclusive findings.  Study size calculations are usually closely related to decisions 
on expending resources, so it is important to get them right.  


The choice of values for the power and significance levels in sample size calculation is 
debatable.  Setting the significance level at the conventional values of 5% or 1%, 
quantify the probability of falsely rejecting the null hypothesis, when it is true.  This is 
known as a Type I error.  The power to detect a minimum meaningful difference, if it 
exists, quantifies a second type of error, conventionally called a Type II error, namely 
that a real difference will remain undetected.  Commonly sample size calculations 
specify a power of 80%, though 90% is also used. 


When using results such as the example above it is important to remember that the 
calculations of sample size or power relate to a single hypothesis.  Most studies have a 
number of objectives and significance testing is usually only a small part of the 
analysis.  In general the same type of calculation should therefore be done for a 
number of the key analyses to ensure that the sample size is sufficient for all the 
objectives of the study.  Thus the proper planning of a data collection study requires 
that the main analyses are foreseen and planned for, before the data collection is 
allowed to start. 
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7. Non-Parametric Methods 


The normally distributed measurement is the starting point of much statistical analysis.  
There are situations where this seems worryingly inappropriate.  Measurements are 
perhaps from a very skew distribution, where an occasional reading is much larger 
than the usual range and cannot be explained or discounted.  Results may be only 
quasi-numerical, e.g. an importance score between 1 and 10 allocated to several 
possible reasons for post-harvest fish losses.  Different fishermen may assign scores in 
their own way, some avoiding extreme scores, while others using them.  We may then 
have reasonable assurance as to the rank order of scores given by each individual, but 
doubtful about applying processes such as averaging or calculating variances for 
scores given to each reason. 


In such cases it is sensible to consider using non-parametric methods.  A simple 
example is the paired data shown earlier in Section 5.  Here the ten differences in 
breaking strength were as follows: 


3 2 3 1 3 0 3 1 1 1 


Earlier we used the t-test, but a simple non-parametric test follows from the fact that 
nine out of the ten values are positive, with the other being zero.  If there were no 
difference in the before and after reading we would expect about half to be positive 
and half negative, so this simple summary of the data provides good evidence (p = 
0.004, on a formal test) against this hypothesis.  Just noting whether the observations 
are positive, zero or negative is also clearly robust against occasional readings being 
very large – if the first difference were 30, rather than 3, this would not affect the 
analysis.  Thus non-parametric methods often provide a simple first step.  They also 
add easily explained support for the conclusions from a parametric analysis. 


We advise caution, however, about the over-use of non-parametric methods.  
Inadequate understanding of the data-generating system by the researcher may be the 
real reason for messy-looking data.  A common reason for apparently extreme values, 
or lumpy distribution of data, is often that the population sampled has been taken as 
homogeneous, when it is an aggregate of different strata, within which the 
observations follow different patterns. 


Sometimes problem data arise from poorly designed measurement procedures, where a 
more thoughtful definition of raters’ tasks would produce more reliable data.  It is then 
better to think harder about the structure of the data than to suppress the complications 
and use an analysis that ignores them. 
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The ethos of non-parametric methods often stems from assuming the measurements 
themselves are flawed, or at least weak, so that estimation procedures are of secondary 
importance.  The primary focus of most non-parametric methods is on forms of 
hypothesis testing, whereas the provision of reasonable estimates usually generates 
more meaningful and useful results. 


In the final section of this guide we outline a more general framework for the analysis 
of many sets of data that used previously to be processed using non-parametric 
methods. 
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8. Analysis of Variance 


8.1 Introduction 


Practical problems are usually more complicated than the illustrations so far.  We use 
the Analysis of Variance to illustrate how the concepts are applied in larger problems. 


Understanding the idea of analysis of variance is now a more general requirement than 
just to analyse experimental data.  The same type of generalisation is possible for data 
on proportions, or where regression, or time-series methods would be used.  When 
data are from non-normal distributions, such as survey data on counts, then the ideas 
of Analysis of Variance are generalised and are then called the Analysis of Deviance.  
The key concepts remain unchanged.  


8.2 One-Way ANOVA 


The t-test for two independent samples shown in Section 5 generalises to more than 
two samples in the form of the one-way analysis of variance.  The comparison of a 
collection of independent samples is described as a “completely randomised design”.  
We illustrate this with an example. 


In a study of species diversity in four African lakes the following data were collected 
on the number of different species caught in six catches from each lake. 


 


Lake Tanganyika Victoria Malawi Chilwa 


 64 78 75 55 


 72 91 93 66 


68 97 78 49  


Catches 
77 82 71 64 


 56 85 63 70 


 95 77 76 68 


Mean 72 85 76 62 


The pooled estimate of variance, 2s , is 100.9.  The standard error of the difference 


between any two of the above means is ( )2s.e.d. 2 /6 5.80s= = . 







20  SSC Guidelines – Basic Inferential Statistics 


The usual analysis of variance (ANOVA) will look like:- 


 
 
One-way ANOVA: catch versus lake 
 
Analysis of Variance for catch    
Source     DF        SS        MS        F        P 
lake        3      1637       546     5.41    0.007 
Error      20      2018       101 
Total      23      3655 
 


 


The F-value and p-value are analogous to the t-value and p-value in the t-test for two 
independent samples.  Indeed, the two-sample case is a special case of the one-way 
ANOVA, and the significance level is the same, irrespective of which test is used. 


With more than two groups a significant F-value, as here, indicates there is a 
difference somewhere amongst the groups considered, but does not say where – it is 
not an end-result of a scientific investigation.  The analysis then usually continues with 
an examination of the treatment means that are shown with the data above.  Almost 
always a sensible analysis will look also at “contrasts” whose form depends on the 
objectives of the study.  For example if lakes in the Tanzanian sector were to be 
compared with the Malawian lakes, we could look at the difference in the mean of the 
first two treatments, compared with the mean of the third and fourth.  If this difference 
were statistically significant, then the magnitude of this difference, with its standard 
error, would be discussed in the reporting the results. 


In the analysis of variance a “non-significant” F-value may indicate there is no effect.  
Care must be taken that the overall F-value does not conceal one or more individual 
significant differences “diluted” by several not-very-different groups.  This is not a 
serious problem; the solution is to avoid being too simplistic in the interpretation.  
Thus again researchers should avoid undue dependence on an arbitrary “cut-off” p-
value, like 5%. 


8.3 Multiple Comparison Tests 


These tests are often known by their author and include Dunnett’s test, Neumann 
Keuls, etc.  They concern the methods of testing differences between means, which 
require ANOVA type analyses.  Some scientists use them routinely while others avoid 
their use. 


Our views are perhaps clear from Section 5.2.  Hypothesis testing is usually just a 
preliminary step, and the further analysis, often concerning the treatment means, 
relates directly to the stated objectives of the study.  This will usually involve 
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particular contrasts, to investigate differences of importance.  We do not recommend 
multiple comparison methods, because they usually do not relate to the objectives of 
the research. 


The case for the multiple comparison tests rests on the danger of conducting many 
significance tests on a set of means, for example comparing the largest with the 
smallest, without adjusting the test for the fact that we have deliberately chosen them 
as being largest and smallest.  The case is clear, but irrelevant to us in most analyses, 
because we do not wish to do lots of tests.  We want, instead to investigate the size of 
differences in relation to their practical importance. 


To take one field of application, that of agricultural field trials, then usually the 
treatment structure will be well defined, with factorial structure being the most 
common.  In such cases multiple comparison procedures are usually clearly not 
relevant.  The only type of factor where we might wish to consider multiple 
comparison methods would be perhaps variety comparison (of maize say) where we 
might wish to present the results in descending order of the mean yields.  Even here, 
we are more likely to try and understand the differences in yields as a function of the 
season length, or country of origin, etc of the varieties, than to suggest a series of tests.  
The one case for the tests would be if we wish to group the varieties into sets that 
behave similarly.  Some might use multiple comparison methods for this.  We would 
suggest cluster analysis, which has the additional advantage that it can be used on 
many variables together.  Even here, we would suggest that the cluster analysis should 
usually be part of a preliminary study, to be followed by attempts to understand the 
reasons for varieties being in one cluster or another. 


Our main concern is that users may be tempted to use a multiple comparison method 
instead of a more thoughtful analysis, and hence will miss interpreting the data in ways 
that are needed given the objectives of the study.  As long as you do not fall into this 
trap, then we invite you to do both.  We predict that when you report the results in 
relation to the objectives, you will not need to use any of the results from the multiple 
comparison methods.  So they can then be deleted from the tables in the report! 


We also discuss this problem in the guide on Informative Presentation of Graphs, 


Tables and Statistics because some scientists may have withdrawal symptoms if they 
do not present tables with a collection of letters beside the corresponding means. 


 







22  SSC Guidelines – Basic Inferential Statistics 


9. A General Framework 


The illustrative examples in this guide have all been simple, to concentrate on the 
concepts.  These concepts include: 


• Our data are (or are assumed to be) a sample from some population, and we wish to 
make inferences about the population. 


• We therefore use our sample to estimate the properties (parameters) of the 
population that correspond to the objectives of our study. 


• The standard error of the estimate is its measure of precision.  Sometimes we 
report the standard error itself and sometimes we report a confidence interval for 
the unknown parameter. 


• We often use hypothesis (significance) tests to identify whether differences 
between parameters can be detected in our study.  This testing phase is often the 
first step in the inference part of the analysis. 


 


All the examples in this guide can be written in a general way as: 


 data = pattern (or model) + residual 


This is our assumed model for the population.  For example, the problem of strength 
of rubber can be written as: 


 Strength = Occasion effect + Plantation effect + residual 


Our objective was to investigate the difference between the two plantations, and the 
effect was clear.  But we also saw in Section 6, that if we omitted the occasion effect 
from the model, i.e. if we used the simpler model: 


 Strength = Plantation effect + residual  


then we could not detect the Plantation effect.  This showed that we need the 
“Occasion effect” in the model, even though studying the size of the Occasion effect 
might not have been one of our objectives. 


The model above is the same if there are more than two plantations, as in Section 7 
and would still apply if the data were not “balanced”, i.e. if plantations did not send 
samples on all occasions.  With standard statistics packages the inferences can still be 
made. 


Earlier, one limitation was that the data had to come from a distribution that was 
approximately normal, but this is no longer the case.  Parametric methods are now 
very flexible in dealing with well-behaved data, even when not normally distributed 
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and this often provides an attractive framework for data analysis than the simple tests 
that are often still in current use.  For example, instead of using a simple chi-square 
test to examine relationships in a two-way contingency table, the use of log-linear 
models provides a more general and usable framework, for inferences about 
proportions.  This general framework can be used with both two-way tables (like a 
chi-square test) and with more complicated tables of counts. 


Within this general context, significance tests are often used to provide guidance on 
how complicated a model is required.  Then, using the chosen model, we estimate, as 
above, the properties that correspond to our objectives, and give a measure of 
precision to indicate our level of confidence in reporting the results. 
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8.3 Defining the treatment structure  

We have analysed two designs so far: a completely randomised design (or a one-way 
ANOVA without blocking) and a one-way ANOVA in randomised blocks. In each case 
there has been one single factor identifying the individual treatments. In the ANOVA 
dialogue window, when you click on the arrow next to the design-box, you can see a 
whole range of other designs that can be analysed. 

Designs in ANOVA menu: 
One-way ANOVA (no Blocking) 

One-way ANOVA (in Randomized Blocks) 

Two-way ANOVA (no Blocking) 

Two-way ANOVA (in Randomized Blocks) 

Completely Randomized Design 

Split-Plot Design 

Split-split Plot Design 

Latin Square 

Graeco-Latin Square 

Lattice Design 

You can also choose General Analysis of Variance and we suggest you use this 
option routinely. Once you understand a few basics you will be able to specify the 
correct analysis for more complex designs.  

The treatment and layout (blocking) structure are entered using a formula in 
which following operators are used: 

+ addition  e.g. A+B+C main effects of A, B, and C 

. interaction  e.g. A.B interaction of A and B 

* cross-product  A*B is equivalent to A+B+A.B 

/ nesting   A/B is equivalent to A+A.B 

We explore this for two examples of a factorial treatment structure, one in a 
randomised block layout, and the other in split plots. 

8.3.1 Factorial treatment structure 

Factorial experiments are studies during which direct effects of more than one 
experimental treatment are examined simultaneously, while at the same time cross-
effects or interactions of those treatments are examined. The advantages of factorial 
experiments are summarised as 

- if there are no interactions, you benefit from “hidden replication” 
- if there are interactions, the trial can investigate them 

Let’s start with a theoretical example. An experiment is set up to examine the influence 
of variety, the application of an insecticide and the application of a fungicide on the 
yield of maize. Let’s investigate some possible approaches. 
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Treatment Description 

A Variety 1, no insecticide, no fungicide 

B Variety 2, no insecticide, no fungicide 

C Variety 1, insecticide, no fungicide 

D Variety 2, no insecticide, fungicide 

 

If the experiment were set up as in the table above, there would be some problems 
caused by the way the experiment was designed. When comparing treatments using a 
one–way ANOVA, only the differences between treatment A and B will be caused by 
the variety effect. The differences between C and D could be due to variety, insecticide 
or fungicide and the effect of variety is measured only for no insecticide or fungicide. 

An alternative designe, with 8 treatments, is 

Treatment Description 

A Variety 1, no insecticide, no fungicide 

B Variety 2, no insecticide, no fungicide 

C Variety 1, insecticide, no fungicide 

D Variety 2, insecticide, no fungicide 

E Variety 1, insecticide, fungicide 

F Variety 2, insecticide, fungicide 

G Variety 1, no insecticide, fungicide 

H Variety 2, no insecticide, fungicide 

 

If the experiment were set up as in this table, you could analyse using a one-way 
ANOVA and calculate some confidence intervals as seen above. The effect of the 
variety could be found by examining the difference between treatments A and C and E 
and G versus B and D and F and H. 

This ANOVA is completely valid, but the results are meaningful only if you are willing 
to accept that the effect of each factor is the same at all levels of the other factors: 
changes in maize yield due to the use of a different variety are the same if an 
insecticide is applied or not and if a fungicide is applied or not AND changes in maize 
yield due to the use of an insecticide are the same for both varieties and if a fungicide 
is applied or not AND changes in maize yield due to the use of a fungicide are the 
same for both varieties and if an insecticide is applied or not. So, this ANOVA is valid 
under the assumption of the treatment effects being additive (we used the word “and” 
quite often in the previous sentence). There is however no way that we can prove that 
this assumption is true and if the assumption is not true, the results are only valid for 
each specific set of levels that were compared. For instance the Variety effect would 
only be valid if no insecticide and no fungicide are applied.  

Although there are situations where it makes no sense to look at interactions, most of 
the time it does and a factorial treatment structure will give much more information for 
this type of analyses. 
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The design of the theoretical example should be rewritten as a design with 3 factors in 
which all the levels of each factor are combined with each other. This factorial 
treatment structure would look as follows. 

(Treatment number) Variety Insecticide Fungicide 
1 V1 No No 
2 V2 No No 
3 V1 Yes No 
4 V2 Yes No 
5 V1 No Yes 
6 V2 No Yes 
7 V1 Yes Yes 
8 V2 Yes Yes 

 

Now we can find the main effects of each factor, the average change for different levels 
of the other factors, by examining following differences: 

- Main effect of Variety = treatments 1, 3, 5, 7 versus 2, 4, 6, 8 
- Main effect of Insecticide = treatments 1, 2, 5, 6 versus 3, 4, 7, 8 
- Main effect of Fungicide = treatments 1, 2, 3, 4 versus 5, 6, 7, 8 

We can also investigate interactions. Does using an insecticide has for instance the 
same effect on both varieties? In this example, this would be examined by examining 
treatments 1 and 5 versus 2 and 6 (the effect of variety when no insecticide is applied) 
and by examining treatments 3 and 7 versus 4 and 8 (the effect of variety when an 
insecticide is applied). 

GenStat doesn’t have a special option to analyse three-way ANOVA’s. Instead, we use 
the General Analysis of Variance design. In the Treatment structure box, we type a 
formula using the operators mentioned in the introduction above. For the example this 
would be (Fig.  8.9): 

Variety*Insecticide*Fungicide 

This can be rewritten as: 

Variety+Insecticide+Fungicide+Variety.Insecticide+Variety.Fungicide+ 
Insecticide.Fungicide+Variety.Insecticide.Fungicide 

So, a combination of the main effect of each factor, the first order interactions and the 
second order interactions.  

Fig.  8.9 An example of a factorial treatment structure 
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We now analyse the dataset “Salmonella typhirum survival.xls” that was considered in 
chapter 6. Open this file. We want to analyse the variate Density, the design is factorial 
with two factors Water and Sorbic and the experimental units are grouped in 
randomised blocks. Complete the Analysis of Variance dialogue window as shown in 
Fig.  8.10 and indicate in the ANOVA Options window that you also want the LSDs to 
appear in the Output Window. 

Fig.  8.10 Factorial treatment structure Fig.  8.11 Indicating you want the 
LSDs 

 

 

The Output includes the ANOVA table, with sums of squares for each factor and also 
for the interaction.  

There are three tables of means in the output, corresponding to each of the terms in 
the treatment formula, one each for the main effects of Sorbic and Water, and one for 
the full treatment set (interaction table).   

The tables of standard errors of differences of means and LSDs each have three 
columns to match the three tables of means.  For example in the ‘Least significant 
differences’ table the value of 0.136 given under ‘Sorbic’ is the LSD for comparing 
Sorbic means – these are means of 18 (= 3 blocks x 6 levels of Water) data values 
(‘rep’) and the LSD (and equivalent SED) is based on 34 d.f. (The Residual d.f.). 

 


Salmonella

		Data from Mead, Curnow & Hasted - p113

		Effects of three levels of sorbic acid and six levels of water activity on survival of Salmonella typhimurium

		unit		block number		sorbic acid (ppm)		water activity		water density (log(density/ml))

		Unit		Block!		Sorbic!		Water!		Density:2

		1		1		0 ppm		0.98		8.19

		2		2		0 ppm		0.98		8.37

		3		3		0 ppm		0.98		8.33

		4		1		0 ppm		0.94		6.65

		5		2		0 ppm		0.94		6.7

		6		3		0 ppm		0.94		6.25

		7		1		0 ppm		0.9		5.87

		8		2		0 ppm		0.9		5.98

		9		3		0 ppm		0.9		6.14

		10		1		0 ppm		0.86		5.06

		11		2		0 ppm		0.86		5.35

		12		3		0 ppm		0.86		5.01

		13		1		0 ppm		0.82		4.85

		14		2		0 ppm		0.82		4.31

		15		3		0 ppm		0.82		4.52

		16		1		0 ppm		0.78		4.31

		17		2		0 ppm		0.78		4.34

		18		3		0 ppm		0.78		4.2

		19		1		100 ppm		0.98		7.64

		20		2		100 ppm		0.98		7.79

		21		3		100 ppm		0.98		7.59

		22		1		100 ppm		0.94		6.52

		23		2		100 ppm		0.94		6.19

		24		3		100 ppm		0.94		6.51

		25		1		100 ppm		0.9		5.01

		26		2		100 ppm		0.9		5.28

		27		3		100 ppm		0.9		5.78

		28		1		100 ppm		0.86		4.85

		29		2		100 ppm		0.86		4.95

		30		3		100 ppm		0.86		4.29

		31		1		100 ppm		0.82		4.29

		32		2		100 ppm		0.82		4.43

		33		3		100 ppm		0.82		4.18

		34		1		100 ppm		0.78		4.13

		35		2		100 ppm		0.78		4.39

		36		3		100 ppm		0.78		4.18

		37		1		200 ppm		0.98		7.14

		38		2		200 ppm		0.98		6.92

		39		3		200 ppm		0.98		7.19

		40		1		200 ppm		0.94		6.33

		41		2		200 ppm		0.94		6.18

		42		3		200 ppm		0.94		6.43

		43		1		200 ppm		0.9		5.2

		44		2		200 ppm		0.9		5.10

		45		3		200 ppm		0.9		5.43

		46		1		200 ppm		0.86		4.41

		47		2		200 ppm		0.86		4.40

		48		3		200 ppm		0.86		4.79

		49		1		200 ppm		0.82		4.26

		50		2		200 ppm		0.82		4.27

		51		3		200 ppm		0.82		4.37

		52		1		200 ppm		0.78		3.93

		53		2		200 ppm		0.78		4.12

		54		3		200 ppm		0.78		4.15
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***** Analysis of variance ***** 
  
Variate: Density 
 
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              2    0.01385    0.00692    0.17 
  
Block.*Units* stratum 
Water                      5   81.56910   16.31382  403.72  <.001 
Sorbic                     2    2.75936    1.37968   34.14  <.001 
Water.Sorbic              10    1.31626    0.13163    3.26  0.005 
Residual                  34    1.37389    0.04041 
  
Total                     53   87.03245 
  
 * MESSAGE: the following units have large residuals. 
 Block 3     *units* 9            0.41   s.e. 0.16 
 Block 3     *units* 10          -0.42   s.e. 0.16 
  
  
***** Tables of means ***** 
 
Variate: Density 
  
Grand mean  5.50 
  
    Water     0.78     0.82     0.86     0.90     0.94     0.98 
              4.19     4.39     4.79     5.53     6.42     7.68 
  
   Sorbic    0 ppm  100 ppm  200 ppm 
              5.80     5.44     5.26 
  
    Water   Sorbic    0 ppm  100 ppm  200 ppm 
     0.78              4.28     4.23     4.07 
     0.82              4.56     4.30     4.30 
     0.86              5.14     4.70     4.53 
     0.90              6.00     5.36     5.24 
     0.94              6.53     6.41     6.31 
     0.98              8.30     7.67     7.08 
  
 *** Standard errors of differences of means *** 
  
Table                Water      Sorbic       Water 
                                            Sorbic 
rep.                     9          18           3 
d.f.                    34          34          34 
s.e.d.               0.095       0.067       0.164 
  
*** Least significant differences of means (5% level) *** 
  
Table                Water      Sorbic       Water 
                                            Sorbic 
rep.                     9          18           3 
d.f.                    34          34          34 
l.s.d.               0.193       0.136       0.334 
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The GenStat commands that were produced to execute the analysis can be seen in the 
input log (Window ⇒ Input log). 

"General Analysis of Variance." 
BLOCK Block 
TREATMENTS Water*Sorbic 
COVARIATE "No Covariate" 
ANOVA [PRINT=aovtable,information,means; FACT=32; FPROB=yes; 
PSE=diff,lsd; LSDLEVEL=5]\ 
 Density 

When interpreting the results from a factorial analysis of variance with an interaction, it 
is often useful to give a pictorial representation of the 2-way table of means.  One 
method of doing this within GenStat is to select the [Further Output] button in the 
Analysis of Variance dialogue box, then click [Means Plots].   

This plot allows the table of means to be plotted against one of the factors.  
If an analysis of variance has been carried out, with two treatment factors in 
a factorial combination, then one of the factors is chosen as the Factor for 
X-axis. The means will be plotted against this factor. The other factor 
defines the Groups. The means for each level of the Groups factor will be 
distinguished with different colours and/or symbols.  By default, just the 
means are plotted, but if Lines is selected under Method instead, then the 
means will be connected by lines. 

In this example choose water to be the factor whose levels are on the x-axis, and 
sorbic to be the groups factor, as shown in Fig.  8.12. Select Lines as the Method of 
plotting. The resulting graph is shown in Fig.  8.13. 

Fig.  8.12 Selecting the factor for the 
X-axis and the factor for the groups Fig.  8.13 The resulting graph 

 

 

 

The graph includes an SED bar, which is centred about the grand mean.   
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It is sometimes more helpful to give the LSD bar.  As yet, this cannot be 
done directly with the menu, but this can be achieved by modifying the 
command the menu produces.  The modified line can then be executed 
with Run ⇒ Line.  LSDs was selected under [Options] of the Analysis of 
Variance dialogue box, so the appropriate LSD value has already been 
calculated and printed (0.334).  

The use of the dialogue above, followed by the editing of the line in the Input log has 
sent the single line AGRAPH [method=lines] Water;Sorbic to the GenStat server.  
Once you become more experienced, a much quicker alternative way is to type the 
command directly.  This is best done in a new Input window. Alternatively you can 
modify commands from the Input log or in the Output Window.  If you add “; bar=0.334 
“ to the end of this line (as below),  

AGRAPH [method=lines] Water;Sorbic;bar=0.334 

Leave the cursor in the line and choose Run ⇒ Submit Line, to give a graph with the 
LSD bar as shown in Fig.  8.14 

If you add that command to those that are given in the Input log earlier (see page 94) 
and submit everything to the GenStat server, GenStat will carry out the ANOVA and 
plot the graph automatically.  

 

Fig.  8.14 The same graph but with an LSD bar 

 

 

Refer to chapter 6.3 for adding textboxes to the graph.  Use Run ⇒ Restart Session 
to clear the data. 
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8.3.2 Nested blocking structure 

In some factorial experiments, it is necessary for practical reasons to use larger 
experimental units for some factors than for others.  This is called a Split Plot design.  
For a Split Plot experiment with the main plots laid out in a Randomised Block design, 
a factor is needed for blocks (block), another for main plots within blocks (mainplot – to 
which levels of treatment factor1 are applied) and another for subplots within main plots 
(subplot – to which levels of treatment factor2 are applied).  In general, there can be 
more than one factor at either level. 

The general formula describing the layout and the factorial treatments of a split-plot 
design are :  

Layout : block/mainplot/subplot 

Treatment factors :  factor1*factor2 

The operator “/” is the nesting operator. For instance the formula 

A/B 

would expand to A+A.B The latter term can be thought of as “B within A”. 

Enter this in the General Analysis of Variance dialogue box or alternatively, select Split-
plot from the list of possible designs.  The three layout factors then have to be entered 
in the Blocks, Whole Plots, and Sub-plots boxes. 

Both dialogues generates the following GenStat commands: 

BLOCK block/mainplot/subplot 
TREATMENTS factor1*factor2 

The BLOCK statement can be translated as ‘subplots nested within mainplots which 
are nested within blocks’. GenStat is excellent for analysing designs with this greater 
level of complexity, as all the information required is given by the formulae entered into 
the boxes defining the layout (Blocks, Whole Plots etc) and, separately, the 
Treatment Structure (or with the equivalent BLOCK and TREATMENTS statements).  
The output is comprehensive as all the standard errors of differences are calculated, 
even for multi-way treatment tables, along with the degrees of freedom required for 
each. 
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Example: from Mead, Curnow and Hasted, pages 151-155 (Example 7.4). Six varieties 
of lettuce are grown in frames and the frames are removed on several dates. There are 
4 blocks (1, 2, 3, 4), each with 3 main plots for the 3 different uncovering dates (x, y, z).  
Within each main plot there are 6 subplots for the 6 varieties (A, B, C, D, E, F).  The 
data (yield of lettuce) were originally given in systematic order.  For the purposes of 
illustrating the factors required in GenStat, these data are presented below as from a 
possible experiment.   

 
 Block 1   Block 2   Block 3   Block 4  

111 1 1 1 x F 9.9 211 2 1 1 Y E 11.1 311 3 1 1 x F 4.8 411 4 1 1 z D 11.3 

112   2  E 16.2 222   2  D 11.3 312   2  D 10.3 412   2  A 6.3 

113   3  C 9.2 223   3  F 14.3 313   3  C 11.4 413   3  F 12.2 

114   4  A 11.8 224   4  A 8.8 314   4  B 11.8 414   4  B 8.8 

115   5  D 15.6 225   5  B 12.9 315   5  A 9.7 415   5  C 2.6 

116   6  B 8.3 226   6  C 15.7 316   6  E 14.0 416   5  E 14.1 

121 1 2 1 z D 12.6 221 2 2 1 Z F 11.6 321 3 2 1 y B 11.2 421 4 2 1 x F 9.8 

122   2  C 3.3 222   2  B 8.4 322   2  D 11.0 422   2  B 8.5 

123   3  A 7.0 223   3  A 9.1 323   3  F 15.9 423   3  C 7.2 

124   4  E 12.6 224   4  E 12.3 324   4  C 7.6 424   4  D 14.7 

125   5  B 5.7 225   5  C 6.9 325   5  E 10.8 425   5  A 6.4 

126   6  F 10.2 226   6  D 15.4 326   6  A 12.5 426   6  E 11.5 

131 1 3 1 y E 16.5 231 2 3 1 X C 10.6 331 3 3 1 z E 14.4 431 4 3 1 y E 8.5 

132   2  D 13.2 232   2  B 8.4 332   2  A 7.1 432   2  F 7.5 

133   3  B 5.4 233   3  A 7.5 333   3  C 1.0 433   3  C 9.4 

134   4  C 12.1 234   4  F 10.8 334   4  D 14.2 434   4  A 9.4 

135   5  F 12.5 235   5  D 10.8 335   5  F 10.4 435   5  B 7.8 

136   6  A 9.7 236   6  E 11.2 336   6  B 6.1 436   6  D 10.7 
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In the plan above, the first four entries (columns) in each plot are the unit, block, 
mainplot and subplot numbers (blocking factors). These layout factors are 
systematically ordered within the design. They are followed by the labels for the 
treatment factors for date and variety, together with the yields that are to be analysed.  

Enter the data into a spreadsheet (e.g. column by column from the plan above), with 
three factors (block, mainplot, and subplot) which define the layout of the experiment 
(these will be in a systematic order). Two factors are created to indicate the treatment 
factors date and variety. The spreadsheet is shown in Fig.  8.15. Save the data, giving 
the file the name “Lettuce uncovered.gsh” 


Wim Buysse
Double-click to open the GenStat spreadsheet "Lettuce uncovered.gsh"
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Fig.  8.15 The spreadsheet with the 
lettuce data 

Fig.  8.16 Factorial treatment structure and nested 
blocking structure 

 
 

 

In the Analysis of Variance dialogue box, choose the General Analysis of Variance and 
complete as in Fig.  8.16. Notice that the two SEDs required for the variety by date 
table of means are printed in the right-hand column of the Standard errors table.  The 
second (under the section headed ‘Except when comparing means with the same 
level(s) of’) is for comparing two means with the same date (1.59).  The first SED for 
the variety by date table (1.65) is to compare two means for different dates.  The 
relevant d.f. are printed immediately below each SED. Use Run ⇒ Restart Session to 
clear the data. 
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***** Analysis of variance ***** 
  
Variate: Lettuce 
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3     29.343      9.781    1.35 
  
Block.Mainplot stratum 
Date                       2     38.003     19.002    2.62  0.152 
Residual                   6     43.566      7.261    1.44 
  
Block.Mainplot.Subplot stratum 
Variety                    5    260.508     52.102   10.32  <.001 
Variety.Date              10    163.698     16.370    3.24  0.003 
Residual                  45    227.277      5.051 
  
Total                     71    762.395 
  
* MESSAGE: the following units have large residuals. 
Block 1     Mainplot 3     Subplot 1             4.3   s.e. 1.8 
Block 1     Mainplot 3     Subplot 3            -4.4   s.e. 1.8 
  
***** Tables of means ***** 
Variate: Lettuce 
  
Grand mean  10.3 
  
  Variety        A        B        C        D        E        F 
               8.8      8.6      8.1     12.6     12.8     10.8 
  
     Date        x        y        z 
              10.4     11.1      9.3 
  
  Variety     Date        x        y        z 
        A               8.9     10.1      7.4 
        B               9.3      9.3      7.2 
        C               9.6     11.2      3.4 
        D              12.8     11.5     13.4 
        E              13.2     11.7     13.3 
        F               8.8     12.6     11.1 
  
*** Standard errors of differences of means *** 
Table              Variety        Date     Variety 
                                              Date 
rep.                    12          24           4 
s.e.d.                0.92        0.78        1.65 
d.f.                    45           6       46.05 
Except when comparing means with the same level(s) of 
 Date                                         1.59 
 d.f.                                           45 
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8.3.3 Checking for outliers 

The nesting approach can also be used to increase the information shown in the 
Output Window. Start a new session and open the “Egg production.gsh” file again. 
Each unit is a pen of 6 chickens. We can consider each unit as a level of a factor “Pen”. 
So, insert a column containing this factor before the column “Block” as in Fig.  8.17.  
Now we will add a mistake to the dataset to be sure it will contain an outlier. Change 
the number of eggs laid by Pen 3 (Block 3, Treatment O) from 295 to 195. 

Fig.  8.17 Adding a unique identifier for each 
unit 

 

***** Analysis of variance ***** 
  
Variate: Eggs 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3      3980.      1327.    0.76 
  
Block.*Units* stratum 
Treatment                  2     11129.      5565.    3.19  0.114 
Residual                   6     10472.      1745. 
  
Total                     11     25581. 
  
  
* MESSAGE: the following units have large residuals. 
  
Block 3     *units* 1            -66.   s.e. 30. 

 

When you carry out the ANOVA, you will get a warning that one observation has large 
standardized residuals. But you have to start counting to find this observation; in this 
case it is the first unit of block 3 (Fig.  8.18). Now, this is not very convenient when you 
analyse large and complex datasets. Furthermore, the message will be different when 
the order of data changes.  


Wim Buysse
Double-click to open the Genstat spreadsheet "Egg production.gsh"
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For instance, the same ANOVA on the same dataset but this time ordered according to 
the descending number of eggs would result in following warning. 

***** Analysis of variance ***** 
  
Variate: Eggs 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3      3980.      1327.    0.76 
  
Block.*Units* stratum 
Treatment                  2     11129.      5565.    3.19  0.114 
Residual                   6     10472.      1745. 
  
Total                     11     25581. 
  
  
* MESSAGE: the following units have large residuals. 
  
Block 3     *units* 3            -66.   s.e. 30. 

 

However, the unit number, in this case the pen number, could be considered as a 
layout factor that is nested within the blocks. So we could also carry out an ANOVA as 
in Fig.  8.19 

Fig.  8.18 Counting to find the observation 
with a large standardized residual 
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Fig.  8.19 Putting the units in the block structure 

"General Analysis of Variance." 
BLOCK Block/Pen 
TREATMENTS Treatment 
COVARIATE "No Covariate" 
ANOVA 
[PRINT=aovtable,information,means; 
FACT=32; FPROB=yes; PSE=diff] Eggs 

 

 

The resulting error message will now give very direct information regardless of how the 
data were ordered, in this example that the observation with the large residual is 
observation Pen 4 from Block 3. 

***** Analysis of variance ***** 
  
Variate: Eggs 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3      3980.      1327.    0.76 
  
Block.Pen stratum 
Treatment                  2     11129.      5565.    3.19  0.114 
Residual                   6     10472.      1745. 
  
Total                     11     25581. 
  
* MESSAGE: the following units have large residuals. 
  
Block 3     Pen 4            -66.   s.e. 30. 
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8.4 Randomising an Experiment  

GenStat includes the facilities for the randomisation of a wide range of designs.  For 
those that are used in this guide the procedure is to use Stats ⇒ Design ⇒ Generate 
a Standard Design. 
Here we first show how to design a randomised block experiment of the same size as 
analysed earlier, namely with 4 blocks and 3 treatments.  Select One-way Design (in 
Randomized blocks). Complete the dialogue as shown in Fig.  8.20, by inserting the 
information for the blocks and treatments.  All the rest can remain as the defaults, so 
click on [OK]. The results are as shown in the spreadsheet in Fig.  8.21. 

Fig.  8.20 The dialogue window for generating 
a standard design Fig.  8.21 The resulting spreadsheet 

 

Note that GenStat has added a column to give the plot number, as well as 
one, called Plot, which gives the plot number within each block.  The order 
of the values in your treatment column will probably not be the same as 
above, but you could get the identical randomisation if you use the same 
number for the Seed, as is shown in the dialogue box above. This 
‘Randomization Seed’ is an initial value GenStat needs for a subroutine that 
generates a random numbers. 

The design information has been copied into a spreadsheet.  This can now 
be saved as a GenStat spreadsheet, if you intend later to enter the 
experimental data directly into GenStat.  Alternatively it can be saved in a 
standard spreadsheet format, such as an Excel file, if you will use that for 
the design of data collection forms and then for the data entry. 

The next example is an experiment with a factorial treatment structure.  Use Run ⇒ 
Restart Session to clear the data and then Stats ⇒ Design ⇒ Generate a Standard 
Design.  As an example we take a Randomised Block design with 5 blocks of 12 
treatment combinations comprising the factorial set for two factors, one with 3 levels 
(fact1) and the other with 4 levels (fact2). 
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Complete the menu as shown in Fig.  8.22.  It gives the plan in a spreadsheet (Fig.  
8.23) and also the dummy ANOVA table in the output window, as shown below. 

Fig.  8.22 Generating a two-way design in 
randomised blocks Fig.  8.23 The resulting spreadsheet 

 

 

***** Analysis of variance ***** 
Source of variation     d.f. 
  
Block stratum              4 
  
Block.Plot stratum 
fact1                      2 
fact2                      3 
fact1.fact2                6 
Residual                  44 
  
Total                     59 
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The final example shows the completion of the same dialogue for a split plot design, 
with the same structure as was analysed earlier in this guide.  Note when completing 
the dialogue a further option is to request an ANOVA with trial data.  This illustrates the 
form that the results will be presented in. 

Fig.  8.24 Generating a split-plot design Fig.  8.25 The resulting spreadsheet 

 



GenStat Discovery Edition for everyday use 
 

 
 106 

***** Analysis of variance ***** 
  
Variate: _Rand_ 
  
Source of variation     d.f.       s.s.       m.s.    v.r.  F pr. 
  
Block stratum              3    215.770     71.923   13.15 
  
Block.Mainplot stratum 
Date                       2      0.865      0.433    0.08  0.925 
Residual                   6     32.807      5.468    5.47 
  
Block.Mainplot.Subplot stratum 
Variety                    5      1.981      0.396    0.40  0.849 
Date.Variety              10      5.563      0.556    0.56  0.840 
Residual                  45     45.000      1.000 
  
Total                     71    301.987 
 
***** Tables of means ***** 
  
Variate: _Rand_ 
  
Grand mean  13.28 
  
     Date        1        2        3 
             13.43    13.20    13.21 
  
  Variety        1        2        3        4        5        6 
             12.95    13.36    13.29    13.42    13.21    13.44 
  
Date  Variety     1        2        3        4        5        6 
  1             13.58    13.27    13.11    13.47    13.43    13.74 
  2             12.88    13.43    12.86    13.55    13.16    13.32 
  3             12.39    13.37    13.92    13.25    13.04    13.26 
  
  
*** Standard errors of means *** 
  
Table                 Date     Variety        Date 
                                           Variety 
rep.                    24          12           4 
e.s.e.               0.477       0.289       0.660 
d.f.                     6          45       19.78 
Except when comparing means with the same level(s) of 
 Date                                        0.500 
 d.f.                                           45 
  
*** Least significant differences of means (5% level) *** 
  
Table                 Date     Variety        Date 
                                           Variety 
rep.                    24          12           4 
l.s.d.               1.652       0.822       1.950 
d.f.                     6          45       19.78 
Except when comparing means with the same level(s) of 
 Date                                        1.424 
 d.f.                                           45 
  
  
***** Stratum standard errors and coefficients of variation ***** 
Variate: _Rand_ 
  
Stratum                   d.f.          s.e.         cv% 
  
Block                        3         1.999        15.1 
Block.Mainplot               6         0.955         7.2 
Block.Mainplot.Subplot      45         1.000         7.5 



9 Challenge 3  

The design of the experiment in Challenge 1 (page 57) was a randomised 
block design, with the blocks specified in column REP.  Use the analysis of 
variance to find the standard error of the difference between Sesbania 
(code SES) and natural fallows (code NAT) in (a) mean maize yield (b) soil 
nitrate. 


91 season

		Data from Chipata, Zambia

		Screening of suitable species for 3 year fallow

		Treatment		Replication number		Grain Yield		Striga		NITRATE N

						(t/ha)		Striga		(mg/kg)

		TRT!		REP!		YIELD		STRIGA		NIT_N

		SES		1		5.46		1		7.58

		GLI		1		4.50		19.5		6.43

		LEU		1		3.01		8		2.50

		FLE		1		2.68		8		5.32

		SEN		1		1.64		2		1.72

		ROT		1		2.20		105.5		8.98

		NAT		1		2.06		169		2.56

		M		1		1.49		1504		6.53

		CAL		1		2.36		49		4.51

		SES		2		6.35		2		7.02

		GLI		2		5.93		382		4.96

		LEU		2		3.51		9.5		3.17

		FLE		2		4.04		26.5		4.99

		SEN		2		2.43		5		2.78

		ROT		2		3.95		37		10.80

		NAT		2		3.15		173		3.56

		M		2		3.10		312		8.04

		CAL		2		3.62		10		4.40

		SES		3		6.86		0.5		11.70

		GLI		3		4.44		720		7.78

		LEU		3		3.50		10.5		3.10

		FLE		3		3.82		14		8.15

		SEN		3		2.15		1.5		2.84

		ROT		3		3.99		74		9.22

		NAT		3		2.61		245.5		4.66

		M		3		2.01		728		6.79

		CAL		3		2.14		112		4.16

		SES		4		7.18		1		10.72

		GLI		4		4.97		402.5		9.07

		LEU		4		5.83		30.5		4.33

		FLE		4		3.33		876.5		7.21

		SEN		4		2.15		4.5		2.08

		ROT		4		4.12		229.5		11.23

		NAT		4		4.17		53.5		4.16

		M		4		2.04		909.5		6.80

		CAL		4		3.04		76		4.49



&A

Page &P



Wim Buysse
Double-click to open the MS Excel file "Fallow species trial.xls"
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10 Further Reading  

10.1 Other free documentation 

A second part of this guide, called “Further regression and ANOVA using GenStat 
Discovery Edition”, is being produced. As the title says, it includes further information 
on regression and on the analysis of variance. It will be distributed on future versions of 
the GenStat Discovery Edition CD and will also be available from the GenStat for Africa 
website: www.worldagroforestrycentre.org/genstatforafrica  

ICRAF, the World Agroforestry Centre, has prepared a set of notes on the analysis of 
experimental data. These include analyses using GenStat, plus a set of sample data 
files. The materials are on the CD and are also available from the website of ICRAF’s 
Research Support Unit: www.worldagroforestrycentre.org/rsu (under Data Analysis). 
On the same website, under Resources, you find several technical notes. Some of 
them contain additional information on GenStat. 

The Statistical Services Centre of the University of Reading (http://www.rdg.ac.uk/ssc/) 
, has produced a series of “good-practice” guides. They are on the CD and are also 
available on the SSC website: http://www.rdg.ac.uk/ssc/develop/dfid/booklets.html 
They include a guide to help MSTAT users who would like to start using GenStat. The 
Biometry Unit Consultancy Services (BUCS) of the University of Nairobi, in 
collaboration with statisticians from Malawi and Zimbabwe, has produced a guide on 
their strategy for statistical software in their agriculture faculties. They propose the use 
of GenStat for postgraduate students and research. For undergraduates they suggest 
the use of SSC-Stat (an add-in for Excel) and Instat+ (a simple statistics package). In 
addition to GenStat Discovery Edition, the CD also includes both SSC-Stat and Instat. 
Up-to-date versions of these packages may be downloaded from the SSC website. 
Some presentations on the BUCS strategies can be found at 
http://www.uonbi.ac.ke/acad_depts/bucs/presentation.htm The whole BUCS website is 
also available on the CD. 

10.2 The Help menu 

We showed in chapter 2.2.2 (page 10) how to find more information on a subject using 
the GenStat Help. In the example, we saw how to learn more about the different 
spreadsheet formats that can be imported into GenStat. The GenStat help looks and 
works rather similar to many other Windows programs, but if in doubt on how to use it, 
browse first through the “how to use help” menu. Choose Help => How to use help 
and select for instance “To find a topic in Help”. Click on the [Display] button as in Fig.  
10.1 and a help window will pop up containing information on finding a topic in the 
GenStat Help (Fig.  10.2). 

http://www.rdg.ac.uk/ssc/
http://www.rdg.ac.uk/ssc/develop/dfid/booklets.html
http://www.uonbi.ac.ke/acad_depts/bucs/presentation.htm
http://www.worldagroforestrycentre.org/genstatforafrica
www.worldagroforestrycentre.org/rsu
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Fig.  10.1 Learning more about the GenStat 
Help 

Fig.  10.2 The resulting information on how to 
find a topic in the GenStat Help 

 

 

Choosing Help=> GenStat Tutorial opens a tutorial covering similar subjects as in this 
guide but in an interactive way: partly text, partly video, partly interactive pop-up 
windows. Click on the [Main Menu] button (Fig.  10.3) to start the tutorial.  

Fig.  10.3 Starting the GenStat Tutorial 
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You navigate through the tutorial by clicking on different types of buttons (Fig.  10.4). 

Fig.  10.4 Different types of buttons in the GenStat Tutorial and their meaning 

go to a specific section 

start a movie clip about the topic 

open an interactive page about the topic 

On such an interactive page, move the 
cursor over the red dots and a window 
will pop up containing more information, 
in this case about the different menu 
options. 

 

You leave the tutorial by clicking on a [Quit] button, or first by clicking on a [Back] 
button until you see a [Quit] button, and confirming that you want to quit by clicking 
[Yes]. 

10.3 “Hidden” user guides 

And there is more! After installing GenStat Discovery edition, you have somewhere 
hidden on your computer almost 3,000 pages of user guides in pdf format. Pdf format 
stands for portable data format and is a file format that can be read with Adobe Acrobat 
Reader. This software is free and is likely to be on your machine. If not, a copy is 
included on the CD. You can get the latest version at www.adobe.com  

The reason for the fact that those files are not easily visible is that the guides are 
intended to be included in the Help menu of GenStat version 6. VSN International, the 
producers of GenStat, decided shortly before the release of the Discovery Edition to 
also make these guides available for Discovery Edition users but there was no time left 
to change the menus. Although the guides are intended for version 6, most of the 
information is still useful for the GenStat Discovery Edition (which is basically version 
5). Only the sections on graphics are likely to differ. 

If you installed GenStat Discovery Edition in a standard way, you find the pdf-files 
containing the documentation in the subfolder: C:\Program Files\GenDisc\doc (Fig.  
10.5). 

www.adobe.com
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Fig.  10.5 The folder containing additional information 

 

Following table gives an overview of the different documents. 

Introguide.pdf Roger Payne, Darren Murray, Simon 
Harding, David Baird, Duncan Soutar & 
Peter Lane. 2002. GenStat® for 
WindowsTM (6th Edition) Introduction. 
VSN International, Oxford, UK. 276 pp. 
ISBN-1-904375-06-5 

NewFeatures.pdf Roger Payne (Ed.) 2002. New features in 
GenStat® Release 6.1 VSN 
International, Oxford, UK. 95 pp.  ISBN 
1-904375-02-2 

SyntaxGuide.pdf Roger Payne (Ed.). 2002. The Guide to 
GenStat® Release 6.1 Part 1: Syntax 
and Data Management. VSN 
International, Oxford, UK. 492 pp. ISBN 
1-904375-00-6 

StatsGuide.pdf Roger Payne (Ed.). 2002. The Guide to 
GenStat® Release 6.1 Part 2: Statistics 
VSN International, Oxford, UK. 856 pp. 
ISBN 1-904375-01-4 

Refman1.pdf Roger Payne et al. 2002. GenStat®  
Release 6.1 Reference Manual Part 1: 
Summary. VSN International, Oxford, 
UK. 254 pp. ISBN 1-904375-03-0 

Refman2.pdf Roger Payne et al. 2002. GenStat® 
Release 6.1 Reference Manual Part 2: 
Directives VSN International, Oxford, UK. 
396 pp. ISBN 1-904375-04-9 

Refman3.pdf Roger Payne and Gillian Arnold (Eds.) 
2002. GenStat® Release 6.1 Reference 
Manual Part 3: Procedure Library PL14 
VSN International, Oxford, UK. 454 pp. 
ISBN 1-904375-05-7 
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10.4 Non-English speakers 

In the same directory, you find two introductory guides on using GenStat for Windows 
version 5, translated in French and Spanish. GenStat Discovery Edition is exactly the 
same as version 5 except for the graphics. 

IntroFrench5ed.pdf Simon Harding, Peter Lane, Darren 
Murray et Roger Payne. Traduit par 
Gaston Kokodé. 2000. Genstat pour 
Windows (5éme Edition) Introduction 
VSN International sarl, Oxford, UK. 216 
pp. ISBN 1-85206-183-9  

IntroSpanish5ed.pdf Simon Harding, Peter Lane, Darren 
Murray y Roger Payne. Traducido al 
español por Guillermo Hough y Freddy 
Ledezma.  2000. Genstat para Windows 
(5ta. Edición) Introducción  VSN 
Internacional Ltda., Oxford, UK. 216 pp. 
ISBN 1-85206-183-9 

 

Also, the guide that you are reading now is being translated in French and might be on 
the CD already. It will be available on the GenStat for Africa website: 
www.worldagroforestrycentre.org/genstatforafrica  

 

10.5 The GenStat user community 

Finally, there is an informal community of GenStat users who are active trough a 
mailing list. You can read the rules of the list, browse the archives and join the list at 
http://www.bioss.sari.ac.uk/genstat/  

http://www.bioss.sari.ac.uk/genstat/
http://www.worldagroforestrycentre.org/genstatforafrica
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